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CCDciel is a free CCD capture software intended for the amateur astronomer.

CCDciel has all functionality required for advanced imaging of celestial objects including sequences for fully

automated unattended operation. But it is also possible to make simple capture in a manual way.

For devices connection it uses the INDI [http://www.indilib.org/] and ASCOM [http://ascom-standards.org/] standards drivers.

It can control the CCD/CMOS camera, focuser, filter wheel, rotator and telescope mount and uses image resolving

software such astrometry.net for accurate positioning. It can serve both the beginner astro photographer as the

advanced who can take a nap while the equipment is imaging.

You can use CCDciel on Windows, macOS or Linux.

The program is still in beta version but it is now quit stable and run smoothly on every platform 

In any case I will appreciate your help for testing this software and reporting any bug or other problem you may

encounter.

A copy of the program documentation in pdf format is included with the program.

To install the program, look a the specific instructions for your computer and download from SourceForge

[http://sourceforge.net/projects/ccdciel/files/] the version you need, always get the latest version as it is frequently

improved!

The source code is available from GitHub [https://github.com/pchev/ccdciel]

Contact
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Documentation

Tutorial

Start by this tutorial to quickly get an idea how the program work.

The program screen

Connecting the equipment

Global configuration

Focusing

Simple capture

Automated sequence

Reference Manual

This give detailed information on every program aspect.

The pages follow the order of the main menu.

Menu File

Menu Edit

Menu Tools and toolbox

Menu Help

Right click menu

Status bar

Installation

To install the software look at the page corresponding to your computer.

Installation on Ubuntu, Debian

Installation on Linux

Installation on Windows

Installation on macOS

External dependencies

You must install this softwares to take full advantage of CCDciel, at least one of the equipment driver, one for plate

solving, one auto-guider and one planetarium.

Equipment driver

ASCOM

INDI

Plate solving

Astrometry.net

Star Locator Elbrus

PlateSolve 2

Auto-guider

PHD2 [https://openphdguiding.org/]

Lin_guider [https://sourceforge.net/projects/linguider/]

Planetarium

Cartes du Ciel [https://www.ap-i.net/skychart/fr/start]

Hallo Northern SKY [http://www.hnsky.org/software.htm]

Credit

Tools

CCDciel make use of the following development tools:

Free Pascal [https://www.freepascal.org/] compiler

Lazarus [http://www.lazarus-ide.org] IDE and library

BGRABitmap [http://wiki.freepascal.org/BGRABitmap] component

Synapse [https://www.ararat.cz/synapse] library

WCSTools [http://tdc-www.harvard.edu/wcstools/] library

Developer

Patrick Chevalley

Han Kleijn
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License

Copyright (C) 2015-2017 Patrick Chevalley

http://www.ap-i.net/ccdciel

  

This program is free software; you can redistribute it and/or

modify it under the terms of the GNU General Public License

as published by the Free Software Foundation; either version 3

of the License, or (at your option) any later version.

https://www.gnu.org/licenses/gpl.html [https://www.gnu.org/licenses/gpl.html]
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Tutorial

1- The program screen

When you start the program you see the following screen:

On the top you have the standard menu: File, Edit, Tools, Help, and four menus with a icon: Connect, Focus, Capture

and Sequence. The four menus with icons are the same as on the left tabbed menus.

These four tabbed menus are used for connecting the equipment, focusing the camera, take a capture or run a

sequence of operation.

On the left bottom there is the visualisation control for the picture preview and on the right a text log with activity

messages.

The taken or loaded images will be displayed in the middle.

The plate solving functions are available from the image right click menu.

The layout is under Tools customisables for either a small monitor or laptop. For example if you do not use a

motorized rotator, you can uncheck the rotator entry under tools to simplify the Capture tab.

You can drag and drop every tool to another part of the screen. Just hold left mouse button down and drag the tool

title to one of the screen border and drop it by releasing the mouse button.

If you have a large monitor, you can make all the controls visible at the same time without using the tabs.

Next tutorial >>
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Tutorial

2- Connecting the equipment

When you are a first time user, you have to select first the correct equipment drivers and set some settings.

First step is to select INDI interface (typical in Linux) or the ASCOM interface (typical MS-Windows) to communicate

with your camera, mount and any other equipment.

The program will automatically open the File→devices setup menu.

Create a new profile for your equipment.

All the devices and all the program options will be stored in this profile, allowing to have completely different

settings for your different equipments or locations.

Select either INDI

 

or ASCOM interface.

 

Select also the mandatory camera driver and other equipment like mount or focuser but that can also be done

later.

Click okay and program will create a new default profile for your equipment. All the devices and all the program

options will be stored in this default profile. You could later create an additional profile with different settings,

equipment or location.

Next menu will show the default options. The first thing to do is to set the capture folder to something like like in

Linux to /home/username/capture which or for windows from the default C:\ to something like C:\CCDciel

When ready click the OK button.

Select the left tab (pointer icon) and locate the Connect button at the top. The red dot indicates no connection to

any device. Below the connect button you will see the mandatory camera, mount if selected and any other

equipment.
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Click on Connect and after a few seconds the light should change to green if all listed equimpment is connected.

In the connection phase, the indication light will first turn orange and finally green if all equipment is successfully

connected. In case of a connection failure or if an error occurs, the indication light will turn red. All program

activities and errors will be logged, so in case of device connection problem have look to the log for an error

indication.

Devices with a connection problem could be disabled temporary in File→devices setup menu. As a bare minimum

only an imaging camera is required to operate.

Next tutorial >>
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Tutorial

3- Global configuration

You access the global configuration from the menu Edit→Preferences.

All this options will be stored in the current profile.

There are a number of options for every part of the program and many can be examined later.

 

To start it is essential you set:

1. a valid folder for the captured images and

2. your observatory latitude and longitude since they are used in several program functions

Next tutorial >>
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Tutorial

4- Focusing

Manual focus

Point your telescope somewhere high in the sky and set the Preview exposure time and binning. Click on the Loop

button.

If you are way out of focus start first with a long 10-15 seconds exposure time to see some large out of focus stars

disk and move the focuser to reduce the size. If you near the correct focus reduce the exposure time to 1 seconds

less.

Leave the preview looping and click on the Focus tab to show the focuser and star profile

Double click on a star in somewhere the middle of the captured image. Check the recorded star intensity for

saturation or have look to the star profile. The intensity value should be smaller then the sensor maximum value of

typically 65535. In case of saturation select a fainter star or reduce the exposure time. Checkmark the “Manual focus

aid” to magnify the star image.

Use the focuser buttons or manually adjust the focuser to make the star image as small and bright as possible. It

could be beneficial to use a very short exposure time to reduce the seeing and have a quick visual feedback.

When ready uncheck “Manual focus aid”.

Auto-focus

To configure the auto-focus use the focuser calibration wizard to help you set the different parameters specific to

your setup.

Later you can refine them in the auto-focus preferences.

Next tutorial >>
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Tutorial

5- Simple capture

Open the Capture tab and set the required options:

The exposure time

The binning

The name of the object

The number of exposures to take

Be sure the type is Light, other setting may let the shutter closed!

You can also choose to dither between exposures and to regularly adjust the auto-focus.

Dither introduces a small artificial cyclic drift typically required for CMOS sensors when imaging very faint objects. It

helps to smoothen out unequal sensitivity of the individual pixels. Leave his option off in the beginning

Binning combines pixels if they are too small to record any details and reduces noise. Typically you set this on 1×1 or

for large sensors on 2×2.

If you have a filter wheel you can specifiy the filter to use.

You can specify the frame dimensions if you don't want to use the full sensor surface.

If you have a rotator the green/red light indicate if it is calibrated or not. Then you can set the rotation angle.

And if you can control the CCD temperature enter the desired value in Setpoint, and click the Set button.

When all settings are correct click on the START button to start capturing.

The telescope box will indicate the telescope position, the park and tracking status and the remaining time to reach

the meridian.

The status bar shows the image number (count) in progress and the remaining exposure time

After each exposure is finished, the image is shown and the file is saved according the settings. A message in the

status bar indicates the last saved file 

it will continue for the number of exposures (=count) set.

After finishing you could change the filter and start the next series. Or automate it fully using a sequence.

Next tutorial >>
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Tutorial

6- Automated sequence

Sequences allows you to fully automate the imaging. At the sequence tab you can specify all steps required for

unattended operation.

The sequence example on the right will first image the objects M13 and M92, wait for dawn to take some sky flat

and finally park the telescope.

Attached to the M13 and M92 objects is the same LRGB-4H plan specifying 24 images using a luminance filter (L), 8

images using a red filter (R) and finally 8 images using a blue filter (B). All images with an exposure of 300 seconds

and the total duration of the plan is around 4 hours.

After that it wait for the dawn to take a series of sky flat.

The last object in the list is a “Script“ with a plan specifying how to park the telescope.

Running this sequence should keep the equipment unattended busy for around 8 hours.

To take full advantage of this automation you need to configure and test individually:

the astrometry resolver for plate solving and the slewing options

the focuser and autofocus options and calibration

the rotator connection and calibration.

the autoguider connection and preferences

the planetarium connection to help to set the object coordinates

the automated meridian flip options

the flat automatic exposure options

And most important you must be sure your telescope mount and all the equipment include a way to

protect themselves against an unwanted operation. This include hardware slew and tracking limit on the

mount.

You can read more on how to edit a sequence in the specific sequence page.
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File Menu

The File menu includes the following options:

Devices Setup

Bad pixel map

Focuser calibration

Open FITS file

Open picture file

Save FITS file

Open reference image

Clear reference image

Quit

12



Device setup

Open this window from the menu File → Device setup before to connect to any devices.

Interface

 

The first tab “Interface” let you select the kind of drivers you want to use, INDI or ASCOM if running on Windows.

Create a new profile for your equipment.

All the devices and all the program options will be stored in this profile, allowing to have completely different

settings for your different equipments or locations.

The Copy button copy the current profile to a new one, allowing to change a piece of the equipment. 

The New button create a totally empty profile, with no equipment and no options. This can be use to create a profile

for another observatory and be sure to not left behind an incompatible option.

For INDI you have to enter the network name or IP address, and the port of the INDI server, then click the button

“Connect and get devices list” to make the program know which devices are available.

For ASCOM there is no additional information.

Note that the program will close and restart if you change between INDI and ASCOM.

Camera

 

Select the camera to use with CCDciel, from the dropdown list for INDI or using the ASCOM chooser.

A camera is mandatory so you cannot leave this page unconfigured.

For ASCOM you can click the Setup button to access the driver options now before the camera is connected.

For INDI the “sensor” field is to select the sensor to use for dual-chip camera, you probably always want “Main

sensor” here.

Check the corresponding box if you want to automatically load the INDI saved configuration when the device is

connected.

Then select how you want INDI to transfer the image data:

Network the normal transfer mode you can use with local and remote INDI server.

RAM disk may improve the performance if you use a local INDI server. Be sure the path you set point to an in
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memory disk, it 's size need to be two time the size of one of your FITS image.

For INDI the driver options are available from the menu Edit/INDI settings.

Filter wheel

 

Check “Use filter wheel”.

Select the filter wheel to use with CCDciel, from the dropdown list for INDI or using the ASCOM chooser.

Or check the corresponding box if the filter wheel is commanded by the camera driver.

Focuser

 

Check “Use focuser”.

Select the focuser to use with CCDciel, from the dropdown list for INDI or using the ASCOM chooser.

Or check the corresponding box if the focuser is commanded by the mount driver.

Rotator

 

Check “Use rotator”.

Select the rotator to use with CCDciel, from the dropdown list for INDI or using the ASCOM chooser.
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Mount

 

Check “Use mount”.

Select the telescope mount to use with CCDciel, from the dropdown list for INDI or using the ASCOM chooser.

Watchdog

Check “Use watchdog”, select the INDI driver and set the threshold value in minutes.

The watchdog [http://www.indilib.org/support/tutorials/154-securing-remote-observatories.html] is a specific INDI driver that

can park the mount and the dome if the connection is lost with CCDciel for more than the threshold time limit.

There is no similar function when using ASCOM drivers.

Click OK after you finish your setting.
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Bad/Hot pixel map

The bad pixel map will prevent the auto-focus or slewing function locking on a hot pixel rather then on a star.

The bad pixel map will be only applied on preview images, focus or slewing images. It is not applied on captured

images. Those images are not altered.

Use the menu File → Bad pixel map → Apply to current image If you want to apply the bad pixel map to an image

you load in the program.

You have two options to create, using the camera directly or using a processed dark frame. The second option is

preferred because the processed dark as less noise and you can use a lower sigma value to detect fainter deviant

pixels.

Create from the camera

Procedure:

1. Camera should be connected and cooling on if available.

2. Set the required binning in Preview tool. Use the same binning as for the focus and slewing

3. Select an exposure time between 10 and 60 seconds.

4. Cover the camera or telescope similar as taking a dark image. If your camera has a shutter it will remain closed

during the exposure.

5. Select menu File → Bad pixel map → Create from camera

6. Click Continue. A dark will be taken and number of hot pixels will be reported in the log window.

Create from a dark file

Select menu File → Bad pixel map → Create from dark file

Select the dark file from the file dialog.

Clear the bad pixel map

To remove/clear the bad pixel map select the menu File → Bad pixel map → Clear bad pixel map

Check the bad pixel map

Take a preview image and check if the bright hot pixels are suppressed.

Or open a saved raw image and use the menu File → Bad pixel map → Apply to current image

If you still see some not removed hot pixel you can retry the procedure after setting a lower value for sigma.

Possible errors

Error: If you get an error message: “too many hot pixels”, increase the sigma threshold value in the menu Edit →

Preferences → preview options. If successful the program log will report the number of hot pixels suppressed.

. 

A typical threshold value is 5 for CCD and 8 for a modern CMOS sensors. Decrease the threshold value if you want

suppress more hot pixels. Normally you should suppress maybe 5 to 30 hot pixels but you can go much higher.
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Focuser calibration

This function help you to set the auto-focus parameters specific to your focuser, telescope and camera because it is

not immediately evident what to set for all this numbers.

The principle is you start by centering and manually focusing a star that is used by the procedure to find how the

star diameter change with an increasing movement of the focuser.

At the end it propose you new auto-focus parameters you can save to the configuration.

If you use an absolute position focuser it set to use the V curve focusing method and give you the opportunity to

learn a new curve using the same star you already centered in the image.

To start the procedure select the menu File → Focuser calibration

The first screen give you information about centering, focusing and correctly exposing the star.

The next one let you select the direction you want to move the focuser in the auto-focus operations. If the focuser

need a backlash correction you can enter the value now.

Then it offer you to change two measurement parameter, the maximum defocused star diameter (HFD) it will try to

reach, and the initial movement of the focuser in step.

You can change the first parameter if you know what your equipment can achieve, otherwise keep the default and

follow the recommendation if the first try fail. 

The minimum movement is not really important to change because any way the program will double the value until

it see enough change in the star diameter. You can just save a few time if you know your focuser need more steps

even for fine focus.
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It start slowly, just wait until it reach the maximum diameter.

Then it start to move the focuser on the opposite side, much quickly as it know what speed to use.

You can check if the curve is symmetrical and as not evidence of gross error.

You can review the parameters before to click Next to save them to the configuration,

The procedure is completed and you can close this window.

With an absolute position focuser the focusing method is set to Vcurve and now you must learn a new curve for the

new parameters.

The Vcurve learning automatically open, already filled with the correct setting. Do not change any value and just

click the Learn button and after if complete click the **Save* button.
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Open FITS file

From the menu File → Open FITS file.

This let you load a FITS file in the preview window instead of taking the image with the camera.

This is useful if you want to review a previous shot from the capture sequence, or to play with some other image.

Note this is not a multi-purpose FITS file viewer. It is intended to display images from the camera but it could fail

displaying FITS files from other programs.
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Open picture file

From the menu File → Open picture file.

This let you load an picture file in one of the following format: png, bmp, jpg, tif, gif, tga.

This support monochrome picture both 8 or 16 bit per pixel, or color picture 3×8 or 3×16 bit per pixel.

The image is converted in 16 bit FITS format to load it in the preview window.

If you want you can then save to a file in FITS format using the menu Save FITS file.

This is useful if you want to review a previous shot from the capture sequence, or to play with some other image.
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Save FITS file

From the menu File → Save FITS file.

This let you save to a FITS file the image in the preview window.

This is not used part of the capture sequence as the files are automatically saved, but this can be useful to save an

image taken with the Preview function or loaded with File → Open FITS file.

Be careful this Preview image can be processed for bad pixel if you create a bad pixel map.
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Reference image

You can load a reference image of the object you want to capture to adjust the position of the telescope and the

rotation of the camera. This is very useful to continue a sequence over many night.

You can adjust the display threshold and the color of the reference image in the preview options. 

Normally you want the threshold to display only the stars from the reference image.

To load the image use the menu File / Open reference image

Then start a preview loop, it show the new image over the reference.

You can now move the telescope or rotate the camera to match the reference.

When you are satisfied with the result you can remove the reference image from the menu File / Clear reference

image

Tips:

To help to center the telescope open first the reference image with File / Open FITS file. Right click on the image

and select “Resolve and slew to image center”. After the telescope stop slewing process as above to adjust the

rotation.
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Quit

From the menu File → Quit.

Exit the program and save the configuration.

If the devices are connected you are asked if you want to disconnect them.
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Edit Menu

The Edit menu consists of the following items:

Preferences

INDI settings

View FITS header
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Preferences

From the menu Edit → Preferences. Set the global preferences and options for the program.

Files

With this menu you can specify how the image files are named and if they are stored in named folders. A typical

imaging session will produce a great number of files so it is important to preserve the details for later processing.

One way of working is to make subfolders based on object name and select for file names all details; object name, the

filter, a date sequence, exposure time, binning. This is all depending on personal preferences and image processing

software used later.

For folder name you have the choice between two date. One to make a folder with the same UT time as for the file

name, the other is based on local time and change at noon to allow to put all the files for a given night to the same

folder.

For file name, if Date/Sequence is checked the UT date and time is appended. If it is not checked a sequence number

is appended to make the file unique.

You can reorder the different elements with a mouse drag and drop of the sequence number column.

You can change the program language from the list if you prefer to use another language than the one selected

automatically. The program must be restarted after changing the language.

The base capture folder should be specified.

Normally you not need to change the temporary file folder. But this may be necessary in the case astrometry.net

cannot work with the default one.

At the bottom you can select to save all log messages to a file for further inspection or debugging. it is

recommended to always let it checked.

And you can activate a TCP/IP server to get remotely the status of CCDciel

Observatory
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The informations on top will be set in each FITS file for the OBSERVER, ORIGIN and TELESCOP keyword.

The latitude and longitude of the observatory is used to get the Alt/Az position of the object, or for the

scope_alignment script.

The “Horizon profile” and “Minimum observing elevation” are used to compute the object rise and set time in the

sequence planner. If this values are set the rise/set time are relative to this limits.

You can set only one value or both. In the last case the highest elevation is used.

The horizon profile file is the same as the local horizon line in Skychart  [https://www.ap-

i.net/skychart/en/documentation/observatory#horizon].

Preview

This settings affect only the preview, the FITS files are recorded in RAW format to allow further preprocessing.

If you use a color camera you can debayer the preview image by checking the corresponding box and selecting the

color pattern for your sensor. If you don't know what to select, make a test on a colorful subject on daytime. You can

also do some color balance with the cursors on the right.

The reference image help you to frame a previous image, for example to continue a sequence.

Select the threshold and color for the display of the reference image.

The image clipping indicator level. You can set the low and high threshold in ADU for this indicator.

The bad pixel map prevent the auto-focus function to lock on a hot pixel.

Select the threshold for detection of hot pixels for the bad pixel map.

Preview stacking allow you to stack the preview frames in real time. This feature is normally use for demonstration

in public event. 

You can select to disable this option to not risk an unwanted use during your imaging session.

Using a dark frame subtraction before the image addition improve the result quality.

This dark image must always be in 16bit format, even for a 8bit camera.
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Select the preview rate for the video. Video require a suitable camera and is available only with INDI devices.

CCD temperature

Configure how you prefer to cool down and warm up you CCD sensor.

Consult your camera documentation to know if you need to limit the temperature change. 

In this case check “Limit temperature change” and indicate the maximum rate in degree (Celsius) per minute.

Check the corresponding box if you want your camera to start cooling as soon it is connect to the program and

indicate the target temperature you want.

Flat

Configure the method to use to capture a flat series form a sequence.

For the twilight flat it is require to configure the automatic exposure as the sky lightness change a lot during dusk

or dawn. 

You can also configure this automatic exposure for a use with other light source.

The program will adjust the exposure time between the two limits to maintain the image level.

Set the shortest exposure time that give an uniform sensor illumination. This depend on the kind of shutter used by

the camera.

Set the longest exposure time you want for a flat. You have to take the corresponding dark separately.

Then give an image mean level range that make an acceptable flat. Start with 80% of your camera full range but

check there is no saturated part in the center of the flat image, specifically if the vignetting is important.

Focus
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Select the size in unbinned pixel of the star detection area and the size of the zoomed window for the focus mode. If

you use a binning different than 1×1 for the focus operation the window size is reduced accordingly.

If this is not already done by your focuser driver you can activate a backlash compensation.

Indicate the number of additional steps to use for the compensation. this can be greater than the actual backlash.

Indicate the direction the focuser will always finish to move. The best depend on your configuration but be sure to

use the same value as the auto-focus move direction.

If it take some time for the focus position to stabilize after a move you can set a delay to wait after every focuser

movement. This is more likely of use if the motor directly move the primary mirror of a SCT.

If your focuser can measure the temperature you can set here the temperature coefficient (in steps per Celsius)

used to adjust the focuser position between the exposures, or to shift the auto-focus V curve accordingly. The

coefficient is positive if the focuser needs to move UP in position when the temperature drop. The routine will adapt

the focuser if the temperature difference is larger then 0.5 degrees.

Note that for a reflector telescope you typically have to turn the focuser OUT to correct for tube shrinkage. For a

refractor you typically have to turn the focuser IN since the change in refraction coefficient is dominant and much

larger then the tube shrinkage.

The temperature coefficient will help to reduce the number of autofocus actions required. It will work best when

the temperature drops slowly and all parts of the telescope have time to adapt to the changing ambient

temperature.

The compensation factor has to be measured empirical. Start with an almost zero factor=1 and monitor the

autofocus focus position in the log as function of the reported temperature. If you sufficient data points which show

a repeatable temperature coefficient enter the estimated factor in this menu. Some telescopes like a SCT could

have less predictable coefficient and you most likely have to disable the coefficient and rely on the autofocus routine

only.

If the factor is set well, the result of each autofocus routine run should be close to the previous focus position.

For each filter you can also set a focuser offset in focuser steps that will be applied to the focuser when you change

the filter.

The filter exposure factor is used for the auto-focus functions and the automatic sky flat. For example if your R filter

require two time the exposure of the L filter set : L=1 R=2

Auto-Focus
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This section can be hard to fill with the right values for your specific equipment. It is strongly suggested you use the

focuser calibration wizard to set the correct default parameters.

Select the auto-focus method:

V curve: This is the preferred method for an absolute position focuser. By measuring the size of a defocused

star it can accurately calculate the ideal focus position. In advance your system has to be analyzed using the V-

curve learning tool. This routine will measure the star size (HFD value) as function of the focuser position of

your setup. The slope of the two lines left and right of the focus position is constant. Temperature changes,

filters and slippage will only shift the focus but not the slope of the two lines. Once the V-curve (slope) has been

measured accurately and saved using the V-curve learning tool, every auto focus operation will be done quick

and efficient.

Dynamic: This method can be used with relative position focuser. It require you start very near of the focus

position and it make a small V curve every time.

Iterative: A dumb method that move in one direction or another as long the star diameter is smaller. I as the

advantage to work with any kind of focuser and you can start with a very defocused star. But it is slow and

imprecise.

None: If you want to use your focuser only manually.

Common parameters

Exposure time to use for the auto-focus operation. This time is multiplied by the filter exposure factor above.

Binning to use for the auto-focus. Use binning 1×1 unless you are way oversampled.

The move direction of the focuser. Depending on you setting the focuser can work better when moved in or

out of focus.

Autofocus tolerance is the maximum HFDthat can be considered as a successful focus. If the HFD after and

auto focus operation is higher than this value the focuser position is set back to it's previous value.

The minimum SNR of the star during the measurement. If a measurement SNR is higher than this value the

auto focus operation is canceled and the focuser position is set back to it's previous value.

Autofocus star list, select the magnitude of a star that give a good SNR for the auto-focus operation using

the above exposure time. The telescope is moved to a nearby star of this magnitude to run the auto-focus. You

can set here the precision require for the slew to put the star in half the image height. Use a lower precision

than for target slewing to speedup the process.

V curve parameters

Near focus HFD: We move the focuser to get this HFD to make the measurement on the V curve. This is not

the focus HFD, it must be half way on the linear part of the curve. For example if your focus HFD is 3.0 and you

make a V curve up to a HFD of 20.0, you can set 10.0 here.

n.exp : The number of exposure we take to get a mean HFD value. Increase this value if the seeing is not good.

Start focus HFD: The focus starting point on the V curve used to determine the Near focus position. Use a

high value near the top of the V curve but inside the measurement area. A typical value is 20.0.

Slippage correction If your focuser is prone to slippage you can activate a correction here. You must have

configured the filter offset and the focuser temperature compensation, so we can be confident that the

remaining offset is slippage.

The autofocus routine finds the focus in four focus movements using the slope information from the V-curve

learning.
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1. Move beyond the Start focus HFD to (1) taken into account any temperature drift. This to fix any mechanical

hysteresis in your system. 

2. Move to calculated Start focus HFD (2) taken into account any temperature drift. Here a number of

exposures is taken and the average new start HFD is calculated.

3. Based on the average new start HFD of step 2) move using the slope factor to the calculated Near focus HFD

position (3). This (3) will be already adapted to any focus drift and should be spot-on. Take a number of

exposures and use the average new near HFD and slope factor to calculate the new focus position.

4. Move to the new calculated focus position (4).

- If the SNR, signal to noise is too low, the routine is aborted.

- Any focus drift will result in a drift of the new start HFD but not in the new near HFD.

Dynamic parameters

Near focus HFD: the HFD we start to use n.exp exposure to get a mean HFD.

Number of dynamic points: The number of points we take on the curve. Do not set too high as this is done at

every focus operation.

Movement between points: The number of focuser steps we move between each measurement of the curve.

The maximum focuser movement in and out of current position will be (Number of dynamic points)*(Movement

between points)/2

Iterative parameters

Near focus HFD: the HFD we start to use n.exp exposure to get a mean HFD. When the HFD is higher that this

we take a single exposure to speed the process.

Initial movement in focuser steps. This is the movement we use between measurement on the first iteration.

It is then divided by two every time we change the direction.

Final movement in focuser steps. When we reach this movement value we consider we are at the focus. This is

typically the focus tolerance of your optical system.

Astrometry
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Enter the camera pixel size and telescope focal length, or if applicable for your driver, check the box to get it

automatically.

You can also adjust the timeout (in seconds) for a solve operation.

Select the software you want to use for the astrometry resolution of the images, you can use astrometry.net

[http://astrometry.net/use.html] , Elbrus star locator [http://www.astrosurf.com/pulgar/elbrus/elbrusin.htm] or PlateSolve 2

[http://planewave.com/downloads/software/].

For each software you can adjust a few option to make them work quickly and reliably with your images.

Astrometry.net options

Maximum search radius: Is a tolerance in degrees to the telescope position. Set this value high enough if you

use the plate solving to make a pointing model.

Scale tolerance: The tolerance on the pixel scale derived from the focal length and pixel size.

Downsample: the image by this factor. Use at least 4 or 8 for DSLR images. For CCD it is better to use binning.

Maximum number of source to consider.

Create plot of the result: create png image with indication useful for debugging.

Other options: any other option you want to give to the solve-field command.

Use custom script: Use a script instead of the solve-field command. There is two example with the program,

one for remote execution using ssh, the other for remote solving with the astrometry.net python script.

On Windows only, you need to specify the Cygwin path to where astrometry.net is installed, for example

C:\cygwin. See the installation instruction for more details.

Elbrus options

Elbrus images folder: the folder where Elbrus wait for new images to solve.

Images folder Unix path: Unix only, the unix path corresponding to the previous one where CCDciel save the

image for measurement.

PlateSolve 2 options

Program folder: the folder you install the PlateSolve2 program.

Wait after solve: the number of second the PlateSolve2 window remain visible after solving is complete.

Slew

You can adjust how to correct the mount position after plate solving a control picture. 

If your mount allow to sync anywhere select “Mount sync”, if not select “Pointing offset” to make the correction in

software.

Use “Pointing offset” with EQMOD to not fool the pointing model.

Then set the precision you want/can reach and the maximum number of pointing/correction retry before to give up.

Set the parameters (exposure time, binning and filter) for the control exposure. This must give enough stars with

your telescope/camera combination for the astrometry resolver to work.

If your mount need some time to stabilize after the movement you can increase the delay to wait before to take the

plate solving picture.

Meridian
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Configure here what you want to do when the mount reach the meridian.

Do nothing: select this option if your mount is not affected by the meridian (fork mount).

Automatic flip: automatically do a reversal of the mount to continue to track past meridian.

Abort: abort the current capture and stop the mount.

Automatic flip options

Can track past meridian for: the number of minute your mount can safely track past the meridian without

flip. This depend on the declination, set the smaller value here.

No flip until past meridian for: the minimum number of minute after the meridian we wait before to initiate

the flip. This two parameters allow to loss the minimal time during a capture sequence, otherwise you can wait

for a long as a single exposure time.

Autofocus after meridian flip: In some case the focus point can move after a flip.

Calibrate autoguider after meridian flip: If your mount do not report the side of pier to the autoguider you

must check this option.

Pause before meridian flip:

Pause after meridian flip: this two checkbox give you a prompt before or after the flip to let you the time to

do some manual operation on the mount (moving the counterweight for example).

Timeout: The maximum time we wait for the after meridian pause, if you not close the prompt after this time

the sequence continue automatically.

Autoguider

Select your autoguiding software, this can be PHD2 [https://openphdguiding.org/] or Lin_Guider

[https://sourceforge.net/projects/linguider/].

For PHD2 you need to set the network name of the computer running PHD2 and the port number.

Set the options for dithering between the exposure, the number of pixel (in the guide camera) and if you want to

dither only in RA (if you have a lot of DEC backlash).

The settle tolerance define how we consider the autoguiding as good after a dither operation or after it start.

It must stay within the number of pixel for Min.time. But we wait for the maximum of Timeout if this is not possible.

Set also the maximum time to wait if a new calibration is required.
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In the case of guide star lost (passing clouds…) we can try to restart the guider after some time. This is useful if the

star as moved out of the search area, but if the clouds are still there we can start guiding on a hot pixel. A value of

zero disable this function.

Then we can abort the current sequence after some time, maybe the next object on the plan is in a clear area.

For Lin_Guider you can choose to communicate by a local Unix socket or by the TCP network, on Windows only the

TCP option is available. The selection must correspond to the one in the Lin_Guider general setting.

The Star lost and Settle tolerance options are not used by Lin_Guider.

Planetarium

Select the planetarium application you want to use.

You can use the planetarium to select a target, or to display a solved image or image frame.

You have the choice between Skychart  [http://www.ap-i.net/skychart]. HNSKY [http://www.hnsky.org/software.htm], or a SAMP

[http://www.ivoa.net/samp/] application like Aladin [http://aladin.u-strasbg.fr/aladin.gml] or Topcat

[http://www.star.bris.ac.uk/~mbt/topcat/].
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INDI settings

From the menu Edit → INDI settings.

This menu is not active if you select the ASCOM devices interface.

This open a standard INDI client  [http://www.indilib.org/] window where you can set any specific option for your devices.
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View FITS header

From the menu Edit → View header.

Show the FITS header of the current file.
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Tools Menu

The Tools menu let you select the tools you want to include or not in your screen.

Check or uncheck each tool to make it visible or not.

You can also move each tool on another part of the screen to suite your need just by dragging the tool title to one of

the main window border.

It includes the following options:

Connection

Preview

Autoguider

Planetarium

Script

Focuser

Star profile

Capture

Filters

Frame

Rotator

CCD Temperature

Telescope mount

Sequence

Video

Visualisation

Messages

Clock

Reset to default

By default many tools are grouped in four tabs on the right of the window.

This correspond to the main functionality for a capture session.

Connection and preview

Focusing

Simple capture

Automated sequence

You can use the keyboard F1 to F4 to select one of the tabs.

This same function are also available from the main menu:
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Connection Tool

This tool let you connect or disconnect your equipment and monitor the status.

It is a mandatory tool as the first thing to do after starting the program is to click the Connect button.
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Preview Tool

This tool is to take a preview exposure for focusing or centering purpose.

Set the exposure time and the binning to use for the preview. 

You can also change the gain or the “ISO” if the camera support this setting

This setting is totally independent of the Capture setting.

Click Preview for a single exposure or Loop to take exposure continuously until you stop it with the same button.

The light change to green when the loop is active.

If you activate the “preview stacking” in the preferences you also see a Stack check-box.

When it is checked, every preview frame is added to the previous ones. 

If a bright enough star is present the frames will be aligned on this star.

After you start the Loop, you see the object image to appear progressively in the screen as the number of frame

increase. This function is often use in public demonstration.

You can use the menu File/ Save FITS file... to record the stacked image after you stop the Loop.

A new stack is started when you start the Loop, or after you take a preview without this option.
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Autoguider Tool

This tool is to interface with the external autoguider.

Start the autoguider application and then click the Connect button.

It show the autoguider status and let you to start or stop autoguiding, force a new calibration, or dither.

This functions are used automatically by the sequence tool when the autoguider is connected.
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Planetarium Tool

This tool is to control the connection to the planetarium.

It is used to display an astrometry resolved image with the right click menu, or to set the targets coordinates in the

sequence preparation.

Click the New target button, click or search an object in the planetarium, then click OK.

This make a plate solved slew to the object position and set the object name in the Capture tool.

You must have a camera and mount connected before you can use this function.

The same box is used in the sequence editor to set the target coordinates.

Note that the target coordinates are apparent and could differ from the planetarium if the planetarium displays the

position in equinox J2000 coordinates.
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Script

This tool let you create or run a script

The scripts can be used to automate some task in CCDciel or to interface with external program for example to

manage your observatory and equipment.

The same scripts can be used as a step in a sequence, or in specific conditions, but this box is a convenient way to

create, test and quickly run any script.
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Focuser Tool

With this tool you can control your motorized focuser manually. The control are adapted if you use an absolute or

relative focuser. The temperature is reported if available.

With a relative focuser you can set the desired movement in steps, then click the arrow buttons < > to move the

focuser in or out.

With an absolute position focuser you can set the movement as with the relative focuser, or set an absolute position

and click Move to.

The button V-learn start the V-curve learning.

V curve learning

If you not already do it, it is strongly suggested you use the focuser calibration wizard to set the correct default

parameters before to use this procedure.

Introduction

In case you have an absolute position focuser and want to use the V-curve auto-focus you have to run the V-curve

learning routine first.

The routine steps the focuser and measures at several positions the size (HFD value) of a star. This will result in a

typical V-curve of two lines left and right of the focus point, The slope of the lines will be used later in the autofocus

routine for finding the focus. in this screenshot the routine will step from position 12186+800 to position 12186-800.

The focus position shown as 12186 should be approximately the best focus position. The maximum offset 800 as

shown should be selected such that the HFD value at the beginning and end is above the Start HFD focus=20 so in

this example 25.

Steps to follow

If you are using filters, select the luminance filter. Start an preview loop of about one second exposure and center on

and select a bright star. Run the manual focus aid and check if the peak intensity indication is about 80% of

saturation level using the star_profile tool. If not adapt the exposure accordingly or select an other star.

Be sure to stop the preview loop and press the V-learn button
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The first time you launch this tool all the settings and graphic are empty.

Indicate the most accurate focus position you can estimate, as you make a manual focus just before you can click the

Get current button here.

Set the Max offset value such that moving to the best focus position plus this offset give a defocused image with an

HFD around 25.

Set the number of step to 30, this is a good value that allow for precision curve. But for the first try you can save

some time by setting it to 10. Just remember to repeat with 30 when you are accustomed with the procedure.

When this three numbers are set click the Learn button on the bottom.

This curve is slowly build up until the procedure is finished. Progress in is also reported in the Log and Star profile

tools.

After the measurement are completed the curve should look as in the screen shot here. The graph shows the HFD

value as function of the focuser position.

Check the following important points before you continue:

The curve must be centered with top left and right about at the same level focus in the middle.

It must extent to about the double of the value of Near focus HFD in the options, indicated by a blue line here.

The two branches of the V must show a long linear part, specifically on the side of the base of the focus

direction arrow (right on the screen shot).

The branches must not flatten on the top. If you remark such behavior you must reduce the Max offset value.

The move direction should be such that the learn routine moves the focuser in the same the direction as you

have to adjust the focuser manually during the night when it is cooling down. If not change the direction in

settings. For a reflector (mirrors) type of telescope you typically have to turn the focuser out if the

temperature drops. For a refractor (lenses) type of telescope you typically have to turn the focuser in.

At the center of the V with the points marked in red. 

It is important to exclude this points from the linear regression and you can use the Fit cursor to exclude more or

less points.

When you adjust this cursor, look to maximize the Quality value on the right but also check the aspect of the black

regression line across the green circles. The linearity must be specially good at the intersection with the blue line.

When you are satisfied by the result click the Save button. This will save the curve parameters and mean

temperature for use in the auto-focus routine.

You can now try the Autofocus in the Star profile tool.
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Star profile Tool

With this tool you can check the focus or start an autofocus run. It can be used with motorized focuser or manual

focuser.

Make first a preview exposure and double click on a non saturated star.

The top curve is a cross-section of the star image. Try to make it as narrow as possible.

Below the previous relative HFD measurement in red and the intensity in green.

The HFD (Half Flux Diameter) unit is pixels.

The FWHM (Full Width at Half Maximum) units are pixels and arc-seconds.

Optimum focus is reached when HFD and FWHM are at minimum.

The star peak intensity should be not be saturated.

Click Manual focus aid to start a preview loop on the selected star area. See zoomed

Click Autofocus to start the auto-focus procedure on the selected star. You must have configured the auto-focus in

advance and if applicable run the V curve learning tool and saved the result.

When the autofocus is running it show a plot of the HFD versus the focuser position. The aspect of the plot depend

on the selected focusing method.

Vcurve Dynamic Iterative

If you move the mouse over the graph it display the values of the focuser position and HFD.

You can click a button to not close the graph when the auto-focus is completed to let you more time for

examination. Click the button again to close the graph.

Click Image inspection to detect the stars in your image and indicate the HFD for each and plot a tilt indicator in

the image.
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The tilt is indicated in the log as % ratio between the best and worst corner median values. In addition as an

graphical indication it draws an trapezium in the image based on the four median values.

There can be some variation in images of the same series, so a tilt of maybe 20% looks normal but anything more

indicates a camera mounting problem.
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Capture Tool

This tool is to take a series of exposures.

Set the exposure time, the gain if supported, and the binning to use.

Enter an object name. The object name will be used for the file name and stored in the FITS header at keyword

OBJECT.

Set the number of consecutive exposures to be taken.

Select the type of frame: Light for sky exposure. Bias, Dark, Flat for the calibration. This selection will be used for the

folder name and stored in the FITS header at keyword IMAGETYP. If your camera has a shutter, it will be closed for

Bias and Dark.

If dithering is required, put a checkmark and enter the image interval. Dithering requires the autoguider to be

connected, configured and guiding from the Autoguider tool before you start capturing.

if autofocus is required, put a checkmark and enter the image interval. Autofocus must have been configured in

auto-focus and V curve learning should have been run and result saved. For autofocus the telescope will

automatically slew to a database star of configured magnitude. The slew to and return will only work accurately if

you have configured the plate solver and slewing options.

Click the Start button to begin the exposure series. The same button can be used to interrupt the series.
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Filter Tool

With this tool you can control your filter wheel.

It will show the currently mounted filter.

To change the filter, select one from the list.
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Frame Tool

This tool is to set the sensor area used for imaging.

The first row is the horizontal starting point and width.

The second row is the vertical starting point and height.

You can set the values with the mouse on a preview exposure. Press the Shift key and the mouse left button to draw

the frame.

Click the Set button to send the values to the camera.

Click the Reset button to reset to full frame.
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Rotator Tool

With this tool you can control your motorized rotator.

To rotate to a new position type the new Position Angle and click Rotate.

Check Reverse if your optical configuration require to reverse the rotation to match the celestial position angle.

The light is red when the PA field is the rotator raw value without calibration.

Use the right click menu Resolve and sync the rotator to calibrate the rotation angle. After that the light is green

and PA field indicate the celestial position angle.

The last calibration is restored when the rotator is connected.
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CCD Temperature Tool

With this tool you can set the camera cooling setpoint and read the current imaging sensor¹ temperature.

To start cooling, enter the temperature Setpoint (target) and click on the Set button. Automaticaly the Cooler

check mark wil be checked.

To stop cooling un-check Cooler

If you have configured a maximum temperature rate the button text change to “Cancel” to let you cancel the

current temperature change.

¹) CCD or CMOS imaging sensor.
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Telescope Tool

This tool display the current telescope RA/DEC position, the side of pier if reported by the driver, the time to or from

the meridian.

You can park or unpark the mount using the corresponding button.

The Track button start the mount tracking.

Use the planetarium or the sequence tool if you want to move the telescope at a new location from CCDciel.
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Sequence Tool

This tool is to control a complex sequence of exposure on one or more objects.

The top grid show the current list of targets.

You can Load an existing file with a list of target, create a New one, Edit the current list, Copy to a new list or Delete

a list.

Use the Start and Stop button to start or interrupt a sequence.

When the sequence start it first check if the autoguider and camera cooling are available and try to start them if

not.

The “Run unattended” check box control how the program react in case of error.

If is not checked a message prompt you on the screen what you want to do.

If it is checked the operation is canceled.

The bottom grid show you the plan for the current target.

When the sequence is running the current target and step is highlighted.

Target editor

Add a target

52

https://www.ap-i.net/ccdciel/_detail/en/documentation/tool_sequence.png?id=en%3Adocumentation%3Asequence
https://www.ap-i.net/ccdciel/_detail/en/documentation/target_editor.png?id=en%3Adocumentation%3Asequence


After you click New or Edit, the target editor let you modify the target list.

A target can be an object you want to take the images or a script to run in the sequence.

You can type the object name and coordinates in the corresponding box or click the Planetarium button to select the

object in the connected planetarium application. 

The coordinates can also be selected by plate solving the current image.

Or click the “No move” button to not change the telescope position.

Note that the target coordinates are apparent and could differ from the planetarium if the planetarium displays the

position in equinox J2000 coordinates.

Select the exposure plan to apply to this target using the dropdown box, or use the New button to create a new plan,

or the Edit button to change the plan. You can also copy an existing plan or delete one.

The plan are saved in separated files and can be shared by many target list. This way you not have to edit the detail

of the plan every time.

If you are imaging a fast moving asteroid or comet you can check “Update RA+Dec” to ask the planetarium for the

object coordinates just before the telescope is slewed to the target.

Be sure the planetarium is connected before to run the sequence.

Check the name of the object is compatible with the search function of the planetarium. No problem if you set the

coordinate and name from the planetarium.

The planetarium must be set to follow the system time, otherwise the asteroid position is not updated.

Check “Use astrometry…” box to refine the telescope position with an astromery solved control exposure. In this case

you are ensured the selected object is framed exactly as required.

You can check “Stay in place for autofocus” if you are sure that the center of the image field contain a suitable star

for auto-focus.

If unchecked or if the in place focus failed, the telescope is first moved to a focus star of the magnitude defined in

the auto-focus preference, and returned to the target after the operation.

Check “Set rotator angle” to move the rotator at the specified angle. 

You can type the position angle or use the current image orientation after plate solving.

Be sure the rotator is calibrated before to start the sequence if you use celestial PA.

Set the start and end time

You can set a time range for this target to be imaged, it will no be images before “Start time” or after “End time”. If

“End time” is reach during exposure plan it is stopped and the next target is selected.

Click “rise” or “set” to automatically use the rise or set time of the object above the limits you define in the

Observatory configuration, for the date of the observation.

To not use this function click the “Any time” button.

You can also define when the whole sequence start and stop.

Check the box “Start at” or “Stop at” and enter the time you want.

Check “dusk” or “dawn” to adjust the time for the astronomical twilight for the date of the observation.

Repeat a target

You can set this target to repeat it's whole plan for a number of time at a given interval between two consecutive
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start.

Set the number of repetition and the interval. If the interval is smaller than the total plan duration the next

repetition start immediately. 

You can also start a preview loop while waiting for the next repetition, this is useful to keep the Sun or Moon

centered if you do an eclipse sequence.

Add a script

To add a script you just have to select the one you want from the list, or create a new script here.

Add an automatic flat

To add an automated flat click the Sky flat button.

Set if you want the flat series to be taken at dusk or at dawn, this change the position in the list.

Select the number of flat to take for each filter, the binning and finally check the filters to use.

The automatic exposure time must be configured in the flat preferences.

To better manage the changing sky luminosity the filter are selected from the darker to the lighter at dusk, from

the lighter to the darker at dawn. This require you configure the filter exposure factor.

When you add a sky flat to the plan this disable the “Start at dusk” and “Stop at dawn” global options. Do not re-

enable them otherwise the sequence will not run during the twilight and the flat are bypassed.

For the same reason you must be careful the sky flat remain in first or last position in the list. The only acceptable

steps before or after them are script to manage the equipment because they will run in full daylight.

Repeat the whole sequence

You can also repeat the whole list a number of time by checking the box at the bottom of the list.

There is no option for the interval here, the repetition is immediate. But you can add scripts in the sequence to delay

the execution in a more flexible way.

Manage the target list

You can add a new target, script, flat or delete one with the four buttons at the bottom of the list.

You can change the target order with a mouse drag/drop on the first column of the list.
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The target list is saved when you click the Save button. If this is a new one you are asked for a file name.

Plan editor

Add a step

Use the plan editor to specify the exposure steps to take of a target.

Give a description of the step that can be used to make a subfolder.

Set the type of frame, exposure time, gain, binning, number of exposure, as in the Capture tool.

Set the filter to use as in the Filters tool.

Check corresponding box if you want to run an auto-focus at the start of this step. 

For long steps you can also repeat the auto-focus after a given number of images.

Repeat a step

You can repeat the same step at a specified interval. Set the number of repetition and the interval.

If the interval is smaller than the step duration the repetition is immediate.

Manage the steps

You can add a new step or delete one with the two button at the bottom of the list.

You can change the steps order with a mouse drag/drop on the first column of the list.

The plan is saved when you click the Save button.
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Video tool

This tool is only available for INDI camera with video stream capability, specifically on Linux and Mac. 

Because of the way INDI record the video, the file is written on the computer running the INDI server.

The video tool appear in a new tab after the Sequence if the INDI camera you connected as video stream capability.

You must first set the preview rate in the Preview options. Do not use a too high value as this preview frames have to

transit by the network.

Check Preview to visualize the frames.

Select the exposure range in the drop down box then adjust with the cursor.

Depending on the camera there can be other settings for the Gain, Gamma or Brightness.

The More settings button open the INDI client for this camera, this let you to access some properties specific to

your camera.

Two more drop down list are to select the image size and the frame rate.

Next are the video capture options, you can limit the capture time or the number of frames.

The object name is use for the filename the same way as the static images.

Click the Start to start recording. The recording to the video file is alway directly done by the INDI driver without

any action from CCDciel.

Use the Stop button if you want the stop the recording before the planned end.
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Visualisation Tool

This tool is to control the aspect of the preview image. None of the setting here have any influence to the image

saved as a FITS file. They are only to help you to view the most of detail on the single raw images.

It is separated in two part, an histogram of the image and the control buttons.

On the top left, two rows of buttons are to control the range of histogram drawing, using from 90% to 98% or the

full histogram range. Reducing the histogram range help to see faint nebulae in the image.

Bellow you can adjust the Gamma value for the display. This also help to better see the faint part of the image but

without saturation of the bright area.

The four right button are preselected zoom level for the image.

You can also get other zoom level using the mouse wheel rotation

When the zoomed image is bigger than the screen you can move it with the left mouse button.

On the histogram you can move the high (green) and low (red) clipping bar with the mouse.

You can also directly edit the low and high threshold by moving the mouse cursor to the top left or right to display

the edit box.

The bull eye button show the mark on the image. If the image is plate solved it also display an arrow with the North

and East direction and print the image rotation angle.

A focus star can be automatically selected in the square that circumscribe the external circle.
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The (i) button let you check for saturation in the image.

The overflow in the highlight area is marked in pink.

The clipped shadows area is marked in yellow.

You can define the clipping level for your camera in ADU in the preferences, the default are 0 and 65535.
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Logging

This text window will report all messages (Log) from the program and drivers.

If configured, the messages (log) will be also stored in a text log file for further study. It essential to use this option if

you let the program run unattended.

The file location is:

Linux:

/home/[your user name]/.config/ccdciel/Log

Windows:

C:\Users\[your user name]\AppData\Local\ccdciel\log

Note that above folders are typically hidden.

The Help menu provide a quick access to this folder and the current log file.
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Clock

This tool show the current local time in the menu bar.

This is useful if you not have another clock on the computer screen but you may want to disable it if you use some

remote desktop display on a slow network.
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Help

Some help to use the software.

PDF documentation open the PDF documentation installed with the software

Online documentation open the documentation in a web browser

Show current log open the current log file using the default text editor

Browse log files open the log file folder in the file explorer

Report a problem open the CCDciel bug tracker

Download latest version open the SourceForge download page. Ignore this entry if you use a package from

your Linux distribution.

About show the program version and copyright notice.
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Right click menu

Right click on the preview image to show the following menu:

Plate solving functions

The image will be resolved (plate solved) and if successful, the image position, pixel size and orientation will be saved

in the FITS file.

A second resolve request for the same image will use the saved solution, for example you can first show the image in

the planetarium, and then slew to cursor without running the plate solver again. 

Once the image is resolved the astronomical position of the mouse cursor will be displayed at the left bottom status

bar in apparent coordinates.

Resolve

Resolve the image using the astrometry software and load the solved image in the preview.

You can show the RA/DEC of the cursor by moving the cursor on the image.

If you save the FITS file now it will include the astrometry solution.

Resolve and Slew to image center

Resolve the image using the astrometry software and if the resolution is successful move the telescope at the

position of the image center.

This useful to center the telescope on an image taken on a previous session.

Resolve and Slew to cursor

Resolve the image using the astrometry software and if the resolution is successful move the telescope at the cursor

position.

Can be useful to refine an object position but be careful of the mount backlash.

Resolve and Sync the mount

Resolve the image using the astrometry software and if the resolution is successful Sync the telescope at the

current position.

If you use Eqmod for your telescope driver, this can be used to set the alignment points.

Resolve and Rotate

Resolve the image using the astrometry software and if the resolution is successful set the rotator angle to match

the image orientation. The rotator must be calibrated before this function can work reliably.

Resolve and Sync the rotator

Resolve the image using the astrometry software and if the resolution is successful calibrate the rotator angle to

match the celestial position angle.

Resolve and show image in planetarium
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Resolve the image using the astrometry software and if the resolution is successful view the image in the

planetarium.

Resolve and show image frame in planetarium

Resolve the image using the astrometry software and if the resolution is successful center the planetarium at the

position and draw a frame of the CCD field.

View last resolver log

You can take a look at the output log of the astrometry resolver to help to solve a problem or to refine the

performance.

Preview functions

The default display mode for bayer matrix color images is set in the preview preference. You can switch between the

two mode with this menu.

Preview debayer

Debayer and display the color image if the current image is a raw color image with bayer matrix.

Preview raw

Display the raw image in black/white.
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The status bar

The status bar at the bottom of the program window show a number of information.

On the right, three lamp indicate the status of the planetarium, autoguider and devices connection.

When a capture is running the status bar show the sequence number and the remaining time of the current

exposure. On the right it show the name of the last saved image and the size of this image.

When a preview is running it show the remaining time of the current exposure, the time of the currently displayed

preview and the size of the image

The left part of the status bar show information for the image at the mouse cursor position:

- The X/Y image coordinate of the cursor.

- The pixel intensity.

- The HFD and FWHM of the star under the cursor

- If the image is plate solved it also show the Right ascension and Declination of the cursor position, using the

apparent coordinates if the telescope mount use the coordinates of the date, or J2000 if the telescope use this

system. It show the apparent coordinates if no telescope is connected.
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TCP/IP server

If you activate the server in the preferences you can connect locally or remotely to get informations about the

program.

The program listen on port 3277 and use the following command:

status Return the devices connection status

sequence Return informations about current sequence

capture The capture informations in the status bar

log The last 10 lines of the current log

quit disconnect from the server

For example:

$ telnet localhost 3277

Trying ::1...

Trying 127.0.0.1...

Connected to localhost.

Escape character is '^]'.

OK! id=1

status

Planetarium connected, Autoguider guiding, Devices connected

sequence

Targets: test1 Plan: L-3x2 Start step R

capture

Seq: 2 Exp: 19 sec. Saved /home/pch/Capture/M13_Red_20180217_161453.fits 1392x1040

log

17:13:46:Saved file /home/pch/Capture/M13_Red_20180217_161346.fits

17:13:46:Starting Light exposure 2 for 20 seconds

17:14:07:Saved file /home/pch/Capture/M13_Red_20180217_161407.fits

17:14:07:Starting Light exposure 3 for 20 seconds

17:14:27:Saved file /home/pch/Capture/M13_Red_20180217_161427.fits

17:14:27:Stop capture

17:14:33:Start step R

17:14:33:Start capture

17:14:33:Starting Light exposure 1 for 20 seconds

17:14:53:Saved file /home/pch/Capture/M13_Red_20180217_161453.fits

17:14:53:Starting Light exposure 2 for 20 seconds

quit

Connection closed by foreign host.
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CCDciel Script

The scripts can be executed from the script tool or part of a sequence.

There is also standard script that are executed on defined occasion:

startup is executed when the program in launched, even before any device is connected. This is the place you

can automatically connect the devices, the autoguider and the planetarium.

shutdown is executed when the program is closed.

end-sequence is executed when a sequence is terminated normally. This is the place you can warmup the ccd

and park the telescope. This script is not executed if you click the Stop button in the sequence tool.

unattended_error is executed when a sequence is aborted, you can do the same as in end_sequence and add

more cleanup. This script is not executed if you click the Stop button in the sequence tool.

The script language is very powerful and allow for complex tasks.

But this can also be as simple as sending a list of command to different devices.

There is limitations if you use an ARM processor for example with a Raspberry PI device. In this case some function

are not working, specifically the command that require a TStringList.

Script editor

The editor allow to write a script .

The language to use is Pascal Script  [http://en.wikipedia.org/wiki/Pascal_Script], based on Object Pascal

[http://en.wikipedia.org/wiki/Object_Pascal].

Define first the global variables, then the procedure and function if any, then the private variable, and finally the

main code start with begin and end with end.

Read the script example page for a quick start.

The functions specific to the interface with CCDciel are described in a separate script reference page.

Use the Save button to record your change and return to the main window.

The top button are related to the debugging function as describe below.

Script debugger

Simple debugging function are available to test your code.
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To run the script in debug mode press the green arrow Run button. The program is first compiled.

In case of compilation error, the corresponding row is highlighted in yellow, and the error message is show in the

bottom message area.

If the compilation finish without error the program start to run and stop on the first code line of the main

procedure. The current execution position is highlighted in blue.

You can now use the Step over button to execute your program line by line.

The Step into button do the same, except if the current line is a call to one of your function. In this case Step into

allow to run the function line by line, but Step over execute the function and stop at the main program next line.

You can also set a breakpoint on a specific line to jump directly at this position.

To set a breakpoint click on the leftmost column to show a red icon.

Use the Run button to jump to the next breakpoint. The current line is then highlighted in red.

You can remove a breakpoint by clicking on the red icon or all at at time with the Remove all breakpoint button.

You can display the value of variables when the program is in pause at a breakpoint or after a Step over click.

Just click on the variable name anywhere in the program source to display the value in the message area.

Note this work only for local variables, not for object properties.

You can use the Pause button to pause the program execution. This can be useful to examine the condition of an

infinite loop for example.

The Stop button terminate the program execution immediately.
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Script example

This page give tips and example of scripting functions.

You can also look at the template code provided with the program.

For more details about a specific function see the script reference page.

Generality

We first look in detail at the code of the scope_unpark script you can use to unpark the telescope. To open this script

locate the script tool, select “scope_unpark” in the dropdown list and click the Edit button.

This cover many programming basis.

The full script code look as following:

{

  This script unpark the telescope mount

}

 

var ok,parked: boolean;

    arg: TStringList;

    r: string;

begin

 

  // telescope connected?

  GetB('TELESCOPE_CONNECTED',ok);

  if not ok then begin

    logMsg('Telescope not connected!');

    exit;

  end;

 

  // get park status

  GetB('TELESCOPE_PARKED',parked);

 

  if parked then begin

    getSl('STRL1',arg);

    arg.clear;

    arg.add('OFF');

    r:=cmdArg('TELESCOPE_PARK',arg);

    if r<>msgOK then logMsg('Telescope park: '+r);

  end

  else begin

    logMsg('Telescope already unparked');

  end;

end.                                            

Take a look at each part in detail:

{

  This script unpark the telescope mount

}

Is a comment, you can use // {..} (*..*) to enclose your comments.

var ok,parked: boolean;

    arg: TStringList;

    r: string;

Define the variable we use later in the script.

Important variable type are: integer, double, string, boolean.

The Tstringlist type is use here to send a command argument to CCDciel.

  begin

The start of our script.

GetB('TELESCOPE_CONNECTED',ok);

We ask CCDciel about the status of a boolean variable to know if the telescope is connected, the result is in our

variable ok.

  if not ok then begin

    logMsg('Telescope not connected!');

    exit;

  end;

We test the result of the previous command, ok is true if the telescope is connected, so we add the negation “not” to

test for “not connected”. If the result of the test “not connected” is true we execute the code block starting at

“begin” up to the corresponding “end”, this write a message in the log and exit the script.
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GetB('TELESCOPE_PARKED',parked);

We continue and we do the same to check if the telescope is parked, with the result in our parked variable..

    if parked then begin

We test if the telescope is parked, in this case we can unpark.

GetSL('STRL1',arg);

arg.clear;

Request a TStringList object identified by STRL1. We clear any data that may stay in the object. We need this

TStringlist to pass argument to a CCDciel command.

    arg.add('OFF');

    r:=cmdArg('TELESCOPE_PARK',arg);

Add the argument 'OFF' for the command and execute 'TELESCOPE_PARK' 'OFF'. This effectively unpark the

telescope and the result is in variable r.

if r<>msgOK then logMsg('Telescope park: '+r);

We test the result is different than msgOK, in this case we write a message to the log to show the error from the

driver.

 end.

The end of the script.

Open a document

The following code open an html page in the default web browser.

You can use any document type with this function, the document open with the default application the same way as

if you double click the document in the file explorer.

begin

  OpenFile('document.html');

end.

Run a command

There is three different way to run an external command or program, depending if you want to wait for a result or

the command completion or not.

No wait

If the command can run for an undetermined time or do not produce an output you need to use the following form.

This example run the Skychart program and exit immediately without waiting you exit Skychart.

begin

  Run('skychart');

end.

Wait until the end of the command

If you need to wait the end of a command but it only produce an exit code to signal success or failure you can use

the following form.

begin

  if runWait('/bin/bash -c open_dome.sh') then

    logmsg('Dome opened')

  else

    logmsg('Fail to open the dome')  

end.

Wait for a result

The following command run the DIR command in the current directory. The result is stored in a stringlist and the

first entry is show in the log.

var r:TstringList;

begin

  GetSL('STRL1',r);

  r.clear;

  RunOutput('dir',r);

  logmsg(r[0]);

end.
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Script reference

This page contain reference material for scripting functions.

See the script description page for general information.

See the script example page for a quick start with the programming functions.

Script language

The language to use is Pascal Script  [http://en.wikipedia.org/wiki/Pascal_Script].

For a complete reference of the Object Pascal language your can read the Free Pascal Reference guide

[http://www.freepascal.org/docs-html/ref/ref.html]. But beware that some feature are not implemented by the script

language, for example: no pointer, no assembler, no overloading.

In addition to the standard Pascal Script feature the following CCDciel specific function are added.

Constants

name value

deg2rad degree to radian conversion constant

rad2deg radian to degree conversion constant

msgOK returned when a CCDciel command complete successfully

msgFailed returned when a CCDciel command fail

Global variables access

function GetS(varname:string; var str: string):Boolean;

Get the global string variable identified by varname

varname value

LASTERROR The text of the last error

Str1 .. Str10 Ten global variable for your use

function SetS(varname:string; str: string):Boolean;

Set the global string variable identified by varname for later use

varname value

Str1 .. Str10 Ten global variable for your use

function GetSL(varname:string; var strl: Tstringlist):Boolean;

Get the global stringlist variable identified by varname

varname value

Strl1 .. Strl10 Ten global variable for your use

function SetSL(varname:string; stlr: Tstringlist):Boolean;

Set the global stringlist variable identified by varname for later use

varname value

Strl1 .. Strl10 Ten global variable for your use

function GetI(varname:string; var i: Integer):Boolean;

Get the global integer variable identified by varname
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varname value

Int1 .. Int10 Ten global variable for your use

function SetI(varname:string; i: Integer):Boolean;

Set the global integer variable identified by varname for later use

varname value

Int1 .. Int10 Ten global variable for your use

function GetD(varname:string; var x: double):boolean;

Get the global double variable identified by varname

varname value

TelescopeRA The telescope position right ascension

TelescopeDE The telescope position declination

TimeNow The current time in TDateTime format

CCDTEMP The current CCD temperature

Double1 .. Double10 Ten global variable for your use

function SetD(varname:string; x: Double):Boolean;

Set the global double variable identified by varname for later use

varname value

Double1 .. Double10 Ten global variable for your use

function GetB(varname:string; var x: boolean):boolean;

Get the global boolean variable identified by varname

varname value

TELESCOPE_CONNECTED True if the telescope is connected

TELESCOPE_PARKED True if the telescope is parked

TELESCOPE_EQMOD True if the telescope use the EqMod driver

AUTOGUIDER_CONNECTED True if the auto-guider is connected

AUTOGUIDER_RUNNING True if the auto-guider is running

AUTOGUIDER_GUIDING True if the auto-guider is guiding

WHEEL_CONNECTED True if the filter wheel is connected

FOCUSER_CONNECTED True if the focuser is connected

CAMERA_CONNECTED True if the camera is connected

PLANETARIUM_CONNECTED True if the planetarium is connected

PREVIEW_RUNNING True if the preview is running

PREVIEW_LOOP True if the preview is in loop

CAPTURE_RUNNING True if a capture is running

Commands

function Cmd(cname:string):string;

Execute a simple command cname in CCDciel.

Valid Cmd() command are:

Command Description
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TELESCOPE_ABORTMOTION Stop any telescope movement

TELESCOPE_TRACK Start telescope tracking

EQMOD_CLEARPOINTS Clear EqMod alignment data

EQMOD_CLEARSYNCDELTA Clear Eqmod sync delta

EQMOD_STDSYNC Set Eqmod in Standard sync mode

EQMOD_APPENDSYNC Set Eqmod in Add point on sync mode

AUTOGUIDER_CONNECT Connect to the autoguider software

AUTOGUIDER_CALIBRATE Force a new calibration of the autoguider

AUTOGUIDER_STARTGUIDING Start to guide

AUTOGUIDER_STOPGUIDING Stop guiding

AUTOGUIDER_PAUSE Pause guiding

AUTOGUIDER_UNPAUSE Restart after pause

AUTOGUIDER_DITHER Dither now

AUTOGUIDER_SHUTDOWN Close the autoguider program

WHEEL_GETFILTER Get the current filter number in the wheel

PREVIEW_SINGLE Start a single preview

PREVIEW_LOOP Start a preview loop

PREVIEW_WAITLOOP Wait until the user stop the preview loop

PREVIEW_STOP Stop any in progress preview or preview loop

CAPTURE_START Start a capture

CAPTURE_STOP Stop a capture

ASTROMETRY_SOLVE Plate solve the current image

ASTROMETRY_SYNC Plate solve the current image and sync the telescope

ASTROMETRY_SLEW_IMAGE_CENTER Plate solve the current image and slew the telescope

PLANETARIUM_CONNECT Connect the planetarium software

PLANETARIUM_SHOWIMAGE Plate solve the current image and show in planetarium

PLANETARIUM_SHUTDOWN Close the planetarium software

PROGRAM_SHUTDOWN Close CCDciel

CLEAR_REFERENCE_IMAGE Remove the reference image

AUTOFOCUS Run auto-focus at the current position

AUTOMATICAUTOFOCUS Move to a bright star and run auto-focus, return to last position when

finished

function CmdArg(cname:string; arg:Tstringlist):string;

Execute a command cname in CCDciel with parameters arg. Add each parameter to the string list.

Valid CmdArg() command are:

Command Arguments Description

DEVICES_CONNECTION ON/OFF Connect or disconnect the devices

TELESCOPE_SLEW RA, DEC Slew to specified coordinates

TELESCOPE_SYNC RA, DEC Sync to specified coordinates

TELESCOPE_PARK ON/OFF Park or unpark the telescope

WHEEL_SETFILTER number Set the filter number in the wheel

WHEEL_GETFILTERSNAME arg On return arg contain the name of the filters

WHEEL_SETFILTERSNAME arg Put each filter name in arg

CCD_SETTEMPERATURE temp Set the CCD temperature

PREVIEW_SETEXPOSURE exp Set the preview exposure time

PREVIEW_SETBINNING bin Set the preview binning
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CAPTURE_SETEXPOSURE exp Set the capture exposure

CAPTURE_SETBINNING bin Set the capture binning

CAPTURE_SETOBJECTNAME name Set the capture object name

CAPTURE_SETCOUNT count Set the capture image count

CAPTURE_SETFRAMETYPE Light/Bias/Dark/Flat Set the capture frame type

CAPTURE_SETDITHER count Set the capture Dither count

SEQUENCE_START sequence Load and start the sequence

SAVE_FITS_FILE filename Save the FITS file

OPEN_FITS_FILE filename Open the FITS file

OPEN_REFERENCE_IMAGE filename Load a reference image

Delay functions

procedure Wait(wt:integer);

Wait wt seconds before to continue the execution

function WaitTill(hour:string; showdialog: boolean):boolean;

Wait until the time is “hour”, encoded as 23:30:00 .

If the time is already passed by less than 12h the function return immediately, if it is passed for more than 12h it

wait for the next day.

If showdialog is true a dialog with time countdown is show, this dialog also allow to cancel or to continue

immediately, it return False if the wait is canceled.

Coordinates conversion

Procedure Eq2Hz(var ra,de : double ; var a,h : double);

Convert Equatorial ra,de to Alt/Az a,h for the location and time of the current chart, all angle in radian

Procedure Hz2Eq(var a,h : double; var ra,de : double);

Convert Alt/Az a,h to equatorial ra,de for the location and time of the current chart, all angle in radian

Formating and conversion

Function ARtoStr(var ar: Double) : string;

Return a string formated Right Ascension of ar value

Function DEtoStr(var de: Double) : string;

Return a string formated Declination of de value

Function StrtoAR(str:string; var ar: Double) : boolean;

Convert a formated string to Right Ascension decimal value

Function StrtoDE(str:string; var de: Double) : boolean;

Convert a formated string to Declination decimal value

Function JDtoStr(var jd: Double) : string;
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Format a julian date to YYYY-MM-DD string

Function StrtoJD(dt:string; var jdt: Double) : boolean;

Convert a formated string YYYY-MM-DD to julian date value

Function FormatFloat(Const Format : String; var Value : double) : String;

Format a decimal number according to the Format  [http://www.freepascal.org/docs-html/rtl/sysutils/formatfloat.html]

specification

Function Format(Const Fmt : String; const Args : Array of const) : String;

The Format  [http://www.freepascal.org/docs-html/rtl/sysutils/format.html] Pascal function

Procedure StrtoFloatD(str:string; var defval: Double; var val: Double);

Convert a string to a floating point value. Return defval if the string is a invalid number

function IsNumber(str: String): boolean;

Return True if the string represent a valid number

function StringReplace(str,s1,s2: String): string;

Replace all occurrence of s1 by s2 in str

Dialog

function MsgBox(const aMsg: string):boolean;

A message confirmation dialog. Return True if YES is clicked.

Procedure ShowMessage(const aMsg: string);

Display a message.

Procedure LogMsg(const aMsg: string);

Write a message to the log

Run external program

function Run(cmdline:string):boolean;

Execute the specified command. Return immediately without waiting for the execution to end.

function RunWait(cmdline:string):boolean;

Execute the specified command. Wait for termination.

function RunOutput(cmdline:string; var output:TStringlist):boolean;

Execute the specified command, wait for termination and put the stdout to “output”. Beware this function can
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completely lock the main program if it not finish in time.

function OpenFile(fn:string):boolean;

Open a document file using the default program
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Installation on Ubuntu, Debian

Bellow installation procedure uses only command line approach, because this is the simpler way to follow

instructions just by copy-pasting the commands in terminal.

This same procedure can be used with any system using deb packages (Debian, Mint, Raspbian, …)

CCDciel and it's dependency are available from the same repository as Skychart  [https://www.ap-i.net/skychart], but you

need the unstable repository as long this program is in beta version only.

1. Add Skychart unstable repository:

sudo apt-add-repository 'deb http://www.ap-i.net/apt unstable main'

2. Install the public key:

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AA716FC2

3. Update repository:

sudo apt-get update

4. Install CCDciel:

sudo apt-get install ccdciel

See also the list of the optional dependencies to install to take full advantage of the software.

76

https://www.ap-i.net/skychart


Installation on Linux

If your Linux system use deb packages,see Installation on Ubuntu.

For other Linux system you can download rpm or tar packages from the Sourceforge download

[http://sourceforge.net/projects/ccdciel/files/] link.

The requirement are Gtk2 and libpasastro [https://sourceforge.net/projects/libpasastro/].

See also the list of dependencies to install to take full advantage of the software.

You can also compile the source code [https://github.com/pchev/ccdciel] using Lazarus [http://www.lazarus-ide.org/index.php].
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Installation on Windows

CCDciel can run on any current version of Windows. It may run on XP but you can experience ASCOM driver crash.

The CCDciel installer always install a 32bit version even in a 64bit Windows system because very few ASCOM driver

work with a 64bit application.

To use the devices connected to your Windows computer you need the ASCOM platform  [http://ascom-standards.org/]

and the drivers for you hardware.

But you can also use the devices connected to a remote Linux system (Raspberry PI for example) using the INDI

protocol.

You can download the setup installer from the Sourceforge download [http://sourceforge.net/projects/ccdciel/files/] link.

See also the list of the optional dependencies to install to take full advantage of the software.
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Installation on macOS

CCDciel can run on a recent version of macOS, the minimal version required to run the program is 10.10 Yosemite.

To use the devices connected to your Mac computer you need the INDI [http://www.indilib.org/] library and the drivers

for you hardware, available from CloudMakers [http://www.cloudmakers.eu/xindi/].

You can download the dmg installer from the Sourceforge download [http://sourceforge.net/projects/ccdciel/files/] link.

See also the list of the optional dependencies to install to take full advantage of the software.
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ASCOM

ASCOM [http://ascom-standards.org] Platform is the standard astronomical equipment driver for Windows.

Install the ASCOM platform and the drivers you need from http://ascom-standards.org/Downloads/Index.htm

[http://ascom-standards.org/Downloads/Index.htm] or from your equipment manufacturer.
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INDI

INDI [http://www.indilib.org/] Library is the standard astronomical equipment  [http://www.indilib.org/devices/] driver for

Linux and macOS.

You can install INDI with the packages provided by your Linux distribution, but as this is a rapidly moving project it is

best to get the latest version [http://www.indilib.org/download.html] directly from the project.

For example for Debian/Ubuntu see https://launchpad.net/~mutlaqja/+archive/ubuntu/ppa

[https://launchpad.net/~mutlaqja/+archive/ubuntu/ppa]

For macOS the best option is to get the version from CloudMakers [http://www.cloudmakers.eu/xindi/].

There is no INDI server for Windows but you can run CCDciel on Windows to connect to a remote Linux computer. Or

use wINDI [http://www.cloudmakers.eu/windi/] to use your ASCOM devices with the INDI protocol.

81

http://www.indilib.org/
http://www.indilib.org/devices/
http://www.indilib.org/download.html
https://launchpad.net/~mutlaqja/+archive/ubuntu/ppa
http://www.cloudmakers.eu/xindi/
http://www.cloudmakers.eu/windi/


Astrometry.net

Astrometry.net can be used to solve the image you just take with your camera. Astrometric solving will give the

exact astronomical position of the image center, its orientation and size.

CCDciel requires a local copy of the Astrometry.net software including the indexes on your computer. It can also run

Astrometry.net on a remote host using the provided script.

At page http://astrometry.net/use.html [http://astrometry.net/use.html] you can find detailed instructions how to install

the software and indexes.

Linux

On Linux astrometry.net is probably packaged by your distribution. This is the easiest and preferred way to install

the software.

For example on Debian or Ubuntu just do:

 sudo apt-get install astrometry.net

Then to install some indexes:

 sudo apt-get install astrometry-data-2mass-08-19 astrometry-data-2mass-07

macOS

For macOS the best option is to get the version from CloudMakers [http://www.cloudmakers.eu/xindi/].

To use the CloudMakers version you need to change the following in the CCDciel Preferences at the astrometry tab:

Check Use custom script

Enter the script name: /Applications/CCDciel/scripts/astrometry-macos.sh

If you use another version of astrometry.net on your Mac you must be sure it can be called from CCDciel without

specifying a path. 

If you need to add the path you can modify one of the example script located in /Applications/CCDciel/scripts to suit

your needs.

Windows

A number of Windows package include a fully automated install of Cygwin and astrometry.net and it is best to get

one of them. CCDciel do not use this applications but the astrometry.net they install. Cygwin is a tool required to

run a compiled version of Astrometry.net under Windows.

The following list indicate tested application and give the Cygwin path you must configure in the astrometry

preferences.

At the time of writing all these application use the same 2010 version 0.38 of Astrometry.net.

ANSVR [https://adgsoftware.com/ansvr/], set Cygwin path to C:\Users\[your user name]\AppData\Local\cygwin_ansvr

Install up to step 9 as indicated in the web based instruction.

Astrotortilla [https://sourceforge.net/projects/astrotortilla/], set Cygwin path to C:\cygwin

All sky plate solver [http://www.astrogb.com/astrogb/All_Sky_Plate_Solver.html], set Cygwin path to C:\Users\[your user

name]\AppData\Local\Astrometry

Windows subsystem for Linux, is not a real option for now as it require a 64 bits version of CCdciel but there is

almost no 64 bits ASCOM drivers available.
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ELBRUS

Elbrus star locator can be used to solve the image you just take with your camera.

Look at the program page for instruction http://www.astrosurf.com/pulgar/elbrus/elbrusin.htm

[http://www.astrosurf.com/pulgar/elbrus/elbrusin.htm]

Before you can use it the Elbrus program must be calibrated for your images. Then select File / E-Wait for message.

Also be sure to set the parameter: “Add the WCS in the FITS header”.

This is a Windows only software but I find it easy to install and use on Linux with Wine.

On the astrometry preference you can set both the DOS and Unix path to the image data to help with this use.

To install Wine on Linux or macOS see Wine web pages [https://www.winehq.org/].

On Linux the best way is to install the wine packages provided by your distribution.
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PlateSolve 2

PlateSolve 2 can be used to solve the image you just taken with your camera. Astrometric solving wil give the exact

astronomical position of the image center, its orientation and size.

Look at the program page for instruction http://planewave.com/downloads/software/

[http://planewave.com/downloads/software/]

Download and install the program and download and extract on of the two available star catalogs e.g. the UCAC3 in

a sub folder. Configure the star catalog in the PlateSolve2 program. Then configure the program path in CCDciel.

You could test its operation manually by loading an image in PlateSolve2. It requires an position and image

dimensions if not contained in the image header.

Linux and Mac

This is a Windows only software but it run on Linux with Wine.

Use winetricks to install the required VB6 dependency:

winetricks vb6run

To install Wine on Linux or macOS see Wine web pages [https://www.winehq.org/].

On Linux the best way is to install the wine packages provided by your distribution.
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