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Chapter 1

Introduction

Xen is an open-sourgeara-virtualizingvirtual machine monitor (VMM), or “hypervi-
sor”, for a variety of processor architectures including x86. Xensemurely execute
multiple virtual machines on a single physical system with near native perfmena
Xen facilitates enterprise-grade functionality, including:

¢ Virtual machines with performance close to native hardware.

e Live migration of running virtual machines between physical hosts.

e Up to 32 virtual CPUs per guest virtual machine, with VCPU hotplug.
x86/32 with PAE, x86/64, and 1A64 platform support.

Intel and AMD Virtualization Technology for unmodified guest operating-sy
tems (including Microsoft Windows).

Excellent hardware support (supports almost all Linux device drjver

1.1 Usage Scenarios

Usage scenarios for Xen include:

Server Consolidation. Move multiple servers onto a single physical host with perfor-
mance and fault isolation provided at the virtual machine boundaries.

Hardware Independence. Allow legacy applications and operating systems to ex-
ploit new hardware.

Multiple OS configurations. Run multiple operating systems simultaneously, for de-
velopment or testing purposes.

Kernel Development. Test and debug kernel modifications in a sand-boxed virtual
machine — no need for a separate test machine.

1|AB4 supports up to 64 virtual CPUs per guest virtual machine



Cluster Computing. Management at VM granularity provides more flexibility than
separately managing each physical host, but better control and isolation th
single-system image solutions, particularly by using live migration for load bal-
ancing.

Hardware support for custom OSes. Allow development of new OSes while bene-
fiting from the wide-ranging hardware support of existing OSes sutinas.

1.2 Operating System Support

Para-virtualization permits very high performance virtualization, evendhmitactures
like x86 that are traditionally very hard to virtualize.

This approach requires operating systems tpdmeedto run on Xen. Porting an OS
to run on Xen is similar to supporting a new hardware platform, however tiheeps
is simplified because the para-virtual machine architecture is very similar totes-u
lying native hardware. Even though operating system kernels must ilyiepport
Xen, a key feature is that user space applications and librdoieetrequire modifi-
cation.

With hardware CPU virtualization as provided by Intel VT and AMD SVM teahn
ogy, the ability to run an unmodified guest OS kernel is available. No porfitipd®®S
is required, although some additional driver support is necessary Wénitself. Un-
like traditional full virtualization hypervisors, which suffer a tremendoeg@mance
overhead, the combination of Xen and VT or Xen and Pacifica technotwgplement
one another to offer superb performance for para-virtualized gyesating systems
and full support for unmodified guests running natively on the praxess

Paravirtualized Xen support is available for increasingly many operagstg®s: cur-
rently, mature Linux support is available and included in the standard distribu
Other OS ports, including NetBSD, FreeBSD and Solaris are also complete.

1.3 Hardware Support

Xen currently runs on the IA64 and x86 architectures. Multiprocessa@himeas are
supported, and there is support for HyperThreading (SMT).

The default 32-bit Xen requires processor support for Physiddréssing Extensions
(PAE), which enables the hypervisor to address up to 16GB of physieaiory. Xen
also supports x86/64 platforms such as Intel EM64T and AMD Opteronhadan
currently address up to 1TB of physical memory.

Xen offloads most of the hardware support issues to the guest Ofiguinrthe Do-
main 0 management virtual machine. Xen itself contains only the code required to
detect and start secondary processors, set up interrupt routidgpesform PCI bus
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enumeration. Device drivers run within a privileged guest OS rathenliim Xen

itself. This approach provides compatibility with the majority of device hardwape
ported by Linux. The default XenLinux build contains support for mesver-class
network and disk hardware, but you can add support for othem@aeby configuring
your XenLinux kernel in the normal way.

1.4 Structure of a Xen-Based System

A Xen system has multiple layers, the lowest and most privileged of which s Xe
itself.

Xen may host multipleguestoperating systems, each of which is executed within a
secure virtual machine. In Xen terminologydamain Domains are scheduled by
Xen to make effective use of the available physical CPUs. Each guestd@@&ges

its own applications. This management includes the responsibility of schedualaig
application within the time allotted to the VM by Xen.

The first domaindomain Q is created automatically when the system boots and has
special management privileges. Domain O builds other domains and manages th
virtual devices. It also performs administrative tasks such as susggrrésuming
and migrating other virtual machines.

Within domain 0, a process callegndruns to manage the system. Xend is responsible
for managing virtual machines and providing access to their consoles. Quisraee
issued to xend over an HTTP interface, via a command-line tool.

1.5 History

Xen was originally developed by the Systems Research Group at therkltyvef
Cambridge Computer Laboratory as part of the XenoServers projextefuby the
UK-EPSRC.

XenoServers aim to provide a “public infrastructure for global distrithatemputing”.

Xen plays a key part in that, allowing one to efficiently partition a single machine to
enable multiple independent clients to run their operating systems and appkcation
in an environment. This environment provides protection, resource isolatid ac-
counting. The project web page contains further information along withteairio
papers and technical reportstp://www.cl.cam.ac.uk/xeno

Xen has grown into a fully-fledged project in its own right, enabling us tostigate
interesting research issues regarding the best techniques for virtgazimurces such
as the CPU, memory, disk and network. Project contributors now include Qitté,
IBM, HP, AMD, Novell, RedHat, Sun, Fujitsu, and Samsung.



Xen was first described in a paper presented at SOSP ir’2@6d the first public
release (1.0) was made that October. Since then, Xen has significanthethahd is
now used in production scenarios on many sites.

1.6 What's New

Xen 3.3.0 offers:

e |O Emulation (stub domains) for HVM 10 performance and scailability

Replacement of Intel VT vmxassist by new 16b emulation code

Improved VT-d device pass-through e.g. for graphics devices

Enhanced C and P state power management

Exploitation of multi-queue support on modern NICs

Removal of domain lock for improved PV guest scalability
e 2MB page support for HVYM and PV guests
e CPU Portability

Xen 3.3 delivers the capabilities needed by enterprise customers ascgiwputing
industry leaders a solid, secure platform to build upon for their virtualizatdutions.
This latest release establishes Xen as the definitive open source satutidnifaliza-
tion.

2http:/iwww.cl.cam.ac.uk/netos/papers/2003-xensosp.p df
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Chapter 2

Basic Installation

The Xen distribution includes three main components: Xen itself, ports of Lamalx
NetBSD to run on Xen, and the userspace tools required to manage saXed-$fys-
tem. This chapter describes how to install the Xen 3.3 distribution from soédee
ternatively, there may be pre-built packages available as part of yauating system
distribution.

2.1 Prerequisites

The following is a full list of prerequisites. Items markegdare required by the xend
control tools, and hence required if you want to run more than one vinaghine;
items markeds’ are only required if you wish to build from source.

e A working Linux distribution using the GRUB bootloader and running on a P6-

class or newer CPU.
1 Theiproute2 package.
t The Linux bridge-util$ (e.g.,/sbin/brctl )

t The Linux hotplug systef(e.g., /sbin/hotplug and related scripts). On
newer distributions, this is included alongside the Linux udev system

*

Build tools (gcc v3.2.x or v3.3.%, binutils, GNU make).

*

Development installation of zlib (e.qg., zlib-dev).

*

Development installation of Python v2.2 or later (e.g., python-dev).

*

IATEX and transfig are required to build the documentation.

! Available fromhttp://bridge.sourceforge.net
2pvailable fromhttp://linux-hotplug.sourceforge.net/
3Seehttp:/iwww.kernel.org/pub/linux/utils/kernel/hotplu g/udev.html/



Once you have satisfied these prerequisites, you can now install eithearg br
source distribution of Xen.

2.2 Installing from Binary Tarball

Pre-built tarballs are available for download from the XenSource dadsipage:
http://www.xensource.com/downloads/
Once you've downloaded the tarball, simply unpack and install:

# tar zxvf xen-3.0-install.tgz
# cd xen-3.0-install
# sh .finstall.sh

Once you've installed the binaries you need to configure your systerasasiloed in
Section 2.5.

2.3 Installing from RPMs

Pre-built RPMs are available for download from the XenSource dowislpage:
http://www.xensource.com/downloads/

Once you've downloaded the RPMs, you typically install them via the RPM com-
mands:

# rpm -iv rpmname
See the instructions and the Release Notes for each RPM set refeaénced

http://www.xensource.com/downloads/

2.4 Installing from Source

This section describes how to obtain, build and install Xen from source.

2.4.1 Obtaining the Source

The Xen source tree is available as either a compressed source tadmt ctone of
our master Mercurial repository.

Obtaining the Source Tarball
Stable versions and daily snapshots of the Xen source tree are avaitablné
Xen download page:

http://www.xensource.com/downloads/



Obtaining the source via Mercurial
The source tree may also be obtained via the public Mercurial repository at:

http://xenbits.xensource.com
See the instructions and the Getting Started Guide referenced at:

http://www.xensource.com/downloads/

2.4.2 Building from Source

The top-level Xen Makefile includes a target “world” that will do the follogin
e Build Xen.
¢ Build the control tools, including xend.

e Download (if necessary) and unpack the Linux 2.6 source code,atot i for
use with Xen.

e Build a Linux kernel to use in domain 0 and a smaller unprivileged kernel,iwhic
can be used for unprivileged virtual machines.

After the build has completed you should have a top-level directory cdited in

which all resulting targets will be placed. Of particular interest are the twad_Xeix

kernel images, one with a “-xen0” extension which contains hardwarieeldrivers
and drivers for Xen'’s virtual devices, and one with a “-xenU” exienghat just con-
tains the virtual ones. These are founddiat/install/boot/ along with the
image for Xen itself and the configuration files used during the build.

To customize the set of kernels built you need to edit the top-level Makebiak for
the line:

KERNELS ?= linux-2.6-xen0 linux-2.6-xenU

You can edit this line to include any set of operating system kernels whigh dwn-
figurations in the top-leveduildconfigs/ directory.

2.4.3 Custom Kernels

If you wish to build a customized XenLinux kernel (e.g. to support additidesices
or enable distribution-required features), you can use the standard tamfiguration
mechanisms, specifying that the architecture being built feens e.g:

# cd linux-2.6.12-xen0

# make ARCH=xen xconfig
# cd .

# make

You can also copy an existing Linux configuratioeoffig ) into e.g.linux-2.6.12-xen0
and execute:



# make ARCH=xen oldconfig

You may be prompted with some Xen-specific options. We advise acceptingthe d
faults for these options.

Note that the only difference between the two types of Linux kernels tiedbailt is
the configuration file used for each. The “U” suffixed (unprivilegedjsions don't
contain any of the physical hardware device drivers, leading to a &action in
size; hence you may prefer these for your non-privileged domains.“Thsuffixed
privileged versions can be used to boot the system, as well as in doveaids and
unprivileged domains.

2.4.4 Installing Generated Binaries

The files produced by the build process are stored undeatighimstall/ direc-
tory. To install them in their default locations, do:

# make install

Alternatively, users with special installation requirements may wish to install them
manually by copying the files to their appropriate destinations.

Thedist/install/boot directory will also contain the config files used for build-
ing the XenLinux kernels, and also versions of Xen and XenLinux kethat contain
debug symbols such agefi-syms-3.0.0  andvmlinux-syms-2.6.12.6-xen0 )
which are essential for interpreting crash dumps. Retain these files asvélepkrs
may wish to see them if you post on the mailing list.

2.5 Configuration

Once you have built and installed the Xen distribution, it is simple to prepare the
machine for booting and running Xen.

2.5.1 GRUB Configuration

An entry should be added ¢pub.conf  (often found undetboot/  or/boot/grub/ )
to allow Xen / XenLinux to boot. This file is sometimes calladnu.Ist , depending
on your distribution. The entry should look something like the following:

titte Xen 3.0 / XenLinux 2.6

kernel /boot/xen-3.0.gz dom0_mem=262144
module /boot/vmlinuz-2.6-xen0 root=/dev/sda4 ro console =tty0

The kernel line tells GRUB where to find Xen itself and what boot paramstersid
be passed to it (in this case, setting the domain 0 memory allocation in kilobytes and
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the settings for the serial port). For more details on the various Xen boatngters
see Section 11.3.

The module line of the configuration describes the location of the XenLinunrekéhat
Xen should start and the parameters that should be passed to it. Thestaralard
Linux parameters, identifying the root device and specifying it be initially nbedin
read only and instructing that console output be sent to the screen. $&tntaitdons
such as SUSE do not require tloe parameter.

To use an initrd, add anotherodule line to the configuration, like:

module /boot/my_initrd.gz

When installing a new kernel, it is recommended that you do not delete existimg me
options frommenu.Ist , as you may wish to boot your old Linux kernel in future,
particularly if you have problems.

2.5.2 Serial Console (optional)

Serial console access allows you to manage, monitor, and interact withsystiem
over a serial console. This can allow access from another neartgnsysa a null-
modem (“LapLink”) cable or remotely via a serial concentrator.

You system’s BIOS, bootloader (GRUB), Xen, Linux, and login accesst mach be
individually configured for serial console access. Ihi strictly necessary to have
each component fully functional, but it can be quite useful.

For general information on serial console configuration under Lirefey ito the “Re-
mote Serial Console HOWTO" at The Linux Documentation Projettp://www.
tidp.org

Serial Console BIOS configuration

Enabling system serial console output neither enables nor disabldscapiadailities

in GRUB, Xen, or Linux, but may make remote management of your system more
convenient by displaying POST and other boot messages over setiahgaallowing
remote BIOS configuration.

Refer to your hardware vendor’s documentation for capabilities arckproes to en-
able BIOS serial redirection.

Serial Console GRUB configuration

Enabling GRUB serial console output neither enables nor disables Xenwot serial
capabilities, but may made remote management of your system more conugnient
displaying GRUB prompts, menus, and actions over serial port and allawimgte
GRUB management.
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Adding the following two lines to your GRUB configuration file, typically either
/boot/grub/menu.|st or /boot/grub/grub.conf depending on your distro,
will enable GRUB serial output.
serial --unit=0 --speed=115200 --word=8 --parity=no --st op=1
terminal --timeout=10 serial console
Note that when both the serial port and the local monitor and keyboarenatged,
the text ‘Press any key to continliwill appear at both. Pressing a key on one device
will cause GRUB to display to that device. The other device will see no oulpuoib.
key is pressed before the timeout period expires, the system will boot wefaelt
GRUB boot entry.

Please refer to the GRUB documentation for further information.

Serial Console Xen configuration

Enabling Xen serial console output neither enables nor disables Limaglkeutput
or logging in to Linux over serial port. It does however allow you to monitut bog
the Xen boot process via serial console and can be very useful irgdily.

In order to configure Xen serial console output, it is necessary to adoteoption to
your GRUB config; e.g. replace the previous example kernel line with:

kernel /boot/xen.gz dom0_mem=131072 com1=115200,8n1 con sole=com1,vga

This configures Xen to output on COM1 at 115,200 baud, 8 data bits, nity pad
1 stop bit. Modify these parameters for your environment. See Section drlehf
explanation of all boot parameters.

One can also configure XenLinux to share the serial console; to adhisvappend
“console=ttySO " to your module line.

Serial Console Linux configuration

Enabling Linux serial console output at boot neither enables nor diskdgging in to
Linux over serial port. It does however allow you to monitor and log the X iboot
process via serial console and can be very useful in debugging.

To enable Linux output at boot time, add the parametesole=ttySO  (or ttyS1,
ttyS2, etc.) to your kernel GRUB line. Under Xen, this might be:

module /vmlinuz-2.6-xen0 ro root=/dev/VolGroup00/LogVo 100 \
console=ttyS0, 115200

to enable output over ttyS0 at 115200 baud.
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Serial Console Login configuration
Logging in to Linux via serial console, under Xen or otherwise, requpexifying a

login prompt be started on the serial port. To permit root logins over sewiaole,
the serial port must be added/tac/securetty
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To automatically start a login prompt over the serial port, add the line:
c:2345:respawn:/shin/mingetty ttySO

to /etc/inittab . Runinit g to force a reload of your inttab and start getty.

To enable root logins, adtyS0 to /etc/securetty if not already present.

Your distribution may use an alternate getty; options include getty, mgetty attg.age
Consult your distribution’s documentation for further information.

2.5.3 TLS Libraries

Users of the XenLinux 2.6 kernel should disable Thread Local Stofag8) (e.g.

by doing amv /lib/tls /lib/tls.disabled ) before attempting to boot a Xen-
Linux kernef. You can always reenable TLS by restoring the directory to its original
location (i.e.mv /lib/tls.disabled /lib/tls ).

The reason for this is that the current TLS implementation uses segmentatia@min a
that is not permissible under Xen. If TLS is not disabled, an emulation modse u
within Xen which reduces performance substantially. To ensure fulbpmadnce you
should install a ‘Xen-friendly’ (nosegneg) version of the library.

2.6 Booting Xen

It should now be possible to restart the system and use Xen. Reboohaoskcthe
new Xen option when the Grub screen appears.

What follows should look much like a conventional Linux boot. The firstiparof
the output comes from Xen itself, supplying low level information about itselfthe
underlying hardware. The last portion of the output comes from Xemnd.inu

You may see some error messages during the XenLinux boot. Thesetareces-
sarily anything to worry about—they may result from kernel configuratifier@nces
between your XenLinux kernel and the one you usually use.

When the boot completes, you should be able to log into your system as lisual.
are unable to log in, you should still be able to reboot with your normal Lirerxdd
by selecting it at the GRUB prompt.

“If you boot without first disabling TLS, you will get a warning messageiry the boot process.
In this case, simply perform the rename after the machine is up and théabin/ldconfig to
make it take effect.
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Chapter 3

Booting a Xen System

Booting the system into Xen will bring you up into the privileged management odipma
Domain0. At that point you are ready to create guest domains and “bamti tising
thexm create command.

3.1 Booting Domain0

After installation and configuration is complete, reboot the system and auselihe
new Xen option when the Grub screen appears.

What follows should look much like a conventional Linux boot. The firstiparof
the output comes from Xen itself, supplying low level information about itsetfthe
underlying hardware. The last portion of the output comes from Xendinu

When the boot completes, you should be able to log into your system as lisual.
are unable to log in, you should still be able to reboot with your normal Lirerxéd
by selecting it at the GRUB prompt.

The first step in creating a new domain is to prepare a root filesystem fobddb
Typically, this might be stored in a normal partition, an LVM or other volume manag
partition, a disk file or on an NFS server. A simple way to do this is simply to boot
from your standard OS install CD and install the distribution into another partiio
your hard drive.

To start the xend control daemon, type
# xend start

If you wish the daemon to start automatically, see the instructions in Sectiondcg. O
the daemon is running, you can use #etool to monitor and maintain the domains
running on your system. This chapter provides only a brief tutorial. Weighedull
details of thexmtool in the next chapter.

15



3.2 Booting Guest Domains

3.2.1 Creating a Domain Configuration File

Before you can start an additional domain, you must create a configufdéo We
provide two example files which you can use as a starting point:

e /etc/xen/xmexamplel is a simple template configuration file for describing
a single VM.

e /etc/xen/xmexample2 file is a template description that is intended to be
reused for multiple virtual machines. Setting the value ofvtihhel variable on
thexm command line fills in parts of this template.

There are also a number of other examples which you may find useful. @eppf
these files and edit it as appropriate. Typical values you may wish to ellitigic

kernel Set this to the path of the kernel you compiled for use with Xen
(e.g.kernel = “/boot/vmlinuz-2.6-xenU” )

memory Set this to the size of the domain’s memory in megabytes (e.g.
memory = 64)

disk Set the first entry in this list to calculate the offset of the domain’s
root partition, based on the domain ID. Set the second to the lo-
cation of/usr if you are sharing it between domains (edigk =
[phy:your  _hard _drive%d,sdal,w’ % (base _partition _number
+ vmid), 'phy:your _usr _partition,sda6,r’ ]

dhcp Uncomment the dhcp variable, so that the domain will receive its
IP address from a DHCP server (edycp=“dhcp” )

You may also want to edit thef variable in order to choose the MAC address of the
virtual ethernet interface yourself. For example:

vif = ['mac=00:16:3E:F6:BB:B3’]
If you do not set this variable, xend will automatically generate a randonC M4-
dress from the range 00:16:3E:xx:xx:xx, assigned by IEEE to Xen8@asan OUI

(organizationally unique identifier). XenSource Inc. gives permissiorafiyone to
use addresses randomly allocated from this range for use by their Xeairun

For alist of [IEEE OUI assignments, deitp://standards.ieee.org/regauth/
oui/oui.txt

3.2.2 Booting the Guest Domain

Thexmtool provides a variety of commands for managing domains. Usertiage
command to start new domains. Assuming you've created a configuratiaryfiteconf
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based arounéktc/xen/xmexample2 , to start a domain with virtual machine ID 1
you should type:

# xm create -c myvmconf vmid=1

The-c switch causesmto turn into the domain’s console after creation. Thed=1
sets thevmid variable used in theayvmconf file.

You should see the console boot messages from the new domain appeattireg
terminal in which you typed the command, culminating in a login prompt.

3.3 Starting / Stopping Domains Automatically

Itis possible to have certain domains start automatically at boot time and to twnge d
wait for all running domains to shutdown before it shuts down the system.

To specify a domain is to start at boot-time, place its configuration file (or a liitk to
undetr/etc/xen/auto/

A Sys-V style init script for Red Hat and LSB-compliant systems is provatediwill
be automatically copied t&tc/init.d/ during install. You can then enable it in
the appropriate way for your distribution.

For instance, on Red Hat:
# chkconfig --add xendomains
By default, this will start the boot-time domains in runlevels 3, 4 and 5.
You can also use theervice command to run this script manually, e.g:
# service xendomains start
Starts all the domains with config files under /etc/xen/auto/.
# service xendomains stop

Shuts down all running Xen domains.
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Chapter 4

Domain Management Tools

This chapter summarizes the management software and tools available.

4.1 Xend

The Xend node control daemon performs system management functiatexdréo
virtual machines. It forms a central point of control of virtualized reses, and must
be running in order to start and manage virtual machines. Xend must ks mgot
because it needs access to privileged system management functions.

An initialization script namedetc/init.d/xend is provided to start Xend at boot
time. Use the tool appropriate (i.e. chkconfig) for your Linux distributionpecsfy
the runlevels at which this script should be executed, or manually craatsoéig links
in the correct runlevel directories.

Xend can be started on the command line as well, and supports the followin§j set
parameters:

# xend start start xend, if not already running

# xend stop stop xend if already running

# xend restart restart xend if running, otherwise start it
# xend status indicates xend status by its return code

A SysV init script calleckend is provided to start xend at boot timmake install
installs this script infetc/init.d . To enable it, you have to make symbolic links
in the appropriate runlevel directories or use tihdconfig  tool, where available.
Once xend is running, administration can be done usingihtol.
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4.1.1 Logging

As xend runs, events will be logged tear/log/xen/xend.log and (less fre-
guently) to/var/log/xen/xend-debug.log . These, along with the standard sys-
log files, are useful when troubleshooting problems.

4.1.2 Configuring Xend

Xend is written in Python. At startup, it reads its configuration informatiomfro
the file /etc/xen/xend-config.sxp . The Xen installation places an example
xend-config.sxp filein the/etc/xen  subdirectory which should work for most
installations.

See the example configuration fitend-debug.sxp  and the section 5 man page
xend-config.sxp for a full list of parameters and more detailed information.
Some of the most important parameters are discussed below.

An HTTP interface and a Unix domain socket API are available to communidtie w
Xend. This allows remote users to pass commands to the daemon. By defaudt, Xe
does not start an HTTP server. It does start a Unix domain socketymaremt server,

as the low level utilityxm requires it. For support of cross-machine migration, Xend
can start a relocation server. This supportis not enabled by dedask€urity reasons.

Note: the examplgend configuration file modifies the defaults and starts up Xend as
an HTTP server as well as a relocation server.

From the file:

#(xend-http-server no)
(xend-http-server yes)
#(xend-unix-server yes)
#(xend-relocation-server no)
(xend-relocation-server yes)

Comment or uncomment lines in that file to disable or enable features thatouitere

Connections from remote hosts are disabled by default:

# Address xend should listen on for HTTP connections, if xend -http-server is
# set.

# Specifying ’localhost’ prevents remote connections.

# Specifying the empty string " (the default) allows all con nections.

#(xend-address )
(xend-address localhost)

Itis recommended that if migration support is not neededxémel-relocation-server
parameter value be changed tw" or commented out.
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4.2 Xm

The xm tool is the primary tool for managing Xen from the console. The rgéne
format of an xm command line is:

# xm command [switches] [arguments] [variables]

The availableswitchesand argumentsare dependent on th@mmandchosen. The
variablesmay be set using declarations of the fowariable=value and com-
mand line declarations override any of the values in the configuration file lsied,
including the standard variables described above and any customlear{&r in-

stance, thamdefconfig file uses asrmid variable).

For online help for the commands available, type:
# xm help

This will list the most commonly used commands. The full list can be obtained using
xm help --long . Youcanalsotypem help <command> for more information
on a given command.

4.2.1 Basic Management Commands

One useful command # xm list which lists all domains running in rows of the
following format:

name domid memory vcpus state cputime
The meaning of each field is as follows:
name The descriptive name of the virtual machine.
domid The number of the domain ID this virtual machine is running in.
memory Memory size in megabytes.
vcpus The number of virtual CPUs this domain has.
state Domain state consists of 5 fields:
r running
b blocked
p paused
s shutdown
c crashed
cputime How much CPU time (in seconds) the domain has used so far.

Thexm list command also supports a long output format when-theswitch is
used. This outputs the full details of the running domains in xend’s SXPgroation
format.
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If you want to know how long your domains have been running for, thengan use
the# xm uptime command.

You can get access to the console of a particular domain using tkra console
command (e.g¥¢ xm console myVM).

4.2.2 Domain Scheduling Management Commands

The credit CPU scheduler automatically load balances guest VCPUs atravail-
able physical CPUs on an SMP host. The user need not manually pin VR
balance the system. However, she can restrict which CPUs a particuRld fay run
on using thexm vcpu-pin - command.

Each guest domain is assignedeight and acap .

A domain with a weight of 512 will get twice as much CPU as a domain with a weight
of 256 on a contended host. Legal weights range from 1 to 65535 ardkthalt is
256.

The cap optionally fixes the maximum amount of CPU a guest will be able to owsu
even if the host system has idle CPU cycles. The cap is expressed ém{zaye of one
physical CPU: 100 is 1 physical CPU, 50 is half a CPU, 400 is 4 CPUs, dthe.
default, 0, means there is no upper cap.

When you are running with the credit scheduler, you can check and yngalif- do-
mains’ weights and caps using tk@ sched-credit  command:

xm sched-credit -d <domain> lists weight and cap
xm sched-credit -d <domain> -w <weight> sets the weight
xm sched-credit -d <domain> -c <cap> sets the cap
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Chapter 5

Domain Configuration

The following contains the syntax of the domain configuration files and igkiser of
how to further specify networking, driver domain and general scliregibehavior.

5.1 Configuration Files

Xen configuration files contain the following standard variables. Unlessnetbe
stated, configuration items should be enclosed in quotes: see the cadidiggipts
in /etc/xen/  for concrete examples.

kernel Path to the kernel image.

ramdisk Path to a ramdisk image (optional).

memory Memory size in megabytes.

vcpus The number of virtual CPUs.

console Port to export the domain console on (default 9600 + domain ID).

vif Network interface configuration. This may simply contain an empty string for
each desired interface, or may override various settings, e.g.

vif = [ 'mac=00:16:3E:00:00:11, bridge=xen-br0’,
'bridge=xen-brl’ ]

to assign a MAC address and bridge to the first interface and assigreeediff
bridge to the second interface, leaving xend to choose the MAC addriss.
settings that may be overridden in this way are type, mac, bridge, ip, script,
backend, and vifname.

disk Listof block devices to exportto the domain edisk = [ 'phy:hdal,sdal,r ]
exports physical devicglev/hdal to the domain agdev/sdal  with read-
only access. Exporting a disk read-write which is currently mounted is dange
ous — if you arecertainyou wish to do this, you can specify as the mode.
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dhcp Setto'dhcp’ if you want to use DHCP to configure networking.
netmask Manually configured IP netmask.

gateway Manually configured IP gateway.

hostname Set the hostname for the virtual machine.

root Specify the root device parameter on the kernel command line.
nfs_server IP address for the NFS server (if any).

nfs_root Path of the root filesystem on the NFS server (if any).

extra Extra string to append to the kernel command line (if any)

Additional fields are documented in the example configuration files (e.g. fa@yooa
virtual TPM functionality).

For additional flexibility, it is also possible to include Python scripting commands in
configuration files. An example of this is tlxenexample2 file, which uses Python
code to handle themid variable.

5.2 Network Configuration

For many users, the default installation should work “out of the box”. evimmpli-
cated network setups, for instance with multiple Ethernet interfaces andsting
bridging setups will require some special configuration.

The purpose of this section is to describe the mechanisms provided by xaihoint@
flexible configuration for Xen’s virtual networking.

5.2.1 Xen virtual network topology

Each domain network interface is connected to a virtual network interfaderr0
by a point to point link (effectively a “virtual crossover cable”). Thedevices are
namedvif <domid >. <vifid > (e.g.vif1.0  for the first interface in domain 1,
vif3.1  for the second interface in domain 3).

Traffic on these virtual interfaces is handled in domain 0 using standatck lnvech-
anisms for bridging, routing, rate limiting, etc. Xend calls on two shell script®te p
form initial configuration of the network and configuration of new virtudaenfaces.
By default, these scripts configure a single bridge for all the virtual iates. Arbi-
trary routing / bridging configurations can be configured by customiziagthipts, as
described in the following section.
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5.2.2 Xen networking scripts

Xen's virtual networking is configured by two shell scripts (by defaattvork-bridge
andvif-bridge ). These are called automatically by xend when certain events occur,
with arguments to the scripts providing further contextual information. Thegets

are found by default ivetc/xen/scripts . The names and locations of the scripts
can be configured iretc/xen/xend-config.sxp

network-bridge: This script is called whenever xend is started or stopped to respec-
tively initialize or tear down the Xen virtual network. In the default confagur
tion initialization creates the bridge ‘xen-br0’ and moves ethQ onto that hridge
modifying the routing accordingly. When xend exits, it deletes the Xen bridge
and removes eth0, restoring the normal IP and routing configuration.

vif-bridge: This script is called for every domain virtual interface and can configure
firewalling rules and add the vif to the appropriate bridge. By default, thds ad
and removes VIFs on the default Xen bridge.

Other example scripts are availabhetvork-route  andvif-route  , network-nat
andvif-nat ). For more complex network setups (e.g. where routing is required or
integrate with existing bridges) these scripts may be replaced with customizadtsa

for your site’s preferred configuration.

5.3 Driver Domain Configuration

5.3.1 PCI

Individual PCI devices can be assigned to a given domain (a PClrdtamain) to
allow that domain direct access to the PCI hardware.

While PCI Driver Domains can increase the stability and security of a sysyead-b
dressing a number of security concerns, there are some securitytisstiegmain that
you can read about in Section 9.2.

Compile-Time Setup

To use this functionality, ensure that the PCI Backend is compiled in to a pedle
domain (e.g. domain 0) and that the domains which will be assigned PCI deaces
the PCI Frontend compiled in. In XenLinux, the PCI Backend is availableutic
Xen configuration section while the PCI Frontend is under the architespgeific
"Bus Options” section. You may compile both the backend and the frontendhato
same kernel; they will not affect each other.
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PCI Backend Configuration - Binding at Boot

The PCI devices you wish to assign to unprivileged domains must be "Hidicen
your backend domain (usually domain 0) so that it does not load a davdrém. Use
the pciback.hide kernel parameter which is specified on the kernel command-line
and is configurable through GRUB (see Section 2.5). Note that devieawareally
hidden from the backend domain. The PCI Backend appears to the Lamorllas a
regular PCI device driver. The PCI Backend ensures that no otvizeddriver loads
for the devices by binding itself as the device driver for those deviggbdévices are
identified by hexadecimal slot/function numbers (on Linux, Ispei to determine
slot/function numbers of your devices) and can be specified with or wittheulPCl
domain:
(bus: sl ot. func) example(02:1d.3)
(domai n: bus: sl ot. func) example(0000:02:1d.3)

An example kernel command-line which hides two PCI devices might be:
root=/dev/sdad4 ro console=tty0 pciback.hide=(02:01.f)( 0000:04:1d.0)

PCI Backend Configuration - Late Binding

PCI devices can also be bound to the PCI Backend after boot throughaheal
binding/unbinding facilities provided by the Linux kernel in sysfs (allowimmg &
Xen user to give PCI devices to driver domains that were not specifiedeokernel
command-line). There are several attributes with the PCI Backend’s dirsictory
(/sys/busl/pci/drivers/pciback ) that can be used to bind/unbind devices:

slots lists all of the PCI slots that the PCI Backend will try to seize (or "hide” from
Domain 0). A PCI slot must appear in this list before it can be bound to the PCI
Backend through theind attribute.

new_slot write the name of a slot here (in 0000:00:00.0 format) to have the PCI Back-
end seize the device in this slot.

remove.slot write the name of a slot here (same formabhas_slot ) to have the PCI
Backend no longer try to seize devices in this slot. Note that this does nioidinb
the driver from a device it has already seized.

bind write the name of a slot here (in 0000:00:00.0 format) to have the Linux kernel
attempt to bind the device in that slot to the PCI Backend driver.

unbind write the name of a skit here (same formabasl ) to have the Linux kernel
unbind the device from the PCI Backend. DO NOT unbind a device while it is
currently given to a PCI driver domain!

Some examples:
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Bind a device to the PCI Backend which is not bound to any other driver.

# # Add a new slot to the PCI Backend’s list

# echo -n 0000:01:04.d > /sys/bus/pci/drivers/pciback/ne w_slot
# # Now that the backend is watching for the slot, bind to it
# echo -n 0000:01:04.d > /sys/bus/pci/drivers/pciback/bi nd

Unbind a device from its driver and bind to the PCI Backend.

# # Unbind a PCI network card from its network driver

# echo -n 0000:05:02.0 > /sys/bus/pci/drivers/3c905/unbi nd

# # And now bind it to the PCI Backend

# echo -n 0000:05:02.0 > /sys/bus/pci/drivers/pciback/ne w_slot
# echo -n 0000:05:02.0 > /sys/bus/pci/drivers/pciback/bi nd

Note that the "-n” option in the example is important as it causes echo to naitautp
new-line.

PCI Backend Configuration - User-space Quirks

Quirky devices (such as the Broadcom Tigon 3) may need write accessitaom-

figuration space registers. Xen can be instructed to allow specified R{Cedevrite

access to specific configuration space registers. The policy may be ifmun
letc/xen/xend-pci-quirks.sxp

The policy file is heavily commented and is intended to provide enough docutienta
for developers to extend it.

PCI Backend Configuration - Permissive Flag

If the user-space quirks approach doesn’'t meet your needs youmanatyto enable

the permissive flag for that device. To do so, first get the PCI domas),dbot, and

function information from domO vigspci . Then augment the user-space policy for

permissive devices. The permissive policy can be found in:
letc/xen/xend-pci-permissive.sxp

Currently, the only way to reset the permissive flag is to unbind the dewce tine
PCI Backend driver.

PCI Backend - Checking Status

There two important sysfs nodes that provide a mechanism to view spexcifopsirks
and permissive devices:

/sys/bus/drivers/pciback/permissive
Usecat on this file to view a list of permissive slots.
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[/sys/bus/drivers/pciback/quirks
Usecat on this file view a hierarchical view of devices bound to the PCI back-
end, their PCI vendor/device ID, and any quirks that are associatedtveth
particular slot.

You may notice that every device bound to the PCI backend has 17 qténkdasd
"quirks” regardless okend-pci-quirks.sxp . These default entries are necessary
to support interactions between the PCI bus manager and the devicetbatirieven
non-quirky devices should have these standard entries.

In this case, preference was given to accuracy over aesthetic®bgiog to show the
standard quirks in the quirks list rather than hide them from the inquiring use

PCI Frontend Configuration

To configure a domU to receive a PCI device:

Command-line: Use thepci command-line flag. For multiple devices, use the option
multiple times.
xm create netcard-dd pci=01:00.0 pci=02:03.0

Flat Format configuration file: Specify all of your PCI devices in a python list named
pCi.
pci=['01:00.0’,'02:03.0"]

SXP Format configuration file: Use a single PCI device section for all of your de-
vices (specify the numbers in hexadecimal with the preceding '0x’). Neate th
domainhere refers to the PCIl domain, not a virtual machine within Xen.

(device (pci
(dev (domain Ox0)(bus 0x3)(slot 0xla)(func Ox1)
(dev (domain 0x0)(bus Ox1)(slot 0x5)(func 0x0)

5.4 Support for virtual Trusted Platform Module (VTPM)

Paravirtualized domains can be given access to a virtualized version B#Ma This
enables applications in these domains to use the services of the TPM de\gzario
ple through a TSS stack The Xen source repository provides the necessary software
components to enable virtual TPM access. Support is provided threvehes differ-
ent pieces. First, a TPM emulator has been modified to provide TPM’s funaditip
for the virtual TPM subsystem. Second, a virtual TPM Manager codtekrnhe vir-
tual TPMs efforts, manages their creation, and provides protectedideage using

Trousers TSS stack: http://sourceforge.net/projects/trousers
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the TPM. Third, a device driver pair providing a TPM front- and backisnavailable

for XenLinux to deliver TPM commands from the domain to the virtual TPM man-
ager, which dispatches it to a software TPM. Since the TPM Manager cgliadHW
TPM for protected key storage, therefore this subsystem requiresux-supported
hardware TPM. For development purposes, a TPM emulator is availableséoon
non-TPM enabled platforms.

Compile-Time Setup

To enable access to the virtual TPM, the virtual TPM backend driver beusbmpiled
for a privileged domain (e.g. domain 0). Using the XenLinux configuratimmneces-
sary driver can be selected in the Xen configuration section. Unlessiviee lias been
compiled into the kernel, its module must be activated using the following command:

modprobe tpmbk

Similarly, the TPM frontend driver must be compiled for the kernel trying ® TBM
functionality. Its driver can be selected in the kernel configuration sedevice
Driver / Character Devices / TPM Devices. Along with that the TPM driee the
built-in TPM must be selected. If the virtual TPM driver has been compiledatule,
it must be activated using the following command:

modprobe tpm_xenu

Furthermore, it is necessary to build the virtual TPM manager and sofflirRive by
making changes to entries in Xen build configuration files. The following entilye
file Config.mk in the Xen root source directory must be made:

VTPM_TOOLS 2=y

After a build of the Xen tree and a reboot of the machine, the TPM backérelrdust

be loaded. Once loaded, the virtual TPM manager daemon must be stditeel be
TPM-enabled guest domains may be launched. To enable being the destofadio
virtual TPM Migration, the virtual TPM migration daemon must also be loaded.

vtpm_managerd
vtpm_migratord

Once the VTPM manager is running, the VTPM can be accessed by loadirfigptt
end driver in a guest domain.

Development and Testing TPM Emulator

For development and testing on non-TPM enabled platforms, a TPM emugatdrec
used in replacement of a platform TPM. First, the entry in the file tools/vtpm/Ruoikes
must look as follows:

BUILD_EMULATOR =y
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Second, the entry in the file tool/vtpmanager/Rules.mk must be uncommented as
follows:

# TCS talks to fifo's rather than /dev/tom. TPM Emulator assu med on fifos
CFLAGS += -DDUMMY_TPM

Before starting the virtual TPM Manager, start the emulator by executirfgiibeving
in domO:

tpm_emulator clear

VvTPM Frontend Configuration

To provide TPM functionality to a user domain, a line must be added to the virtual
TPM configuration file using the following format:

vtpm = [instance=<instance number>, backend=<domain id> |

The instance numbereflects the preferred virtual TPM instance to associate with the
domain. If the selected instance is already associated with another domasysthe
tem will automatically select the next available instance. An instance numbategre
than zero must be provided. It is possible to omit the instance parametertbem
configuration file.

The domain idprovides the ID of the domain where the virtual TPM backend driver
and virtual TPM are running in. It should currently always be set to '0’

Examples for valid vtpm entries in the configuration file are
vipm = [instance=1, backend=0’]
and

vtpm = [backend=0].

Using the virtual TPM

Access to TPM functionality is provided by the virtual TPM frontend driv&imilar

to existing hardware TPM drivers, this driver provides basic TPM stafasmation
through thesysfsfilesystem. In a Xen user domain the sysfs entries can be found in
/sys/devices/xen/vtpm-0.

Commands can be sent to the virtual TPM instance using the character fdievitpmO
(major 10, minor 224).
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Chapter 6

Storage and File System
Management

Storage can be made available to virtual machines in a number of differgat Wais
chapter covers some possible configurations.

The most straightforward method is to export a physical block devicerthdrave or
partition) from domO directly to the guest domain as a virtual block device (WBD

Storage may also be exported from a filesystem image or a partitioned filesysage
as afile-backed VBD

Finally, standard network storage protocols such as NBD, iSCSI, NEES,can be
used to provide storage to virtual machines.

6.1 Exporting Physical Devices as VBDs

One of the simplest configurations is to directly export individual partitisasmfdo-
main O to other domains. To achieve this use phg: specifier in your domain
configuration file. For example a line like

disk = ['phy:hda3,sdal,w’]

specifies that the partitiokev/hda3 in domain O should be exported read-write to
the new domain asdev/isdal ; one could equally well export it aglevihda or
/dev/sdb5 should one wish.

In addition to local disks and partitions, it is possible to export any devidd_ithax
considers to be “a disk” in the same manner. For example, if you have i3§lSI ar
GNBD volumes imported into domain 0 you can export these to other domains using
thephy: disk syntax. E.g.:

disk = ['phy:vg/lvml,sda2,w’]
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Warning: Block device sharing

Block devices should typically only be shared between domains in a read-
only fashion otherwise the Linux kernel’s file systems will get very con-
fused as the file system structure may change underneath them (having
the same ext3 partition mounted twice is a sure fire way to cause ir-
reparable damage)! Xend will attempt to prevent you from doing this
by checking that the device is not mounted read-write in domain 0, and
hasn’t already been exported read-write to another domain. If yoti wan
read-write sharing, export the directory to other domains via NFS from
domain O (or use a cluster file system such as GFS or ocfs2).

6.2 Using File-backed VBDs

Itis also possible to use a file in Domain 0 as the primary storage for a virtudlingac

As well as being convenient, this also has the advantage that the virtuklddoce

will be sparse— space will only really be allocated as parts of the file are used. So
if a virtual machine uses only half of its disk space then the file really takealfipth

the size allocated.

For example, to create a 2GB sparse file-backed virtual block devitea(lyconly
consumes no disk space at all):

# dd if=/dev/zero of=vmldisk bs=1k seek=2048k count=0
Make a file system in the disk file:

# mkfs -t ext3 vmldisk
(when the tool asks for confirmation, answer ‘y’)
Populate the file system e.g. by copying from the current root:

# mount -0 loop vmldisk /mnt
# cp -ax [{root,dev,var,etc,usr,bin,sbin,lib} /mnt
# mkdir /mnt/{proc,sys,home,tmp}

Tailor the file system by editingetc/fstab , letc/hostname , etc. Don't forget

to edit the files in the mounted file system, instead of your domain 0O filesystem, e.g.
you would edit/mnt/etc/fstab instead of/etc/fstab . For this example put
/dev/sdal to root in fstab.

Now unmount (this is important!):
# umount /mnt
In the configuration file set:

disk = [tap:aio:/full/path/to/vm1disk,sdal,w’]
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As the virtual machine writes to its ‘disk’, the sparse file will be filled in and cioms
more space up to the original 2GB.

Note: Users that have worked with file-backed VBDs on Xen in previous vessio
will be interested to know that this support is now provided through the biktipr
instead of the loopback driver. This change results in file-based blecices that
are higher-performance, more scalable, and which provide bettey safgerties for
VBD data. All that is required to update your existing file-backed VM caumfigjons
is to change VBD configuration lines from:

disk = [file:/full/path/to/vmldisk,sdal,w’]

to:
disk

['tap:aio:/full/path/to/vmldisk,sdal,w’]

6.2.1 Loopback-mounted file-backed VBDs (deprecated)

Note: Loopback mounted VBDs have now been replaced with blktap-basedrsupp
for raw image files, as described above. This section remains to detailfagacation
that was used by older Xen versions.

Raw image file-backed VBDs may also be attached to VMs using the Linux lokpba
driver. The only required change to the raw file instructions above aspeoify the
configuration entry as:

disk = [file:/full/path/to/vm1disk,sdal,w’]

Note that loopback file-backed VBDs may not be appropriate for baking 1/O-
intensive domains.This approach is known to experience substantial slowdowns un-
der heavy I/0 workloads, due to the I/O handling by the loopback blocicdaised

to support file-backed VBDs in dom0. Loopback support remains foiXeld instal-
lations, and users are strongly encouraged to use the blktap-basagfiets(using
“tap:aio " as described above).

Additionally, Linux supports a maximum of eight loopback file-backed VBD®ss
all domains by default. This limit can be statically increased by usingrtaeloop
module parameter if CONFIBLK _DEV_LOOP is compiled as a module in the domO
kernel, or by using thenaxloop=nboot option if CONFIGBLK _DEV_LOOP is com-
piled directly into the domO kernel. Again, users are encouraged to usdkthg-b
based file support described above which scales to much larger nurhbetive
VBDs.
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6.3 Using LVM-backed VBDs

A particularly appealing solution is to use LVM volumes as backing for domain file
systems since this allows dynamic growing/shrinking of volumes as well aslsoiap
and other features.

To initialize a partition to support LVM volumes:
# pvcreate /dev/sdalO

Create a volume group named ‘vg’ on the physical partition:
# vgcreate vg /dev/sdalO

Create a logical volume of size 4GB named ‘myvmdisk1’:
# Ivcreate -L4096M -n myvmdiskl vg

You should now see that you havedav/vg/myvmdiskl Make a filesystem, mount
it and populate it, e.g.:

# mkfs -t ext3 /dev/vg/myvmdiskl
# mount /dev/vg/myvmdiskl /mnt
# cp -ax / /mnt
# umount /mnt

Now configure your VM with the following disk configuration:
disk = [ ’phy:vg/myvmdiskl,sdal,w’ ]

LVM enables you to grow the size of logical volumes, but you'll need tizeethe
corresponding file system to make use of the new space. Some file systgnexi{@)
now support online resize. See the LVM manuals for more details.

You can also use LVM for creating copy-on-write (CoW) clones of LViElumes
(known as writable persistent snapshots in LVM terminology). This facilityeis
Linux 2.6.8, so isn't as stable as one might hope. In particular, using loBo@f
LVM disks consumes a lot of domO memory, and error conditions such aingiout
of disk space are not handled well. Hopefully this will improve in future.

To create two copy-on-write clones of the above file system you woulthes®llow-
ing commands:

# Ivcreate -s -L1024M -n myclonediskl /dev/vg/myvmdiskl
# Ivcreate -s -L1024M -n myclonedisk2 /dev/ivg/myvmdiskl

Each of these can grow to have 1GB of differences from the master voNouoecan
grow the amount of space for storing the differences using the lvextanchand, e.qg.:

# Ivextend +100M /dev/vg/myclonediskl

Don't let the ‘differences volume’ ever fill up otherwise LVM gets rathenfused. It
may be possible to automate the growing process by ulisgtup wait to spot the
volume getting full and then issue amextend
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In principle, it is possible to continue writing to the volume that has been clahed (
changes will not be visible to the clones), but we wouldn’'t recommend thige the
cloned volume as a ‘pristine’ file system install that isn’t mounted directly lyycdn
the virtual machines.

6.4 Using NFS Root

First, populate a root filesystem in a directory on the server machine. ahiseon a
distinct physical machine, or simply run within a virtual machine on the same node

Now configure the NFS server to export this filesystem over the netwoddtding a
line to/etc/exports , for instance:

/export/vmlroot 192.0.2.4/24 (rw,sync,no_root_squash)

Finally, configure the domain to use NFS root. In addition to the normal vasaybe
should make sure to set the following values in the domain’s configuration file:

root = ’ldevInfs’
nfs_server = '2.3.4.5 # substitute IP address of server
nfs_root = ’'/path/to/root’ # path to root FS on the server

The domain will need network access at boot time, so either statically comfegur
IP address using the config variablps netmask , gateway , hostname ; or enable
DHCP (dhcp="dhcp’ ).

Note that the Linux NFS root implementation is known to have stability problems
under high load (this is not a Xen-specific problem), so this configuratignmagbe
appropriate for critical servers.
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Chapter 7

CPU Management

Xen allows a domain’s virtual CPU(s) to be associated with one or more HIdsC
This can be used to allocate real resources among one or more guestanake
optimal use of processor resources when utilizing dual-core, hypearhng, or other

advanced CPU technologies.

Xen enumerates physical CPUs in a ‘depth first’ fashion. For a systembwith
hyperthreading and multiple cores, this would be all the hyperthreads iorraapre,
then all the cores on a given socket, and then all sockets. I.e. if yoa haol socket,
dual core, hyperthreaded Xeon the CPU order would be:

socket0 socketl
core0 corel core0 corel
htO | htl | htO | htl | htO | htl | htO | htl
#0 | #1 | #2 | #3 | #4 | #5 | #6 | #7

Having multiple vcpus belonging to the same domain mapped to the same physical

CPU is very likely to lead to poor performance. It's better to use ‘vcptist@dot-
unplug one of the vcpus and ensure the others are pinned on difteiPdrd.

If you are running IO intensive tasks, its typically better to dedicate eithemparh
thread or whole core to running domain 0, and hence pin other domainstdbdiia
can’t use CPU 0. If your workload is mostly compute intensive, you mayt teapin
vepus such that all physical CPU threads are available for guest demain

39



40



Chapter 8

Migrating Domains

8.1 Domain Save and Restore

The administrator of a Xen system may suspend a virtual machine’s cstegatinto
a disk file in domain 0, allowing it to be resumed at a later time.

For example you can suspend a domain called “VYM1" to disk using the command:
# xm save VM1 VM1.chk

This will stop the domain named “VM1” and save its current state into a file called
VM1.chk .

To resume execution of this domain, use the restore command:
# xm restore VM1.chk

This will restore the state of the domain and resume its execution. The domain will
carry on as before and the console may be reconnected usirgtltensole com-
mand, as described earlier.

8.2 Migration and Live Migration

Migration is used to transfer a domain between physical hosts. There areatw
eties: regular and live migration. The former moves a virtual machine fragrhost

to another by pausing it, copying its memory contents, and then resuming it on the
destination. The latter performs the same logical functionality but withoutinged

to pause the domain for the duration. In general when performing live tiggréhe
domain continues its usual activities and—from the user’s perspectivemitiration
should be imperceptible.

To perform a live migration, both hosts must be running Xen / xend andekiend-
tion host must have sufficient resources (e.g. memory capacity) to acatetenihe
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domain after the move. Furthermore we currently require both sourceesmtication
machines to be on the same L2 subnet.

Currently, there is no support for providing automatic remote access tgsfitens
stored on local disk when a domain is migrated. Administrators should choose a
appropriate storage solution (i.e. SAN, NAS, etc.) to ensure that domaiystitess

are also available on their destination node. GNBD is a good method for expartin
volume from one machine to another. iISCSI can do a similar job, but is more comple
to set up.

When a domain migrates, it's MAC and IP address move with it, thus it is only gessib
to migrate VMs within the same layer-2 network and IP subnet. If the destinatide n
is on a different subnet, the administrator would need to manually configguriéadole
etherip or IP tunnel in the domain 0 of the remote node.

A domain may be migrated using tlken migrate command. To live migrate a do-
main to another machine, we would use the command:

# xm migrate --live mydomain destination.ournetwork.com

Without the--live  flag, xend simply stops the domain and copies the memory image
over to the new node and restarts it. Since domains can have large allodhtfons
can be quite time consuming, even on a Gigabit network. With-tire  flag xend
attempts to keep the domain running while the migration is in progress, resulting in
typical down times of just 60-300ms.

For now it will be necessary to reconnect to the domain’s console on thenaehine
using thexm console command. If a migrated domain has any open network con-
nections then they will be preserved, so SSH connections do not havienitesion.
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Chapter 9

Securing Xen

This chapter describes how to secure a Xen system. It describes amfrabenarios
and provides a corresponding set of best practices. It begins wittias devoted to
understanding the security implications of a Xen system.

9.1 Xen Security Considerations

When deploying a Xen system, one must be sure to secure the managemairt do
(Domain-0) as much as possible. If the management domain is compromiseteall o
domains are also vulnerable. The following are a set of best practicBofoain-0:

1. Run the smallest number of necessary servicesThe less things that are
present in a management partition, the better. Remember, a service running
as root in the management domain has full access to all other domains on the
system.

2. Use a firewall to restrict the traffic to the management domain.A firewall
with default-reject rules will help prevent attacks on the management domain.

3. Do not allow users to access Domain-0The Linux kernel has been known
to have local-user root exploits. If you allow normal users to access Detna
(even as unprivileged users) you run the risk of a kernel exploit nya&ihof
your domains vulnerable.

9.2 Driver Domain Security Considerations

Driver domains address a range of security problems that exist iregdhe use of de-
vice drivers and hardware. On many operating systems in common use degae
drivers run within the kernel with the same privileges as the kernel. Fe&w arecha-
nisms exist to protect the integrity of the kernel from a misbehaving (reaggys’) or
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malicious device driver. Driver domains exist to aid in isolating a deviceedxithin
its own virtual machine where it cannot affect the stability and integrity ofrodioe
mains. If a driver crashes, the driver domain can be restarted ratherhtéve the
entire machine crash (and restart) with it. Drivers written by unknown tusted
third-parties can be confined to an isolated space. Driver domains ttrtesach num-
ber of security and stability issues with device drivers.

However, due to limitations in current hardware, a number of securityezoscemain
that need to be considered when setting up driver domains (it shouldée that the
following list is not intended to be exhaustive).

1. Without an IOMMU, a hardware device can DMA to memory regions out-
side of its controlling domain. Architectures which do not have an IOMMU
(e.g. most x86-based platforms) to restrict DMA usage by hardwareusmer-
able. A hardware device which can perform arbitrary memory reads atesw
can read/write outside of the memory of its controlling domain. A malicious or
misbehaving domain could use a hardware device it controls to send data ove
writing memory in another domain or to read arbitrary regions of memory in
another domain.

2. Shared buses are vulnerable to sniffingDevices that share a data bus can sniff
(and possible spoof) each others’ data. Device A that is assigned toiDéma
could eavesdrop on data being transmitted by Domain B to Device B and then
relay that data back to Domain A.

3. Devices which share interrupt lines can either prevent the receptio of that
interrupt by the driver domain or can trigger the interrupt servic e routine
of that guest needlessly.A devices which shares a level-triggered interrupt
(e.g. PCI devices) with another device can raise an interrupt and okazer
it. This effectively blocks other devices which share that interrupt lioenfr
notifying their controlling driver domains that they need to be serviced.\dicde
which shares an any type of interrupt line can trigger its interrupt cortinua
which forces execution time to be spent (in multiple guests) in the interrupt
service routine (potentially denying time to other processes within that guest).
System architectures which allow each device to have its own interrupt lipe (e
PCl's Message Signaled Interrupts) are less vulnerable to this dersalrate
problem.

4. Devices may share the use of /O memory address spac¥en can only re-
strict access to a device’s physical I/O resources at a certain grigulaor
interrupt lines and I/O port address space, that granularity is veryderanter-
rupt line and per I/O port). However, Xen can only restrict access taé@nory
address space on a page size basis. If more than one device skeanéa psage
in I/O memory address space, the domains to which those devices are dssigne
will be able to access the I/O memory address space of each other'ssievice
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9.3 Security Scenarios

9.3.1 The Isolated Management Network

In this scenario, each node has two network cards in the cluster. Onerketard is
connected to the outside world and one network card is a physically isolateabea
ment network specifically for Xen instances to use.

As long as all of the management partitions are trusted equally, this is the moget se
scenario. No additional configuration is needed other than forcing ¥ebuhd to the
management interface for relocation.

9.3.2 A Subnet Behind a Firewall

In this scenario, each node has only one network card but the entiterdits behind
a firewall. This firewall should do at least the following:

1. Prevent IP spoofing from outside of the subnet.

2. Prevent access to the relocation port of any of the nodes in the clxstept
from within the cluster.

The following iptables rules can be used on each node to prevent migratidhat
node from outside the subnet assuming the main firewall does not do tlyisuor

# this command disables all access to the Xen relocation
# port:
iptables -A INPUT -p tcp --destination-port 8002 -j REJECT

# this command enables Xen relocations only from the specifi

# subnet:

iptables -I INPUT -p tcp -{}-source 192.0.2.0/24 \
--destination-port 8002 -j ACCEPT

9.3.3 Nodes on an Untrusted Subnet

Migration on an untrusted subnet is not safe in current versions of Xemay be
possible to perform migrations through a secure tunnel via an VPN or Bi&Honly
safe option in the absence of a secure tunnel is to disable migration completely.
easiest way to do this is with iptables:

# this command disables all access to the Xen relocation port
iptables -A INPUT -p tcp -{}-destination-port 8002 -j REJEC T
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Chapter 10

sHype/Xen Access Control

The Xen mandatory access control framework is an implementation of theestiyp
pervisor Security Architecture (www.research.ibm.com/sisgpe). It permits or de-
nies communication and resource access of domains based on a sedigjty Tiwe
mandatory access controls are enforced in addition to the Xen core lspistioh as
memory protection. They are designed to remain transparent during noperaltion
of domains (policy-conform behavior) but to intervene when domains mot&de
their intended sharing behavior. This chapter will describe how the skigpess con-
trols in Xen can be configured to prevent viruses from spilling over foora into
another workload type and secrets from leaking from one workloadttyeother.
sHype/Xen depends on the correct behavior of Domain-0 (cf preioagter).

Benefits of configuring sHype/ACM in Xen include:
e robust workload and resource protection effective against rogeledomains

e simple, platform- and operating system-independent security policies {ateal
heterogeneous distributed environments)

¢ safety net with minimal performance overhead in case operating systenitgec
is missing, does not scale, or fails

These benefits are very valuable because today’s operating systeomebimcreas-
ingly complex and often have no or insufficient mandatory access cont(bls-
cretionary access controls, supported by most operating systemsptaedfactive
against viruses or misbehaving programs.) Where mandatory accessl exists
(e.g., SELinux), they usually deploy platform-specific, complex, and diffio un-
derstand security policies. Multi-tier applications in business environmeritatiyp
require different operating systems (e.g., AlX, Windows, Linux) in défd tiers. Re-
lated distributed transactions and workloads cannot be easily protectieel O level.
The Xen access control framework steps in to offer a coarse-grauneekery robust
and consistent security layer and safety net across different pretfand operating
systems.
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Figure 10.1: Overview of activating sHype workload protection in XerctiSe num-
bers point to representative examples.

To control sharing between domains, Xen mediates all inter-domain communicatio
(shared memory, events) as well as the access of domains to resauices storage
disks. Thus, Xen can confine distributed workloads (domain payloadsgtmitting
sharing among domains running the same type of workload and denyiriggbar
tween pairs of domains that run different workload types. We assumédtrirata
Xen perspective—only one workload type is running per user domaimnable Xen

to associate domains and resources with workload types, security ladatfimgcthe
workload types are attached to domains and resources. These labie Aggervisor
sHype controls cannot be manipulated or bypassed by user domaineeagfteative
even against compromised or rogue domains.

10.1 Overview

This section gives an overview of how workloads can be protected tsengHype
mandatory access control framework in Xen. Figure 10.1 shows thesgsayesteps
in activating the Xen workload protection. These steps are describedaithideSec-

tion 10.2.

First, the sHype/ACM access control must be enabled in the Xen distribuiththa
distribution must be built and installed (cf Subsection 10.2.1). Before weepan
force security, a Xen security policy must be created (cf Subsection2)@ad de-
ployed (cf Subsection 10.2.3). This policy defines the workload typesrdiitiated
during access control. It also defines the rules that compare worklpad tf do-
mains and resources to decide about access requests. Workloadnypepresented
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by security labels that can be securely associated to domains and ess@ifif8ubsec-
tions 10.2.4 and 10.2.5). The functioning of the active sHype/Xen worlpoatéction

is demonstrated using simple resource assignment, and domain creation tegis in S
section 10.2.6. Section 10.3 describes the syntax and semantics of the>&ktype
security policy in detail and introduces briefly the tools that are availablelpoylo®i
create your own sHype security policies.

The next section describes all the necessary steps to create, deplagsta simple
workload protection policy. It is meant to enable Xen users and developeuickly
try out the sHype/Xen workload protection. Those readers who aresgtégf in learn-
ing more about how the sHype access control in Xen works and how infsycmed
using the XML security policy should read Section 10.3 as well. Section 104 co
cludes this chapter with current limitations of the sHype implementation for Xen.

10.2 Xen Workload Protection Step-by-Step

You are about to configure and deploy the Xen sHype workload protelsyidollow-
ing 5 simple steps:

configure and install sHype/Xen

create a simple workload protection security policy

deploy the sHype/Xen security policy

associate domains and resources with workload labels,

e test the workload protection

The essential commands to create and deploy an sHype/Xen security pelityra-
bered throughout the following sections. If you want a quick-guidesturn at a later
time to go quickly through this demonstration, simply look for the nhumbered com-
mands and apply them in order.

10.2.1 Configuring/Building sHype Support into Xen

First, we need to configure the access control module in Xen and installGhé& A
enabled Xen hypervisor. This step installs security tools and compiles &Myl
controls into the Xen hypervisor.

To enable sHype/ACM in Xen, please edit the Config.mk file in the top Xen dimecto

(1) In Config.mk
Change: XSM_ENABLE ?= n
To: XSM_ENABLE 7=y

Change: ACM_SECURITY ?=n
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To: ACM_SECURITY ?=y
Then install the security-enabled Xen environment as follows:

(2) # make world
# make install

Reboot into the security-enabled Xen hypervisor.

(3) # reboot

Xen will boot into the default security policy. After reboot, you can exelibre simple
DEFAULT policy.

# xm getpolicy

Supported security subsystems . ACM

Policy name . DEFAULT
Policy type : ACM
Version of XML policy : 1.0

Policy configuration : loaded

# xm labels

SystemManagement

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

Domain-0 0 941 1 r----- 38.1 ACM:DEFAULT:SystemManagement

In this state, no domains can be started. Now, a policy can be created ded ioto
the hypervisor.

10.2.2 Creating A WLP Policy in 3 Simple Steps with ezPolicy

We will use the ezPolicy tool to quickly create a policy that protects worklodds

will need both the Python and wxPython packages to run this tool. To run tihe to
in Domain-0, you can download the wxPython package from www.wxpytrgror
use the commangum install wxPython in Redhat/Fedora. To run the tool on
MS Windows, you also need to download the Python package from wwwvapyty.
After these packages are installed, start the ezPolicy tool with the folloveimgrand:

(4) # xensec_ezpolicy

Figure 10.2 shows a screen-shot of the tool. The following steps illustoateybu

can create the workload definition shown in Figure 10.2. You carx@3eRL>-h to

pop up a help window at any time. The indicators (a), (b), and (c) in Fijor2 show
the buttons that are used during the 3 steps of creating a policy:

1. defining workloads
2. defining run-time conflicts

3. translating the workload definition into an sHype/Xen access controlpolic
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Defining workloads. Workloads are defined for each organization and department
that you enter in the left panel.

To ease the transition from an unlabeled to a fully labeled workload-proteetioi-
ronment, we have added support to sHype/Xen to run unlabeled domamssamy
unlabeled resources in addition to labeled domains accessing labelettessou

Support for running unlabeled domains on sHype/Xen is enabled by@tttnpre-
defined workload type and label UNLABELED__to the security policy. (This is a
double underscore followed by the strindRILABELEDfollowed by a double under-
score.) The ezPolicy tool automatically adds this organization-level watkigze to

a new workload definition (cf Figure 10.2). It can simply be deleted fronwibwkload
definition if no such support is desired. If unlabeled domains are stgapirthe pol-
icy, then any domain or resource that has no label will implicitly inherit this laiein
access control decisions are made. In effect, unlabeled domainssmuolaes define
a new workload type UNLABELED_, which is confined from any other labeled
workload.

Please use now the “New Org” button to add the organization workload t¥pes
Bank”, “B-Bank”, and “AutoCorp”.

You can refine an organization to differentiate between multiple departmekitioads
by right-clicking the organization and selectidgld Department (or selecting an
organization and pressirgCRTL>-a). Create department workloads “SecurityUn-
derwriting”, and “MarketAnalysis” for the “A-Bank”. The resulting laybof the tool
should be similar to the left panel shown in Figure 10.2.

M EZ Workload Protection Policy Tool Q@@|

File Edit Wiew Help

Organization / Department Run-time Exclusion Rules B

UNLABELED___

s —
} =~ add || _UNLABELED__
dpomk s S
SecurityUnderwriting E-Bank
«-- Del
n} MarketAnalysis
s B-Bank
\a AutoCorp
- __UNLABELED__ Q
A-Bank. Marketanalysis
A-Bank, SecurityUnderwriting

| Create run-time exclusion rule from selection —-> |

Figure 10.2: Final layout including workload definition and Run-time Exclusides.

Defining run-time conflicts. Workloads that shall be prohibited from running con-
currently on the same hypervisor platform are grouped into “Run-time Eiriuules”
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on the right panel of the window. Cautious users should include thiNLABELED
workload type in all run-time exclusion rules because any workload caudnside
unlabeled domains.

To prevent A-Bank and B-Bank workloads (including their departmenmtakloads)
from running simultaneously on the same hypervisor system, select theizatjen
“A-Bank” and, while pressing the CTRL>key, select the organization “B-Bank”. Be-
ing cautious, we also prevent unlabeled workloads from running withcdriiose
workloads by pressing theCTRL>key and selecting “UNLABELED_". Now
press the button named “Create run-time exclusion rule from selection”. pAgpo
window will ask for the name for this run-time exclusion rule (enter a name ohjus
<ENTER3. A rule will appear on the right panel. The name is used as refererige on
and does not affect access control decisions.

Please repeat this process to create another run-time exclusion rule tegartment
workloads “A-Bank.SecurityUnderwriting”, “A-Bank.MarketAnalysisAlso add the
“__UNLABELED __" workload type to this conflict set.

The resulting layout of your window should be similar to Figure 10.2. Savewbik-
load definition by selecting “Save Workload Definition as ...” in the “File” menkisT
workload definition can be later refined if required.

Translating the workload definition into an sHype/Xen access contropolicy. To
translate the workload definition into a access control policy understoebyplease
select the “Save as Xen ACM Security Policy” in the “File” menu. Enter the falg
policy name in the popup windownytest . If you are running ezPolicy in Domain-
0, the resulting policy file mytesgecurity-policy.xml will automatically be placed into
the right directory (/etc/xen/acm-security/policies/). If you run the toolruotlzer sys-
tem, then you need to copy the resulting policy file into Domain-0 before continuin
See Section 10.3.1 for naming conventions of security policies.

Note: The support for UNLABELED__domains and resources is meant to help transitioning from eontrolled
environment to a workload-protected environment by stanitf unlabeled domains and resources and then step-
by-step labeling domains and resources. Once all worklogdgbeled, the  UNLABELED__type can simply be
removed from the Domain-0 label or from the policy through agyalipdate. Section 10.3.5 will show how unlabeled

domains can be disabled by updating thgtest policy at run-time.

10.2.3 Deploying a WLP Policy

To deploy the workload protection policy we created in Section 10.2.2, wadecige
policy representation (mytest.bin), load it into the Xen hypervisor, and guamaiXen
to also load this policy during reboot.

The following command translates the source policy representation into atftivata
can be loaded into Xen with sHype/ACM support, activates the policy, anfigtoes
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this policy for future boot cycles into the boot sequence. Please rethetan man
page for further details:

(5) # xm setpolicy ACM mytest
Successfully set the new policy.
Supported security subsystems . ACM
Policy name : mytest
Policy type : ACM
Version of XML policy : 1.0
Policy configuration : loaded, activated for boot

Alternatively, if installing the policy fails (e.g., because it cannot identify tles Xoot
entry), you can manually install the policy in 3 steps a-c.

(Alternatively to 5 - step)aManually copy the policy binary file into the boot directory:

# cp /etc/xen/acm-security/policies/mytest.bin /boot/m ytest.bin

(Alternatively to 5 - step)YdManually add a module line to your Xen boot entry so that
grub loads this policy file during startup:

titte XEN Devel with 2.6.18.8

kernel /xen.gz

module /vmlinuz-2.6.18.8-xen root=/dev/sda3 ro console= tty0

module /initrd-2.6.18.8-xen.img

module /mytest.bin
(Alternatively to 5 - step)cReboot. Xen will choose the bootstrap label defined in the
policy as Domain-0 label during reboot. After reboot, you can re-labeh&in-0 at

run-time, cf Section 10.2.7.

Assuming that command (5) succeeded or you followed the alternativedtisirs
above, you should see the new policy and label appear when listing domains

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

Domain-0 0 941 1 r----- 81.5 ACM:mytest:SystemManagement

If the security label at the end of the line says “INACTIVE” then the sigus not
enabled. Verify the previous steps. Note: Domain-0 is assigned a difhelt(see
bootstrap  policy attribute explained in Section 10.3). All other domains must be
explicitly labeled, which we describe in detail below.

10.2.4 Labeling Unmanaged User Domains

Unmanaged domains are started in Xen by using a configuration file. Pifasdor
Section 10.2.8 if you are using managed domains.

The following configuration file definedomainl :

# cat domainl.xm

kernel= "/boot/vmlinuz-2.6.18.8-xen"
memory = 128

name = "domainl"
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vif =[]

dhcp = "dhcp”

disk = [file:’home/xen/dom_fc5/fedora.fc5.img,sdal,w oA
file:/home/xen/dom_fc5/fedora.fc5.swap,sda2,w’]

root = "/dev/sdal ro xencons=tty"

Every domain must be associated with a security label before it can statityqe/Xen.

Otherwise, sHype/Xen would not be able to enforce the policy consisteQiy

mytest policy is configured so that Xen assigns a default labéJNLABELED

to domains and resources that have no label and supports them in dledmtranner.

Since neither the domain, nor the resources are (yet) labeled, this domasgtach

under themytest policy:

# xm create domainl.xm
Using config file "./domainl.xm".
Started domain domainl

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl 1 128 1 -b---- 0.7 ACM:mytest:_ UNLABELED_
Domain-0 0 875 1 r----- 84.6 ACM:mytest:SystemManagement

Please shutdown domainl so that we can move it into the protection domainkaef wor
load A-Bank .

# xm shutdown domainl
(wait some seconds until the domain has shut down)

#xm list --label

Name ID Mem VCPUs State  Time(s) Label

Domain-0 0 875 1 r----- 86.4 ACM:mytest:SystemManagement

We assume that the processing in domainl contributes ta-Bank workload. We
explore now how to transition this domain into the “A-Bank” workload-protettio
The following command prints all domain labels available in the active policy:

# xm labels

A-Bank
A-Bank.MarketAnalysis
A-Bank.SecurityUnderwriting
AutoCorp

B-Bank

SystemManagement
__UNLABELED__

Now labeldomainl with the A-Bank label and anothélomain2 with the B-Bank
label. Please refer to the xm man page for further information.

(6) # xm addlabel A-Bank dom domainl.xm
# xm addlabel B-Bank dom domain2.xm

Let us try to start the domain again:

# xm create domainl.xm
Using config file "./domainl.xm".
Error: VM's access to block device ‘file:lhome/xen/dom_fc 5/fedora.fc5.img’ denied

This error indicates thalomainl , if started, would not be able to access its image
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and swap files because they are not labeled. This makes sense biecaoséne
workloads, access of domains to resources must be controlled. Otbedeimains
that are not allowed to communicate or run simultaneously could share dasglthro
storage resources.

10.2.5 Labeling Resources

You can use thexm labels type=res command to list available resource la-
bels. Let us assign the A-Bank resource label tadibimainl image file representing
/dev/sdal and to its swap file:

(7) # xm addlabel A-Bank res \
file:’home/xen/dom_fc5/fedora.fc5.img

# xm addlabel A-Bank res \
file:’home/xen/dom_fc5/fedora.fch5.swap

The following command lists all labeled resources on the system, e.g., to lookup o
verify the labeling:

# Xm resources
file:’home/xen/dom_fc5/fedora.fc5.swap
type: ACM
policy: mytest
label: A-Bank
file:/home/xen/dom_fc5/fedora.fc5.img
type: ACM
policy: mytest
label: A-Bank

Startingdomainl will now succeed:

# xm create domainl.xm
Using config file "./domainl.xm".
Started domain domainl

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl 3 128 1 -b---- 0.8 ACM:mytest:A-Bank
Domain-0 0 875 1 [ 90.9 ACM:mytest:SystemManagement

Currently, if a labeled resource is moved to another location, the label mstsbéi
manually removed, and after the move re-attached using the xm commmaladie|
andaddlabel respectively. Please see Section 10.4 for further details.

(8) Label the resources of domain2 as B-Bank
but please do not start this domain yet.

10.2.6 Testing The Xen Workload Protection

We are about to demonstrate the sHype/Xen workload protection by verifyin
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e that user domains with conflicting workloads cannot run simultaneously

e that user domains cannot access resources of workloads other ¢hametthey
are associated with

e that user domains cannot exchange network packets if they are ncizses
with the same workload type (not yet supported in Xen)

Test 1: Run-time exclusion rules. We assume thatomainl with the A-Bank la-

bel is still running. Whiledomainl is running, the run-time exclusion set of our
policy implies thatdomain2 cannot start because the labelddmainl includes

the CHWALL type A-Bank and the label @omain2 includes the CHWALL type B-
Bank. The run-time exclusion rule of our policy enforces that A-BarnkBuBank can-

not run at the same time on the same hypervisor platform. Once domainl is&toppe
saved, or migrated to another platfordomain2 can start. Oncdomain2 is started,
however,domainl can no longer start or resume on this system. When creating the
Chinese Wall types for the workload labels, the ezPolicy tool policy translaton-
ponent ensures that department workloads inherit all the organizapies {gnd with

it any organization exclusions).

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl 3 128 1 -b---- 0.8 ACM:mytest:A-Bank
Domain-0 0 875 1 [----- 90.9 ACM:mytest:SystemManagement

# xm create domain2.xm
Using config file "./domain2.xm".
Error: 'Domain in conflict set with running domains’

# xm shutdown domainl
(wait some seconds until domain 1 is shut down)

# xm list --label
Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 873 1 r----- 95.3 ACM:mytest:SystemManagement

# xm create domain2.xm
Using config file "./domain2.xm".

Started domain domain2

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domain2 5 164 1 -b---- 0.3 ACM:mytest:B-Bank
Domain-0 0 839 1 r----- 96.4 ACM:mytest:SystemManagement

# xm create domainl.xm
Using config file "domainl.xm".
Error: 'Domain in conflict with running domains’

# xm shutdown domain2

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

Domain-0 0 839 1 [----- 97.8 ACM:mytest:SystemManagement
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You can verify that domains with AutoCorp label can run together with domains
beled A-Bank or B-Bank.

Test2: Resource access.In this test, we will re-label the swap file falomainl

with theB-Bank resource label. In a real environment, the swap file must be sanitized
(scrubbed/zeroed) before it is reassigned to prevent data leakdHeoA-Bank to the
B-Bank workload through the swap file.

We expect thatlomainl will no longer start because it cannot access this resource.
This test checks the sharing abilities of domains, which are defined by théeSiyme
Enforcement Policy component.

# xm rmlabel res file:lhome/xen/dom_fc5/fedora.fc5.swap
# xm addlabel B-Bank res file:’home/xen/dom_fc5/fedora.f c5.swap

# xm resources
file:’home/xen/dom_fc5/fedora.fc5.swap
type: ACM
policy: mytest
label: B-Bank
file:’home/xen/dom_fc5/fedora.fc5.img
type: ACM
policy: mytest
label: A-Bank

# xm create domainl.xm

Using config file "./domainl.xm".

Error:

VM'’'s access to block device ‘file:’home/xen/dom_fc5/fedo ra.fc5.swap’ denied

The resource authorization checks are performed before the domainadastarted
so that failures during the startup are prevented. A domain is only startéidtiea

resources specified in its configuration are accessible.

Test 3: Communication. In this test we would verify that two domains with labels
A-Bank and B-Bank cannot exchange network packets by usingitig @nnectivity
test. Itis also related to the STE polidyote: sHype/Xen does control direct commu-
nication between domains. However, domains associated with differekloads can
currently still communicate through the Domain-0 virtual network. We are ingrk
on the sHype/ACM controls for local and remote network traffic througmBio-0.
Please monitor the xen-devel mailing list for updated information.

10.2.7 Labeling Domain-0 —or— Restricting System Authoriz&éon

The major use case for explicitly labeling or relabeling Domain-0 is to restriekor
tend which workload types can run on a virtualized Xen system. This enidlése
partitioning of the physical infrastructure as well as the workloads rgnamit in a
multi-platform environment.
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In case no Domain-0 label is explicitly stated, we automatically assigned Dontlaa-0
SystemManagement label, which includes all STE (workload) types that are known
to the policy. In effect, the Domain-0 label authorizes the Xen system to miyn o
those workload types, whose STE types are included in the Domain-0 labateH
choosing thesystemManagement label for Domain-0 permits any labeled domain
to run. Resetting the label for Domain-0 at boot or run-time to a label with setulf
the known STE workload types restricts which user domains can run onystens.

If Domain-0 is relabeled at run-time, then the new label must at least inclug8& &
types of those domains that are currently running. The operation failsatige This
requirement ensures that the system remains in a valid security configuaétto re-
labelling.

Restricting the Domain-0 authorization through the label creates a flexibleypolic
driven way to strongly partition the physical infrastructure and the waddaunning
on it. This partitioning will be automatically enforced during migration, start, er re
sume of domains and simplifies the security management considerably. Sitongly
peting workloads can be forced to run on separate physical infrasteugnd become
less depend on the domain isolation capabilities of the hypervisor.

First, we relabel the swap image back to A-Bank and then start up domainl:

# xm rmlabel res file:/home/xen/dom_fc5/fedora.fc5.swap

# xm addlabel A-Bank res file:’lhome/xen/dom_fc5/fedora.f c5.swap

# xm create domainl.xm

Using config file "./domainl.xm".

Started domain domainl

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl 7 128 1 -b---- 0.7 ACM:mytest:A-Bank
Domain-0 0 839 1 r----- 103.1 ACM:mytest:SystemManagement

The following command will restrict the Xen system to only run STE types indude
in the A-Bank label.

# xm addlabel A-Bank mgt Domain-0
Successfully set the label of domain 'Domain-0' to 'A-Bank’

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 839 1 r----- 103.7 ACM:mytest:A-Bank
domainl 7 128 1 -b---- 0.7 ACM:mytest:A-Bank

In our example policy in Figure 10.4, this means that oAlBank domains and
workloads (types) can run after the successful completion of this comimecalise

the A-Bank label includes only a single STE type, nam@hBank . This command
fails if any running domain has an STE type in its label that is not included in the
A-Bank label.

If we now label a domain3 with AutoCorp, it cannot start because DomasnF®
longer authorized to run the workload typetoCorp .
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# xm addlabel AutoCorp dom domain3.xm
(remember to label its resources, too)

# xm create domain3.xm
Using config file "./domain3.xm".

Error: VM is not authorized to run.

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 839 1 [ 104.7 ACM:mytest:A-Bank
domainl 7 128 1 -b---- 0.7 ACM:mytest:A-Bank

At this point, unlabeled domains cannot start either. Let domain4.xm desarib
unlabeled domain, then trying to start domain4 will fail:

# xm getlabel dom domain4.xm
Error: 'Domain not labeled’

# xm create domain4.xm
Using config file "./domain4.xm".
Error: VM is not authorized to run.

Relabeling Domain-0 with the SystemManagement label will enable domain3 to start.

# xm addlabel SystemManagement mgt Domain-0
Successfully set the label of domain 'Domain-0’ to 'SystemM anagement’.

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl 7 128 1 -b---- 0.8 ACM:mytest:A-Bank
Domain-0 0 839 1 [----- 106.6 ACM:mytest:SystemManagement

# xm create domain3.xm
Using config file "./domain3.xm".
Started domain domain3

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

domainl 7 128 1 -b---- 0.8 ACM:mytest:A-Bank

domain3 8 164 1 -b---- 0.3 ACM:mytest:AutoCorp
Domain-0 0O 711 1 r----- 107.6 ACM:mytest:SystemManagement

10.2.8 Labeling Managed User Domains

Xend has been extended with functionality to manage domains along with their con
figuration information. Such domains are configured and started via Xdrcalls.
Since managed domains do not have an associated xm configuration fijdtieg
addlabel command, which adds the security label into a domain’s configuration
file, will not work for such managed domains.

Therefore, we have extended tkem addlabel andxm rmlabel subcommands
to enable adding security labels to and removing security labels from maudaged
main configurations. The following example shows how 8ank label can be
assigned to the xend-managed domain configuratiatoofainl . Removing labels
from managed user domain configurations works similarly.

Below, we show a dormant configuration of the managed domainl withllD and

state"----- before labeling:
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# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl -1 128 N 0.0 ACM:mytest:_ UNLABELED__
Domain-0 0 711 1 r----- 128.4 ACM:mytest:SystemManagement

Now we label the managed domain:

# xm addlabel A-Bank mgt domainl
Successfully set the label of the dormant domain 'domainl’ t o 'A-Bank’.

After labeling, you can see that the security label is part of the domaingeoafion:

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
domainl -1 128 1 - 0.0 ACM:mytest:A-Bank
Domain-0 0 711 1 r----- 129.7 ACM:mytest:SystemManagement

This command extension does not support relabeling of individual rgruser do-
mains for several reasons. For one, because of the difficulty to eenasdources in
cases where a running domain’s new label does not permit accestooes that
were accessible under the old label. Another reason is that changindgpéheia sin-

gle domain of a workload is rarely a good choice and will affect the workisalation

properties of the overall workload.

However, the name and contents of the label associated with running dooaains
be indirectly changed through a global policy change, which will updatevtiee
workload consistently (domains and resources), cf. Section 10.3.5.

10.3 Xen Access Control Policy

This section describes the sHype/Xen access control policy in detailels gnough
information to enable the reader to write custom access control policies asd the
available Xen policy tools. The policy language is expressive enoughetifgpnost
symmetric access relationships between domains and resources efficiently.

The Xen access control policy consists of two policy components. Thecbrat
ponent, called Simple Type Enforcement (STE) policy, controls the shagtween
running domains, i.e., communication or access to shared resourcescbmel €om-
ponent, called Chinese Wall (CHWALL) policy, controls which domains aamgi-
multaneously on the same virtualized platform. The CHWALL and STE policy com-
ponents complement each other. The XML policy file includes all informatiedee

by Xen to enforce those policies.

Figures 10.3 and 10.4 show the fully functional but very simple example ¥eurity
policy that is created by ezPolicy as shown in Figure 10.2. The policy ctinglissh
the 6 workload types shown in lines 11-17 in Fig. 10.3. The whole XML Sscur
Policy consists of four parts:

1. Policy header including the policy name

2. Simple Type Enforcement block
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01 <?xml version="1.0" ?>

02 <!-- Auto-generated by ezPolicy -->

03 <SecurityPolicyDefinition ...">

04 <PolicyHeader>

05 <PolicyName>mytest</PolicyName>

06 <Date>Mon Nov 19 22:51:56 2007</Date>
07 <Version>1.0</Version>

08 </PolicyHeader>

09 <SimpleTypeEnforcement>

10 <SimpleTypeEnforcementTypes>

11 <Type>SystemManagement</Type>

12 <Type>_ UNLABELED__ </Type>

13 <Type>A-Bank</Type>

14 <Type>A-Bank.SecurityUnderwriting</Type>
15 <Type>A-Bank.MarketAnalysis</Type>
16 <Type>B-Bank</Type>

17 <Type>AutoCorp</Type>

18 </SimpleTypeEnforcementTypes>

19 </SimpleTypeEnforcement>

20 <ChineseWall priority="PrimaryPolicyComponent">
21 <ChineseWallTypes>

22 <Type>SystemManagement</Type>

23 <Type>__ UNLABELED__</Type>

24 <Type>A-Bank</Type>

25 <Type>A-Bank.SecurityUnderwriting</Type>
26 <Type>A-Bank.MarketAnalysis</Type>
27 <Type>B-Bank</Type>

28 <Type>AutoCorp</Type>

29 </ChineseWallTypes>

30 <ConflictSets>

31 <Conflict name="RER">

32 <Type>A-Bank</Type>

33 <Type>B-Bank</Type>

34 <Type>__ UNLABELED__</Type>
35 </Conflict>

36 <Conflict name="RER">

37 <Type>A-Bank.MarketAnalysis</Type>
38 <Type>A-Bank.SecurityUnderwriting</Type>
39 <Type>__ UNLABELED__</Type>
40 </Conflict>

41 </ConflictSets>

42 </ChineseWall>

Figure 10.3: Example XML security policy file — Part I: Types and Rulesid&sn.

3. Chinese Wall Policy block
4. Label definition block

10.3.1 Policy Header and Policy Name

Lines 1-2 (cf Figure 10.3) include the usual XML header. The secunticy def-
inition starts in Line 3 and refers to the policy schema. The XML-Schema defini-
tion for the Xen policy can be found in the filetc/xen/acm-security/policies/security-
policy.xsd Examples for security policies can be found in the example subdirectory.
The acm-security directory is only installed if ACM security is configured duim
stallation (cf Section 10.2.1).

ThePolicy Header spans lines 4-8. It includes a date field and defines the policy
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namemytest as well as the version of the XML. It can also include optional fields
that are not shown and are for future use (see schema definition).

The policy name serves two purposes: First, it provides a unique nambeae-
curity policy. This name is also exported by the Xen hypervisor to the Xen man-
agement tools in order to ensure that both the Xen hypervisor and Doneaifefte

the same policy. We plan to extend the policy name with a digital fingerprint of the
policy contents to better protect this correlation. Second, it implicitly points the xm
tools to the location where the XML policy file is stored on the Xen system. Re-
placing the colons in the policy name by slashes yields the local path to the plaicy fi
starting from the global policy directovgtc/xen/acm-security/policies .

The last part of the policy name is the prefix for the XML policy file name, com-
pleted by-security _policy.xml . Our example policy with the nanmaytest

can be found in the XML policy file hamenhytest-security policy.xml

that is stored under the global policy directory. Another, preinstalledhpie pol-

icy namedexample.test  can be found in théest-security_policy.xml
under/etc/xen/acm-security/policies/example

10.3.2 Simple Type Enforcement Policy Component

The Simple Type Enforcement (STE) policy controls which domains can coticaten
or share resources. This way, Xen can enforce confinement &faaoktypes by con-
fining the domains running those workload types and their resourcesan@hdatory
access control framework enforces its policy when domains accesdésteommu-
nication or cooperation means (shared memory, events, shared essuct as block
devices). It builds on top of the core hypervisor isolation, which resttftsvays of
inter-communication to those intended means. STE does not protect or intprad to
tect from covert channels in the hypervisor or hardware; this is agotial problem
that can be mitigated by using the Run-time Exclusion rules described abde or
fixing the problem leading to those covert channels in the core hypexis@mrdware
platform.

Xen controls sharing between domains on the resource and domain leaelleehis
is the abstraction the hypervisor and its management understand naturailg.thiis

is coarse-grained, it is also very reliable and robust and it requires nliclmages
to implement mandatory access controls in the hypervisor. It enables plathmd

operating system-independent policies as part of a layered securityagbp

Lines 11-17 (cf Figure 10.3) define the Simple Type Enforcement polioypoment.
Essentially, they define the workload type nargstemManagement , A-Bank ,
AutoCorp etc. that are available in the STE policy component. The policy rules are
implicit: Xen permits two domains to communicate with each other if and only if their
security labels have at least one STE type in common. Similarly, Xen permits a use
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domain to access a resource if and only if the labels of the domain and theaeso
have at least one STE workload type in common.

10.3.3 Chinese Wall Policy Component

The Chinese Wall security policy interpretation of sHype enables usersven cer-
tain workloads from running simultaneously on the same hypervisor platfBum-
time Exclusion rules (RER), also called Conflict Sets or Anti-Collocation ralefine

a set of workload types that are not permitted to run simultaneously on thevdame
tualized platform. Of all the workloads specified in a Run-time Exclusion rule, a
most one type can run on the same hypervisor platform at a time. Run-timeskexciu
Rules implement a less rigorous variant of the original Chinese Wall seaaity
ponent. They do not implement the *-property of the policy, which wouldiiregto
restrict also types that are not part of an exclusion rule once theyiangng together
with a type in an exclusion rule (http://www.gammassl.co.uk/topics/chinesewall.html
provides more information on the original Chinese Wall policy).

Xen considers th€hineseWallTypes  part of the label for the enforcement of the
Run-time Exclusion rules. It is illegal to define labels including conflicting Céeéne
Wall types.

Lines 20-41 (cf Figure 10.3) define the Chinese Wall policy componened #2-28
define the known Chinese Wall types, which coincide here with the STE tigfesed
above. This usually holds if the criteria for sharing among domains anthghafrthe
hardware platform are the same. Lines 30-41 define one Run-time Exchudés, the
first of which is depicted below:

31 <Conflict name="RER">

32 <Type>A-Bank</Type>

33 <Type>B-Bank</Type>

34  <Type>_ UNLABELED__ </Type>

35 </Conflict>

Based on this rule, Xen enforces that only one of the typd¥ank , B-Bank , or
__UNLABELED__ will run on a single hypervisor platform at a time. For exam-
ple, once a domain assigneddaBank workload type is started, domains with the
B-Bank type or unlabeled domains will be denied to start. When the former domain
stops and no other domains with tAeBank type are running, then domains with the

B-Bank type or unlabeled domains can start.

Xen maintains reference counts on each running workload type to kexdofrevhich
workload types are running. Every time a domain starts or resumes, thermefecount

on those Chinese Wall types that are referenced in the domain’s labetezmented.
Every time a domain is destroyed or saved, the reference counts of itss€hive!
types are decremented. sHype in Xen fully supports migration and live-tioigra
which is subject to access control the same way as saving a domain on tiee sou
platform and resuming it on the destination platform.
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Here are some reasons why users might want to restrict workloadsvaie from
sharing the system hardware simultaneously:

e Imperfect resource management or control might enable a compromised us
domain to starve other domains and the workload running in them.

e Redundant user domains might run the same workload to increase availability;
such domains should not run on the same hardware to avoid single points of
failure.

e Imperfect Xen core domain isolation might enable two rogue domains running
different workload types to use unintended and unknown ways (tolrannels)
to exchange some bits of information. This way, they bypass the policedcXen a
cess control mechanisms. Such imperfections cannot be completely eliminated
and are a result of trade-offs between security and other desigimaeggnts.
For a simple example of a covert channel see http://www.multicians.org/timing-
chn.html. Such covert channels exist also between workloads runnidiffen
ent platforms if they are connected through networks. The Xen Chinedle W
policy provides an approximated “air-gap” between selected workloagbtyp

10.3.4 Security Labels

To enable Xen to associate domains with workload types running in them, eactird
is assigned a security label that includes the workload types of the domain.

The SecurityLabelTemplate (cf Figure 10.4) defines the security labels that
can be associated with domains and resources when this policy is actées¢h@us
xm labels type=any command described in Section 10.2.4 to list all available
labels).

The domain labels include Chinese Wall types while resource labels do rmadénc
Chinese Wall types. Th&ubjectLabels policy section defines the labels that
can be assigned to domains. The VM laBeBank.SecurityUnderwriting

in Figure 10.4) associates the domain that carries it with the workload STE type
A-Bank.SecurityUnderwriting and with the CHWALL typesA-Bank and
A-Bank.SecurityUnderwriting . The ezPolicy tool assumes that any depart-
ment workload will inherit any conflict set that is specified for its orgatidrs i.e.,

if B-Bank is running, not onlyA-Bank but also all its departmental workloads are
prevented from running by this first run-time exclusion set. The separafi®TE
and CHWALL types in the label definition ensures that all departmentalloads are
isolated from each other and from their generic organization workleguke they are
sharing CHWALL types to simplify the formulation of run-time exclusion sets.

Thebootstrap  attribute of the<SubjectLabels> XML node in our example
policy shown in Figure 10.4 names the lalSgistemManagement as the label that
Xen will assign to Domain-0 at boot time (if this policy is installed as boot policyle T
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<SecurityLabelTemplate>
<SubjectLabels bootstrap="SystemManagement">
<VirtualMachineLabel>
<Name>SystemManagement</Name>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
<Type>_UNLABELED__</Type>
<Type>A-Bank</Type>
<Type>A-Bank.SecurityUnderwriting</Type>
<Type>A-Bank.MarketAnalysis</Type>
<Type>B-Bank</Type>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>SystemManagement</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>__UNLABELED__</Name>
<SimpleTypeEnforcementTypes>
<Type>_ UNLABELED__</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>_UNLABELED__</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>A-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>A-Bank.SecurityUnderwriting</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.SecurityUnderwriting</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
<Type>A-Bank.SecurityUnderwriting</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>A-Bank.MarketAnalysis</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.MarketAnalysis</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
<Type>A-Bank.MarketAnalysis</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>B-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>B-Bank</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>B-Bank</Type>
</ChineseWallTypes>
</VirtualMachineLabel>

<VirtualMachineLabel>
<Name>AutoCorp</Name>
<SimpleTypeEnforcementTypes>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>AutoCorp</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
</SubjectLabels>
<ObjectLabels>
<ResourcelLabel>
<Name>SystemManagement</Name>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name>__UNLABELED__</Name>
<SimpleTypeEnforcementTypes>
<Type>_UNLABELED__</Type>
</SimpleTypeEnforcementTypes>
</ResourcelLabel>
<ResourceLabel>
<Name>A-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name>A-Bank.SecurityUnderwriting</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.SecurityUnderwriting</Type>
</SimpleTypeEnforcementTypes>
</ResourcelLabel>
<ResourcelLabel>
<Name>A-Bank.MarketAnalysis</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.MarketAnalysis</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name>B-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>B-Bank</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name>AutoCorp</Name>
<SimpleTypeEnforcementTypes>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
</ResourcelLabel>
</ObjectLabels>
</SecurityLabelTemplate>
</SecurityPolicyDefinition>

Figure 10.4: Example XML security policy file — Part II: Label Definition.

label of Domain-0 can be persistently changed at run-time witlatiibabel com-

mand, which adds an overriding option to the grub.conf boot entry (dfd®et0.2.7).

All user domains are assigned labels according to their domain configu¢stiersec-
tion 10.2.4 for examples of how to label domains).

TheObjectLabels  depicted in Figure 10.4 can be assigned to resources when this
policy is active.

In general, user domains should be assigned labels that have only a Simgike-
TypeEnforcement workload type. This way, workloads remain confined & user
domains become rogue. Any domain that is assigned a label with multiple STE types
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must be trusted to keep information belonging to the different STE typesadeeon-
fined). For example, Domain-0 is assigned the bootstrap &semManagement ,

which includes all existing STE types. Therefore, Domain-0 must takenar® en-
able unauthorized information flow (eg. through block devices or virteadarking)
between domains or resources that are assigned different STE types.

Security administrators simply use the name of a label (specified kiNlene>field)

to associate a label with a domain (cf. Section 10.2.4). The types inside thautabe
used by the Xen access control enforcement. While the name can berdyhlitrasen

(as long as it is unique), it is advisable to choose the label name in accertathe
security types included. Similarly, the STE and CHWALL types should be named
according to the workloads they represent. While the XML representatithre dabel

in the above example seems unnecessary flexible, labels in general maldeke
include multiple types.

We assume in the following example, th&tBank.SecurityUnderwriting
andA-Bank.MarketAnalysis workloads use virtual disks that are provided by a
virtual I/O domain hosting a physical storage device and carrying the fiolgplabel:

<VirtualMachineLabel>
<Name>VIOServer</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank</Type>
<Type>A-Bank.SecurityUnderwriting</Type>
<Type>A-Bank.MarketAnalysis</Type>
<Type>VIOServer</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>VIOServer</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
This Virtual 1/0 domain (VIO) exports its virtualized disks by communicating to all
domains labeled with thé&-Bank.SecurityUnderwriting , the A-Bank , or
the A-Bank.MarketAnalysis label. This requires the VIO domain to carry those
STE types. In addition, this label includes a néDServer type that can be used

to restrict direct access to the physical storage resource to the VIGBoma

In this example, the confinement of these A-Bank workloads dependsdri@do-
main that must keep the data of those different workloads separate.irfied disks

are labeled as well to keep track of their assignments to workload typesSésee
tion 10.2.5 for labeling resources) and enforcement functions inside Bed@imain
must ensure that the labels of the domain mounting a virtual disk and the viidk#he

bel share a common STE type. The VIO label carrying its own VIOSertBNELL

type introduces the flexibility to permit the trusted VIO server to run together with
A-Bank.SecurityUnderwriting or A-Bank.MarketAnalysis workloads.

Alternatively, a system that has two hard-drives does not need a ¥ih@auh but can
directly assign one hardware storage device to each of the workloads pfatform
offers an 10-MMU, cf Section 9.2. Sharing hardware through virtudlidevices is a
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trade-off between the amount of trusted code (size of the trusted comatsed and
the amount of acceptable over-provisioning. This holds both for peaghand for
system platforms.

10.3.5 Managing sHype/Xen Security Policies at Run-time
Removing the sHype/Xen Security Policy

When resetting the policy, no labeled domains can be running. Please stogdown
all running labeled domains. Then you can reset the policy to the defdidy psing
theresetpolicy command:

# xm getpolicy

Supported security subsystems : ACM

Policy name ;. mytest

Policy type : ACM

Version of XML policy : 1.0

Policy configuration : loaded, activated for boot

# xm resetpolicy
Successfully reset the system’s policy.

# xm getpolicy

Supported security subsystems : ACM
Policy name . DEFAULT
Policy type : ACM

Version of XML policy : 1.0

Policy configuration : loaded

# Xxm resources
file:’home/xen/dom_fc5/fedora.fc5.swap
type: INV_ACM
policy: mytest
label: A-Bank
file:’home/xen/dom_fc5/fedora.fc5.img
type: INV_ACM
policy: mytest
label: A-Bank
As thexm resources output shows, all resource labels have invalidated type in-
formation but their semantics remain associated with the resources so tha@they
later on either be relabeled with semantically equivalent labels or sanitize¢ ased

(storage resources).

At this point, the system is in the same initial state as after configuring XSM and
sHype/ACM and rebooting the system without a specific policy. No user mhsncan
run.

Changing to a Different sHype/Xen Security Policy

The easiest way to change to a different, unrelated policy is to resetgtesrspolicy
and then set the new policy. Please consider that the existing domain auudcees
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labels become invalid at this point. Please refer to the next section for arpéxaf
how to seamlessly update an active policy at run-time without invalidating labels.
# xm resetpolicy

Successfully reset the system’s policy.

# xm setpolicy ACM example.test
Successfully set the new policy.

Supported security subsystems : ACM

Policy name . example.test

Policy type : ACM

Version of XML policy : 1.0

Policy configuration : loaded, activated for boot

# xm labels

CocaCola

PepsiCo

SystemManagement

VIO

# xm list --label

Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 873 1 r----- 56.3 ACM:example.test:SystemManag ement

# xm resetpolicy
Successfully reset the system’s policy.

# xm getpolicy
Supported security subsystems : ACM

Policy name : DEFAULT
Policy type : ACM
Version of XML policy : 1.0

Policy configuration : loaded

# xm list --label
Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 873 1 [ 57.2 ACM:DEFAULT:SystemManagement

# xm setpolicy ACM mytest

Successfully set the new policy.

Supported security subsystems : ACM

Policy name . mytest

Policy type : ACM

Version of XML policy : 1.0

Policy configuration : loaded, activated for boot

# xm labels

A-Bank
A-Bank.MarketAnalysis
A-Bank.SecurityUnderwriting
AutoCorp

B-Bank

SystemManagement

_ UNLABELED__

# xm list --label
Name ID Mem VCPUs State  Time(s) Label
Domain-0 0 873 1 f----- 58.0 ACM:mytest:SystemManagement

The described way of changing policies by resetting the existing policy fsiluee
testing different policies. For real deployment environments, a policyatgpds de-
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scribed in the following section is more appropriate and can be applied sshndés
run-time while user domains are running.

Update an sHype/Xen Security Policy at Run-time

Once an ACM security policy is activated (loaded into the Xen hyperviiug)policy
may be updated at run-time without the need to re-boot the system. The Xti#tasp
policy contains several additional information fields that are required fedysknk
the new policy contents to the old policy and ensure a consistent transfonnaétio
the system security state from the old to the new policy. Those additional &sdds
required for policies that are updating an existing policy at run-time.

The major benefit of policy updates is the ability to add, delete, or renamdoaork
types, labels, and conflict sets (run-time exclusion rules) to accommodaigeain
the managed virtual environment without the need to reboot the Xen systhen s
new policy renames labels of the current policy, the labels attached torcescand
domains are automatically updated during a successful policy update.

We have manually crafted an update policy formmgest security policy and stored
it in the file mytestupdate-securitypolicy.xml in the policies directory. We will dis-
cuss this policy in detail before using it to update a running sHype/Xenraysthe
following figures contain the whole contents of the update policy file.

Figure 10.5 shows the policy header of an update-policy and theFnemPolicy

XML node. For the policy update to succeed, the policy name and the poliey ve
sion fields of thé=romPolicy XML node must exactly match those of the currently
enforced policy. This ensures a controlled update path of the policy.

<?xml version="1.0" encoding="UTF-8"?>
<l-- Auto-generated by ezPolicy -->
<SecurityPolicyDefinition xmlns="http://www.ibm.com"
xmins:xsi="http://www.w3.0rg/2001/XMLSchema-instanc e"
xsi:schemalocation="http://www.ibm.com ../../securit y_policy.xsd ">
<PolicyHeader>
<PolicyName>mytest</PolicyName>
<Date>Tue Nov 27 21:53:45 2007</Date>
<Version>1.1</Version>
<FromPolicy>
<PolicyName>mytest</PolicyName>
<Version>1.0</Version>
</FromPolicy>
</PolicyHeader>

Figure 10.5: XML security policy update — Part I: Updated Policy Header.

The version number of the new policy, which is shown in the node followin@tte
node, must be a logical increment to the current policy’s version. Tdrerat least the
minor number of the policy version must be incremented. This ensures tledicg p
update is applied only to exactly the policy for which this update was creatd an
minimizes unforseen side-effects of policy updates.
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Types and Conflic Sets The type names and the assignment of types to labels or
conflict sets (run-time exclusion rules) can simply be changed consistertiygthout

the policy. Types, as opposed to labels, are not directly associatdd@meed outside

the policy so they do not need to carry their history in a “From” field. Theré&gu
below shows the update for the types and conflict sets. TRiNLABELED__type

is removed to disable support for running unlabeled domains. Additionadhyhave
renamed the twé-Bank department types with abbreviated namAeBank.SU and
A-Bank.MA . You can also see how those type names are consistently changed within
the conflict set definition.

<SimpleTypeEnforcement>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
<Type>A-Bank</Type>
<Type>A-Bank.SU</Type>
<Type>A-Bank.MA</Type>
<Type>B-Bank</Type>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
</SimpleTypeEnforcement>

<ChineseWall priority="PrimaryPolicyComponent">

<ChineseWallTypes>
<Type>SystemManagement</Type>
<Type>A-Bank</Type>
<Type>A-Bank.SU</Type>
<Type>A-Bank.MA</Type>
<Type>B-Bank</Type>
<Type>AutoCorp</Type>

</ChineseWallTypes>

<ConflictSets>
<Conflict name="RER">
<Type>A-Bank</Type>
<Type>B-Bank</Type>
</Conflict>
<Conflict nhame="RER">
<Type>A-Bank.MA</Type>
<Type>A-Bank.SU</Type>
</Conflict>
</ConflictSets>
</ChineseWall>

Figure 10.6: XML security policy update — Part II: Updated Types annfli@ Sets.

In the same way, new types can be introduced and new conflict sets dafified by
simply adding the types or conflict sets to the update policy.

Labels Virtual machine and resource labels of an existing policy can be deleted
through a policy update simply by omitting them in the update-policy. However, if
a currently running virtual machine or a currently used resource is ldeth a label

not stated in the update-policy, then the policy update is rejected. Thisesribat a
policy update leaves the system in a consistent security state.

A policy update also enables the renaming of virtual machine and resolreks.la
Linking the old label name with the new label name is achieved throughdhe at-
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tribute in theVirtualMachineLabel

or ResourcelLabel

nodes in the update-

policy. Figure 10.7 shown how subject and resource labels are upatedheir old

nameA-Bank.SecurityUnterwriting
thefrom attribute.

<SecurityLabelTemplate>
<SubjectLabels bootstrap="SystemManagement">
<VirtualMachineLabel>
<Name>SystemManagement</Name>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
<Type>A-Bank</Type>
<Type>A-Bank.SU</Type>
<Type>A-Bank.MA</Type>
<Type>B-Bank</Type>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>SystemManagement</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>A-Bank-WL</Name>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
<Type>A-Bank</Type>
<Type>A-Bank.SU</Type>
<Type>A-Bank.MA</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>SystemManagement</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>A-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name from="A-Bank.SecurityUnderwriting">
A-Bank.SU</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.SU</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
<Type>A-Bank.SU</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name from="A-Bank.MarketAnalysis">
A-Bank.MA</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.MA</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>A-Bank</Type>
<Type>A-Bank.MA</Type>
</ChineseWallTypes>
</VirtualMachineLabel>

to their new namé\-Bank.SU using

<VirtualMachineLabel>
<Name>B-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>B-Bank</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>B-Bank</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
<VirtualMachineLabel>
<Name>AutoCorp</Name>
<SimpleTypeEnforcementTypes>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
<ChineseWallTypes>
<Type>AutoCorp</Type>
</ChineseWallTypes>
</VirtualMachineLabel>
</SubjectLabels>

<ObjectLabels>
<ResourcelLabel>
<Name>SystemManagement</Name>
<SimpleTypeEnforcementTypes>
<Type>SystemManagement</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name>A-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name from="A-Bank.SecurityUnderwriting">
A-Bank.SU</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.SU</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
<ResourcelLabel>
<Name from="A-Bank.MarketAnalysis">
A-Bank.MA</Name>
<SimpleTypeEnforcementTypes>
<Type>A-Bank.MA</Type>
</SimpleTypeEnforcementTypes>
</ResourcelLabel>
<ResourcelLabel>
<Name>B-Bank</Name>
<SimpleTypeEnforcementTypes>
<Type>B-Bank</Type>
</SimpleTypeEnforcementTypes>
</ResourcelLabel>
<ResourceLabel>
<Name>AutoCorp</Name>
<SimpleTypeEnforcementTypes>
<Type>AutoCorp</Type>
</SimpleTypeEnforcementTypes>
</ResourceLabel>
</ObjectLabels>
</SecurityLabelTemplate>
</SecurityPolicyDefinition>

Figure 10.7: XML security policy update — Part 1ll: Updated Label Di&fin.

The updated label definition also includes a new lab&ank-WL that includes all
STE types related to A-Bank. Its CHWALL type BystemManagement . This
indicates that this label is designed as Domain-0 label. A Xen system casthetesl
to only run A-Bank related workloads by relabeling Domain-0 with AhBank-WL

label.

We assume that the update-policy shown in Figures 10.5, 10.6 and 10.&id isttine
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XML file mytest update-securitypolicy.xml located in the ACM policy directory. See

Section 10.3.1 for information about policy names and locations.

The followingxm setpolicy = command updates the active ACM security policy at

run-time.
# xm list --label
Name ID Mem VCPUs State Time(s) Label
domainl 2 128 1 -b---- 0.6 ACM:mytest:A-Bank
domain4 3 164 1  -b-- 0.3 ACM:mytest:A-Bank.SecurityUnde rwriting
Domain-0 0O 711 1 r----- 71.8 ACM:mytest:SystemManagement
# xm resources
file:’home/xen/dom_fc5/fedora.fc5.swap
type: ACM
policy: mytest
label:  A-Bank
file:’home/xen/dom_fc5/fedora.fc5.img
type: ACM
policy: mytest
label: A-Bank
# xm setpolicy ACM mytest_update
Successfully set the new policy.
Supported security subsystems : ACM
Policy name . mytest
Policy type : ACM
Version of XML policy : 1.1
Policy configuration : loaded, activated for boot
# xm list --label
Name ID Mem VCPUs State  Time(s) Label
domainl 2 128 1 -b---- 0.7 ACM:mytest:A-Bank
domain4 3 164 1 -b---- 0.3 ACM:mytest:A-Bank.SU
Domain-0 0 711 1 [----- 72.8 ACM:mytest:SystemManagement
# xm labels
A-Bank
A-Bank-WL
A-Bank.MA
A-Bank.SU
AutoCorp
B-Bank
# Xxm resources
file:’home/xen/dom_fc5/fedora.fc5.swap
type: ACM
policy: mytest
label: A-Bank
file:’home/xen/dom_fc5/fedora.fc5.img
type: ACM
policy: mytest
label: A-Bank
After successful completion of this commanahn list --label shows that the

labels of running domains changed to their new names.labels shows that new
labelsA-Bank.SU andA-Bank.AM are now available in the policy. The resource

labels remain valid after the successful updaterasresources confirms.
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Thesetpolicy  command fails if the new policy is inconsistent with the current one
or the policy is inconsistent internally (e.g., types are renamed in the typetidefin
but not in the label definition part of the policy). In this case, the old pokgyains
active.

After relabeling Domain-0 with the new-Bank-WL label, we can no longer run
domains labele®-Bank or AutoCorp since their STE types are not a subset of the
new Domain-0 label.

# xm addlabel A-Bank-WL mgt Domain-0

Successfully set the label of domain 'Domain-0’ to 'A-Bank- WL'.

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

domainl 2 128 1 -b---- 0.8 ACM:mytest:A-Bank
Domain-0 0 711 1 r----- 74.5 ACM:mytest:A-Bank-WL
domain4 3 164 1 -b---- 0.3 ACM:mytest:A-Bank.SU

# xm getlabel dom domain3.xm
policytype=ACM,policy=mytest,label=AutoCorp

# xm create domain3.xm
Using config file "./domain3.xm".

Error: VM is not authorized to run.

# xm addlabel SystemManagement mgt Domain-0
Successfully set the label of domain 'Domain-0’ to 'SystemM anagement’.

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

domainl 2 128 1 -b---- 0.8 ACM:mytest:A-Bank

domain4 3 164 1 -b---- 0.3 ACM:mytest:A-Bank.SU
Domain-0 0 709 1 [----- 76.4 ACM:mytest:SystemManagement

# xm create domain3.xm
Using config file "./domain3.xm".
Started domain domain3

# xm list --label

Name ID Mem VCPUs State  Time(s) Label

domainl 2 128 1 -b---- 0.8 ACM:mytest:A-Bank

domain4 3 164 1 -b---- 0.3 ACM:mytest:A-Bank.SU
domain3 4 164 1 -b---- 0.3 ACM:mytest:AutoCorp

Domain-0 0 547 1 [----- 77.5 ACM:mytest:SystemManagement

In the same manner, you can add new labels to support new workloadsdndelete,
or rename workload types (STE and/or CHWALL types) simply by changiegm-
position of labels. Another use case is to add new workload types to thenturr
Domain-0 label to enable them to run. Conflict sets (run-time exclusion rofes)
be simply omitted or added. The policy and label changes become activeeaind
new workloads can be run in protected mode without rebooting the Xemsyste

In all these cases, if any running user domain would—under the new pobtype
allowed to run or would not be allowed to access any of the resourceasently uses,
then the policy update is rejected. In this case, you can stop domains tffiattaeith
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the new policy and update the policy afterwards. The old policy remainsaantitl a
policy update succeeds or Xen is re-booted into a new policy.

10.3.6 Tools For Creating sHype/Xen Security Policies

To create a security policy for Xen, you can use one of the following tools:
e ezPolicy GUI tool — start writing policies
e xensec_gen tool — refine policies created wigzPolicy
e text or XML editor

We use theezPolicy tool in Section 10.2.2 to quickly create a workload protection
policy. If desired, the resulting XML policy file can be loaded into ¥emsec_gen

tool to refine it. It can also be directly edited using an XML editor. Any XMLipp

file is verified against the security policy schema when it is translated (dese&u
tion 10.2.3).

10.4 Current Limitations

The sHype/ACM configuration for Xen is work in progress. There isodmgywork for
protecting virtualized resources and planned and ongoing work foegting access
to remote resources and domains. The following sections describe limitatisomef
of the areas into which access control is being extended.

10.4.1 Network Traffic

Local and remote network traffic is currently not controlled. Solutions tbshtl/pe/ACM
policy enforcement to the virtual network exist but need to be discusstuiebthey
can become part of Xen. Subjecting external network traffic to the AGMri#tg pol-
icy is work in progress. Manually setting up filters in domain 0 is required dov but
does not scale well.

10.4.2 Resource Access and Usage Control

Enforcing the security policy across multiple hypervisor systems and ossado
remote shared resources is work in progress. Extending access| tcomew types of
resources is ongoing work (e.g. network storage).

On a single Xen system, information about the association of resourceseunity la-
bels is stored ifvar/lib/xend/security/policies/resource_labels
This file relates a full resource path with a security label. This associatioadk wnd
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will break if resources are moved or renamed without adapting the lahelrfifgov-
ing the protection of label-resource relationships is ongoing work.

Controlling resource usage and enforcing resource limits in generabrmanwork
in the Xen community.

10.4.3 Domain Migration

Labels on domains are enforced during domain migration and the destinapen hy
visor will ensure that the domain label is valid and the domain is permitted to run
(considering the Chinese Wall policy rules) before it accepts the migratiowever,

the network between the source and destination hypervisor as well alsypattvisors
must be trusted. Architectures and prototypes exist that both protecttivenk con-
nection and ensure that the hypervisors enforce access contsidtemly but patches
are not yet available for the main stream.

10.4.4 Covert Channels

The sHype access control aims at system independent security pdlibigids on top

of the core hypervisor isolation. Any covert channels that exist in the legpervisor

or in the hardware (e.g., shared processor cache) will be inheritetho3é covert
channels are not the result of trade-offs between security and gttensproperties,
then they are most effectively minimized or eliminated where they are caudgde s
offers however some means to mitigate their impact, e.g., run-time exclusionefiles (
Section 10.2.2) or limiting the system authorization (cf Section 10.2.7).
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Chapter 11

Build and Boot Options

This chapter describes the build- and boot-time options which may be used to tailo
your Xen system.

11.1 Top-level Configuration Options

Top-level configuration is achieved by editing one of two filesnfig.mk andMakefile

The former allows the overall build target architecture to be specified.withtypi-
cally not need to modify this unless you are cross-compiling. Additional gordtion
options are documented in tlenfig.mk file.

The top-leveMakefile is chiefly used to customize the set of kernels built. Look for
the line:

KERNELS ?= linux-2.6-xen0 linux-2.6-xenU

Allowable options here are any kernels which have a correspondingdarifiguration
file in the buildconfigs/ directory.

11.2 Xen Build Options

Xen provides a number of build-time options which should be set as envirdnme
variables or passed on make’s command-line.

verbose=y Enable debugging messages when Xen detects an unexpected condition.
Also enables console output from all domains.

debug=y Enable debug assertions. Impliesrbose=y (Primarily useful for tracing
bugs in Xen).

debugger=y Enable the in-Xen debugger. This can be used to debug Xen, guest OSe
and applications.
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perfc=y Enable performance counters for significant events within Xen. Thetsou
can be reset or displayed on Xen's console via console control keys.

11.3 Xen Boot Options

These options are used to configure Xen'’s behaviour at runtime. Tuoeydsbe ap-
pended to Xen’s command line, either manually or by edigindp.conf

noreboot Don't reboot the machine automatically on errors. This is useful to catch
debug output if you aren’t catching console messages via the serial line.

nosmp Disable SMP support. This option is implied by ‘ignorebiostables’.
watchdog Enable NMI watchdog which can report certain failures.

noirgbalance Disable software IRQ balancing and affinity. This can be used on
systems such as Dell 1850/2850 that have workarounds in hardwalieQ@e
routing issues.

badpage=<page number>,<page number>, ... Specify a list of pages not to be
allocated for use because they contain bad bytes. For example, if yourrgnemo
tester says that byte 0x12345678 is bad, you would place ‘badpat234x’
on Xen's command line.

serial_tx_buffer=<size> Size of serial transmit buffers. Default is 16kB.

coml=<baud>,DPS<io_base>,<irq > com2=<baud>,DPSxio_base>,<irq >

Xen supports up to two 16550-compatible serial ports. For example: ‘cO600;
8nl, 0x408, 5’ maps COML1 to a 9600-baud port, 8 data bits, no parity,pl sto
bit, 1/0 port base 0x408, IRQ 5. If some configuration options are standa
(e.g., /0 base and IRQ), then only a prefix of the full configuration strizepn
be specified. If the baud rate is pre-configured (e.g., by the bootloidwderyou
can specify ‘auto’ in place of a numeric baud rate.

console=cspecifier list> Specify the destination for Xen console I/O. This is a comma-
separated list of, for example:

vga Use VGA console (until domain 0 boots, unlegsgm=...keepis specified).
coml Use serial port coml.

com2H Use serial port com2. Transmitted chars will have the MSB set. Re-
ceived chars must have MSB set.

com2L Use serial port com2. Transmitted chars will have the MSB cleared.
Received chars must have MSB cleared.

The latter two examples allow a single port to be shared by two subsystems
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(e.g. console and debugger). Sharing is controlled by MSB of eackntitin
ted/received character. [NB. Default for this option is ‘com1,vga’]

vga=<mode>(,keep) The mode is one of the following options:
ask Display a vga menu allowing manual selection of video mode.
current Use existing vga mode without modification.

text-<mode> Select text-mode resolution, where mode is one of 80x25, 80x28,
80x30, 80x34, 80x43, 80x50, 80x60.

gfx-<mode> Select VESA graphics modewidth>x<height-x<depth> (e.g.,
‘vga=gfx-1024x768x32).

mode<mode> Specify a mode humber as discovered by ‘vga ask’. Note that
the numbers are displayed in hex and hence must be prefixed by ‘@’ her
(e.g., ‘vga=mode-0x0335’).

The mode may optionally be followed bykeep to cause Xen to keep writing
to the VGA console after domain 0 starts booting (e.g., ‘'vga=text-80x50)keep

no-real-mode (x86 only) Do not execute real-mode bootstrap code when booting
Xen. This option should not be used except for debugging. It willotiffely
disable thevga option, which relies on real mode to set the video mode.

edid=no,force (x86 only) Either force retrieval of monitor EDID information via
VESA DDC, or disable it (edid=no). This option should not normally be re-
guired except for debugging purposes.

edd=off,on,skipmbr (x86 only) Control retrieval of Extended Disc Data (EDD) from
the BIOS during boot.

consoleto_ring Place guest console output into the hypervisor console ring buffer.
This is disabled by default. When enabled, both hypervisor output aest gu
console output is available from the ring buffer. This can be usefubfgying
and/or remote presentation of console data.

sync.console Force synchronous console output. This is useful if you system fails
unexpectedly before it has sent all available output to the console. lincasss
Xen will automatically enter synchronous mode when an exceptional egent o
curs, but this option provides a manual fallback.

conswitch=<switch-char><auto-switch-char> Specify how to switch serial-console
input between Xen and DOMO. The required sequence is CXRWitch-char-
pressed three times. Specifying the backtick character disables switdtiag.
<auto-switch-chas specifies whether Xen should auto-switch input to DOMO
when it boots — if it is ‘X’ then auto-switching is disabled. Any other value, or
omitting the character, enables auto-switching. [NB. Default switch-chatjis

loglvi=<level> / <level> Specify logging level. Messages of the specified severity
level (and higher) will be printed to the Xen console. Valid levels are ‘hoee
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ror’, ‘warning’, ‘info’, ‘debug’, and ‘all’. The second level sgpdier is optional:
it is used to specify message severities which are to be rate limited. Default is
‘loglvi=warning’.

guestloglvl=<level> / <level> As for loglvl, but applies to messages relating to
guests. Default is ‘guedbglvl=none/warning’.

consoletimestamps Adds a timestamp prefix to each line of Xen console output.

nmi=xxx Specify what to do with an NMI parity or I/O error.
‘nmi=fatal’: Xen prints a diagnostic and then hangs.
‘nmi=dom0’: Inform DOMO of the NMI.
‘nmi=ignore’: Ignore the NMI.

mem=xxx Set the physical RAM address limit. Any RAM appearing beyond this
physical address in the memory map will be ignored. This parameter may be
specified with a B, K, M or G suffix, representing bytes, kilobytes, metgby
and gigabytes respectively. The default unit, if no suffix is specifiddidbytes.

domO_.mem=<specifier list> Set the amount of memory to be allocated to domain
0. This is acomma-separated list containing the following optional components:

min: <min_amt> Minimum amount to allocate to domain O
max:;<min_amt> Maximum amount to allocate to domain O
<amt> Precise amount to allocate to domain O

Each numeric parameter may be specified with a B, K, M or G suffix, repre-
senting bytes, kilobytes, megabytes and gigabytes respectively; if fig suf
specified, the parameter defaults to kilobytes. Negative values are cebtra
from total available memory. l&amt> is not specified, it defaults to all avail-
able memory less a small amount (clamped to 128MB) for uses such as DMA
buffers.

domO.vcpus pin Pins domain 0 VCPUs on their respective physical CPUS (de-
fault=false).

tbuf _size=xxx Set the size of the per-cpu trace buffers, in pages (default 0).

sched=xxx Select the CPU scheduler Xen should use. The current possibilities are
‘credit’ (default), and ‘sedf’.

apic_verbosity=debug,verbose Print more detailed information about local APIC
and IOAPIC configuration.

lapic Force use of local APIC even when left disabled by uniprocessoSBIO
nolapic Ignore local APIC in a uniprocessor system, even if enabled by the BIOS

apic=bigsmp,default,es7000,summitSpecify NUMA platform. This can usually
be probed automatically.

dma_bits=xxx Specify width of DMA addresses in bits. This is used in NUMA
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systems to prevent this special DMA memory from being exhausted in oree nod
when remote nodes have available memory.

vcpu_migration _delay=<minimum _time> Set minimum time of vcpu migration in
microseconds (default 0). This parameter avoids agressive vcputimigrior
example, the linux kernel uses 0.5ms by default.

In addition, the following options may be specified on the Xen command line. Since

domain 0 shares responsibility for booting the platform, Xen will automaticallggro

gate these options to its command line. These options are taken from Linoxsaad-

line syntax with unchanged semantics.

acpi=off,force,strict,ht,noirq,... Modify how Xen (and domain 0) parses the BIOS
ACPI tables.

acpi_skip_timer _override Instruct Xen (and domain 0) to ignore timer-interrupt over-
ride instructions specified by the BIOS ACPI tables.

noapic Instruct Xen (and domain 0) to ignore any IOAPICs that are presengin th
system, and instead continue to use the legacy PIC.

11.4 XenLinux Boot Options

In addition to the standard Linux kernel boot options, we support:
xencons=xxx Specify the device node to which the Xen virtual console driver is
attached. The following options are supported:

‘xencons=off"; disable virtual console

‘xencons=tty’: attach console to /dev/tty1 (ttyO at boot-time)
‘xencons=ttyS’: attach console to /dev/ttySO
‘xencons=xvc’: attach console to /dev/xvcO

The default is ttyS for domO and xvc for all other domains.
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Chapter 12

Further Support

If you have questions that are not answered by this manual, the saircgsrma-
tion listed below may be of interest to you. Note that bug reports, suggestiwhs
contributions related to the software (or the documentation) should be setX@n
developers’ mailing list (address below).

12.1 Other Documentation

For developers interested in porting operating systems to XeXghdnterface Man-
ual is distributed in thalocs/ directory of the Xen source distribution.

12.2 Online References

The official Xen web site can be found at:
http://www.xen.org

This contains links to the latest versions of all online documentation, includimg th
latest version of the FAQ.

Information regarding Xen is also available at the Xen Wiki at
http://wiki.xensource.com/xenwiki/

The Xen project uses Bugzilla as its bug tracking system. You'll find theB{egzilla
at http://bugzilla.xensource.com/bugzilla/.
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12.3 Mailing Lists

There are several mailing lists that are used to discuss Xen related topiegndst
widely relevant are listed below. An official page of mailing lists and subgorip
information can be found at

http://lists.xensource.com/

xen-devel@lists.xensource.consed for development discussions and bug reports.
Subscribe at:
http://lists.xensource.com/xen-devel

xen-users@lists.xensource.corUsed for installation and usage discussions and re-
guests for help. Subscribe at:
http://lists.xensource.com/xen-users

xen-announce@lists.xensource.cortysed for announcements only. Subscribe at:
http://lists.xensource.com/xen-announce

xen-changelog@lists.xensource.cor@hangelog feed from the unstable and 3.x trees
- developer oriented. Subscribe at:
http://lists.xensource.com/xen-changelog
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Appendix A

Unmodified (HVM) guest domains
In Xen with Hardware support for
Virtualization

Xen supports guest domains running unmodified guest operating syssamgsvir-
tualization extensions available on recent processors. Currentlygsasefeaturing
the Intel Virtualization Extension (Intel-VT) or the AMD extension (AMD-\Wessup-
ported. The technology covering both implementations is called HVM (for \arel
Virtual Machine) in Xen. More information about the virtualization extensiares
available on the respective websitagp://www.intel.com/technology/computing/vptech

http://www.amd.com/us-en/assets/content _type/white  _papers _and _tech _docs/24593.pdf

A.1 Building Xen with HVM support

The following packages need to be installed in order to build Xen with HVM sttpp
Some Linux distributions do not provide these packages by default.
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Package Description

dev86 The dev86 package provides an assembler and linker for red mo
80x86 instructions. You need to have this package installed in order
to build the BIOS code which runs in (virtual) real mode.
If the dev86 package is not available on the @6 distri-
bution, you can install the i386 version of it. The dev86
rom package for various distributions can be found at
http:/iwww.rpmfind.net/linux/rpm2html/search.php?qu ery=dev86&submit=Search

SDL-devel, SDL Simple DirectMedia Layer (SDL) is another way of virtualjzine un-
modified guest console. It provides an X window for the guest console.
If the SDL and SDL-devel packages are not installed by
default on the build system, they can be obtained from
http://www.rpmfind.net/linux/rpm2html/search.php?qu ery=SDL&amp;submit=Search
http://www.rpmfind.net/linux/rpm2html/search.php?qu ery=SDL-devel&submit=Search

A.2 Configuration file for unmodified HVM guests

The Xen installation includes a sample configuration fé/xen/xmexample.hvm

There are comments describing all the options. In addition to the common optédns th
are the same as those for paravirtualized guest configurations, HV# gofigura-
tions have the following settings:
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Parameter
kernel
builder
acpi

apic

pae

hap

vif

disk

boot

devicemodel
sdl

vnc
vncconsole

serial

Description

The HVM firmware loadefusr/lib/xen/boot/hvmloader

The domain build function. The HVM domain uses the 'hvm’ builder.
Enable HVM guest ACPI, default=1 (enabled)

Enable HVM guest APIC, default=1 (enabled)

Enable HVM guest PAE, default=1 (enabled)

Enable hardware-assisted paging support, such as AMD-Vitedhes
paging or InteRVT's extended paging. If available, Xen will use
hardware-assisted paging instead of shadow paging for this guest’s
memory management.
Optionally defines MAC address and/or bridge for the network inter-
faces. Random MACs are assigned if not giveype=ioemu means
ioemu is used to virtualize the HVYM NIC. If no type is specified, vbd is
used, as with paravirtualized guests.

Defines the disk devices you want the domain to have access to, and
what you want them accessible as. If using a physical device as the
HVM guest’s disk, each disk entry is of the form
phy:UNAME,ioemu:DEV,MODE,

where UNAME is the host device file, DEV is the device name the do-
main will see, and MODE is r for read-only, w for read-write. ioemu
means the disk will use ioemu to virtualize the HVM disk. If not adding
ioemu, it uses vbd like paravirtualized guests.

If using disk image file, its form should be like
file:FILEPATH,ijoemu:DEV,MODE

Optical devices can be emulated by appending cdrom to the device type
",hdc:cdrom,r’

If using more than one disk, there should be a comma between each disk
entry. For example:

disk = [file:/var/images/imagel.img,ioemu:hda,w’,

‘phy:hdal,hdbl,w’, ‘file:/var/images/installl.iso,hd c:cdrom,r’]

Boot from floppy (a), hard disk (c) or CD-ROM (d). For exampite

boot from CD-ROM and fallback to HD, the entry should be:
boot="dc’
The device emulation tool for HVM guests. This parameter should not
be changed.
Enable SDL library for graphics, default = 0 (disabled)
Enable VNC library for graphics, default = 1 (enabled)
Enable spawning of the vncviewer (only valid when vnadefgult = 0
(disabled)
If vnc=1 and vncconsole=0, user can use vncviewer to manually cbnne
HVM from remote. For example:
vhcviewer domain0  _IP _address:HVM _domain _id
Enable redirection of HVM serial output to pty device
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usb Enable USB support without defining a specific USB device. This
option defaults to 0 (disabled) unless the option usbdevice is spec-
ified in which case this option then defaults to 1 (enabled).

usbdevice  Enable USB support and also enable support for thedgvere.
Devices that can be specified areuse (a PS/2 style mouse),
tablet (an absolute pointing device) arbst:id1:id2 (a
physical USB device on the host machine whose idsdareand
id2 ). The advantage ahblet is that Windows guests will au-
tomatically recognize and support this device so specifying the

config line
usbdevice=tablet’

will create a mouse that works transparently with Windows guests
under VNC. Linux doesn’t recognize the USB tablet yet so Linux
guests under VNC will still need the Summagraphics emulation.
Details about mouse emulation are provided in sechiagh3.

localtime Set the real time clock to local time [default=0, that is, set to
UTC].

soundhw  Enable sound card support and specify the hardware totemula
Values can be sb16, es1370 or all. Default is none.

full-screen  Start in full screen.

nographic  Another way to redirect serial output. If enabled, no 'sdi/mc’
can work. Not recommended.

A.3 Creating virtual disks from scratch

A.3.1 Using physical disks

If you are using a physical disk or physical disk partition, you need tiailngs Linux
OS on the disk first. Then the boot loader should be installed in the cotese. g-or
exampledev/sda for booting from the whole disk, ddev/sdal for booting from
partition 1.

A.3.2 Using disk image files

You need to create a large empty disk image file first; then, you need to insialla L
OS onto it. There are two methods you can choose. One is directly installinggt us
a HVM guest while booting from the OS installation CD-ROM. The other is capyin
an installed OS into it. The boot loader will also need to be installed.
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To create the image file:

The image size should be big enough to accommodate the entire OS. This example
assumes the size is 1G (which is probably too small for most OSes).

# dd if=/dev/zero of=hd.img bs=1M count=0 seek=1024

To directly install Linux OS into an image file using a HVM guest:

Install Xen and create HVM with the original image file with booting from CD-ROM
Then it is just like a normal Linux OS installation. The HVM configuration filewldo
have a stanza for the CD-ROM as well as a boot device specification:

disk=['file:/var/images/your-hd.img,hda,w’, ’,hdc:cd rom,r' ] boot="d’

If this method does not succeed, you can choose the following method yihgogn
installed Linux OS into an image file.

To copy a installed OS into an image file:

Directly installing is an easier way to make partitions and install an OS in a disk image
file. But if you want to create a specific OS in your disk image, then you willtmos
likely want to use this method.

1. Install a normal Linux OS on the host machine
You can choose any way to install Linux, such as using yum to install Réd Ha
Linux or YAST to install Novell SUSE Linux. The rest of this example assumes
the Linux OS is installed iftvar/guestos/

2. Make the partition table
The image file will be treated as hard disk, so you should make the partition
table in the image file. For example:

# losetup /dev/loopO hd.img

# fdisk -b 512 -C 4096 -H 16 -S 32 /dev/loopO

press 'n’ to add new partition

press 'p’ to choose primary partition

press '1’ to set partition number

press "Enter" keys to choose default value of "First Cylinde r' parameter.
press "Enter" keys to choose default value of "Last Cylinder " parameter.
press 'w' to write partition table and exit

# losetup -d /dev/loop0O

3. Make the file system and install grub
# In -s /dev/loopO /dev/loop
# losetup /dev/loop0 hd.img
# losetup -0 16384 /dev/loopl hd.img
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mkfs.ext3 /dev/loopl

mount /dev/loopl /mnt

mkdir -p /mnt/boot/grub

cp /boot/grub/stage * [boot/grub/e2fs _stagel 5 /mnt/boot/grub

umount /mnt

H O OH ¥ OH ¥ OH

grub

grub> device (hd0) /dev/loop
grub> root (hd0,0)

grub> setup (hdO)

grub> quit

# rm /dev/loop

# losetup -d /dev/loop0O

# losetup -d /dev/loopl

Thelosetup option-o 16384 skips the partition table in the image file. It
is the number of sectors times 512. We néd=l/loop  because grub is ex-
pecting a disk deviceame wherenamerepresents the entire disk andmel
represents the first partition.

4. Copy the OS files to the image
If you have Xen installed, you can easily usmount instead ofosetup and
mount when coping files to some partitionemount just needs the partition
information.

# lomount -t ext3 -diskimage hd.img -partition 1 /mnt/guest
# cp -ax /var/guestos/ {root,dev,var,etc,usr,bin,sbin,lib } /mnt/guest

# mkdir /mnt/guest/ {proc,sys,home,tmp  }

5. Edit the /etc/fstab of the guest image
The fstab should look like this:

# vim /mnt/guest/etc/fstab

/dev/hdal / ext3 defaults 1 1

none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 O

none /proc proc defaults 0 0

none /sys sysfs efaults 0 O

6. umount the image file
# umount /mnt/guest

Now, the guest OS imadw®l.img is ready. You can also refereniagp://free.oszoo.org
for quickstart images. But make sure to install the boot loader.

92



A.4 HVM Guests

A.4.1 Editing the Xen HVM config file

Make a copy of the example HVM configuration fiketc/xen/xmexample.hvm
and edit the line that reads

disk = [ ‘file:/var/images/ nm n-el 3-i 386. i ng,hda,w’ ]

replacingmin-el3-i386.imgwith the name of the guest OS image file you just made.

A.4.2 Creating HVM guests

Simply follow the usual method of creating the guest, providing the filenamewf yo
HVM configuration file:

# xend start
# xm create /etc/xen/hvmguest.hvm

In the default configuration, VNC is on and SDL is off. Therefore VNiaows will
open when HVM guests are created. If you want to use SDL to create blyédts, set
sdl=1 in your HVM configuration file. You can also turn off VNC by settingc=0 .

A.4.3 Mouse issues, especially under VNC

Mouse handling when using VNC is a little problematic. The problem is that the VNC
viewer provides a virtual pointer which is located at an absolute location W@
window and only absolute coordinates are provided. The HVM device haodgerts
these absolute mouse coordinates into the relative motion deltas that areedxXpec
the PS/2 mouse driver running in the guest. Unfortunately, it is impossiblegjp ke
these generated mouse deltas accurate enough for the guest cursacttp match

the VNC pointer. This can lead to situations where the guest’s cursor is irettierc

of the screen and there’s no way to move that cursor to the left (it cgrehapat the
VNC pointer is at the left edge of the screen and, therefore, theredomger any left
mouse deltas that can be provided by the device model emulation code.)

To deal with these mouse issues there are 4 different mouse emulationblaviaden
the HVM device model:

PS/2 mouse over the PS/2 portThis is the default mouse that works perfectly well
under SDL. Under VNC the guest cursor will get out of sync with the VNC
pointer. When this happens you can re-synchronize the guest tortberVNC
pointer by holding down thkeft-ctl andleft-alt keys together. While these keys
are down VNC pointer motions will not be reported to the guest so that the
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VNC pointer can be moved to a place where it is possible to move the guest
cursor again.

Summagraphics mouse over the serial port.The device model also provides emu-
lation for a Summagraphics tablet, an absolute pointer device. This emulation
is provided over the second serial pddev/ttyS1for Linux guests an€COM2
for Windows guests. Unfortunately, neither Linux nor Windows provides
fault support for the Summagraphics tablet so the guest will have to beathanu
configured for this mouse.

Linux configuration.

First, configure the GPM service to use the Summagraphics tablet. Thisrgan va
between distributions but, typically, all that needs to be done is modify the file
letc/sysconfig/mouse to contain the lines:

MOUSETYPE="summa"

XMOUSETYPE="SUMMA"
DEVICE=/dev/ttyS1

and then restart the GPM daemon.

Next, modify the X11 configetc/X11/xorg.conf to support the Summ-
graphics tablet by replacing the input device stanza with the following:

Section "InputDevice"
Identifier "Mouse0"
Driver "summa"
Option "Device" "/dev/ttyS1"
Option "InputFashion" "Tablet"
Option "Mode" "Absolute"
Option "Name" "EasyPen"
Option "Compatible" "True"
Option "Protocol" "Auto"
Option "SendCoreEvents" "on"
Option "Vendor" "GENIUS"
EndSection

Restart X and the X cursor should now properly track the VNC pointer.
Windows configuration.

Get the filehttp://www.cad-plan.deffiles/download/tw2k.exe and
execute that file on the guest, answering the questions as follows:

1. When the program asks forodel, scroll down and sele@ummaSketch
(MM Compatible) .

2. When the program asks f@OM Port specifycom2
3. When the programs asks fo€arrsor Type specify4 button cursor/puck.

94



4. The guest system will then reboot and, when it comes back up, tlst gue
cursor will now properly track the VNC pointer.

PS/2 mouse over USB port.This is just the same PS/2 emulation except it is pro-
vided over a USB port. This emulation is enabled by the configuration flag:

usbdevice="mouse’

USB tablet over USB port. The USB tablet is an absolute pointing device that has
the advantage that it is automatically supported under Windows guests,giithou
Linux guests still require some manual configuration. This mouse emulation is
enabled by the configuration flag:

usbdevice="tablet’
Linux configuration.

Unfortunately, there is no GPM support for the USB tablet at this point in time.
If you intend to use a GPM pointing device under VNC you should configure
the guest for Summagraphics emulation.

Support for X11 is available by following the instructions at
http://stz-softwaretechnik.com/"ke/touchscreen/evto uch.html
with one minor change. Theorg.conf  given in those instructions uses the
wrong values for the X & Y minimums and maximums, use the following con-
fig stanza instead:

Section "InputDevice"

Identifier "Tablet"

Driver "evtouch"

Option "Device" "/dev/input/event2"

Option "DeviceName" "touchscreen"

Option "MinX" "0"

Option "MinY" "0"

Option "MaxX" "32256"

Option "MaxyY" "32256"

Option "ReportingMode” "Raw"

Option "Emulate3Buttons”

Option "Emulate3Timeout" "50"

Option "SendCoreEvents" "On"
EndSection

Windows configuration.

Just enabling the USB tablet in the guest’s configuration file is sufficient; Win
dows will automatically recognize and configure device drivers for thiistjmg
device.

95



A.4.4 USB Support

There is support for an emulated USB mouse, an emulated USB tablet asidghy
low speed USB devices (support for high speed USB 2.0 devices is sdidirutevel-
opment).

USB PS/2 style mouseDetails on the USB mouse emulation are given in sections
A.2 andA.4.3. Enabling USB PS/2 style mouse emulation is just a matter of
adding the line

usbdevice="mouse’
to the configuration file.

USB tablet. Details on the USB tablet emulation are given in sectidirisandA.4.3.
Enabling USB tablet emulation is just a matter of adding the line

usbdevice="tablet’
to the configuration file.
USB physical devices.Access to a physical (low speed) USB device is enabled by
adding a line of the form
usbdevice="host:vid:pid’
into the the configuration filé.vid andpid are a product id and vendor id that
uniquely identify the USB device. These ids can be identified in two ways:

1. Through the control window. As described in sectid.6 the control
window is activated by pressingl-alt-2 in the guest VGA window. As
long as USB support is enabled in the guest by including the config file
line

usb=1
then executing the command
info usbhost

in the control window will display a list of all usb devices and their ids.
For example, this output:

Device 1.3, speed 1.5 Mb/s
Class 00: USB device 04b3:310b

was created from a USB mouse with vendof#b3and product idB10h.
This device could be made available to the HVM guest by including the
config file entry

usbdevice="host:04be:310b’

There is an alternate way of specifying a USB device that uses the syastbus.addr but this
syntax suffers from a major problem that makes it effectively usel@$e problem is that thaddr
portion of this address changes every time the USB device is plugged intystem. For this reason
this addressing scheme is not recommended and will not be docunieritest.
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It is also possible to enable access to a USB device dynamically through
the control window. The control window command

usb_add host:vid:pid

will also allow access to a USB device with vendowid and product id
pid.
2. Through thdproc file system. The contents of the pseudo/filec/bus/usb/devices
can also be used to identify vendor and product ids. Looking at this file,
the line starting withP: has a field/endor giving the vendor id and another

field ProdID giving the productid. The contents/pfoc/bus/usb/devices
for the example mouse is as follows:

T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 3 Spd=1.5 MxCh =0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1

P:  Vendor=04b3 ProdID=310b Rev= 1.60

C:+ #lfs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 1 ClIs=03(HID ) Sub=01 Prot=02 Driver=(n one)
E: Ad=81(l) Atr=03(Int.) MxPS= 4 Ivl=10ms

Note that theP: line correctly identifies the vendor id and product id for
this mouse a®4b3:310b

There is one other issue to be aware of when accessing a physical &¥&® d
from the guest. The DomO kernel must not have a device driver loamdtd
device that the guest wishes to access. This means that the DomO kerbel mus
not have that device driver compiled into the kernel or, if using modules, th
driver module must not be loaded. Note that this is the device specific USB
driver that must not be loaded, either t4elCl or OHCI USB controller driver

must still be loaded.

Going back to the USB mouse as an examplisrifod gives the output:

Module Size Used by
usbmouse 4128 O
usbhid 28996 0
uhci_hcd 35409 0

then the USB mouse is being used by the DomO0 kernel and is not available to
the guest. Executing the commamamod usbhid? will remove the USB mouse
driver from the DomO kernel and the mouse will now be accessible by thd HV
guest.

Be aware the the Linux USB hotplug system will reload the drivers if a USB
device is removed and plugged back in. This means that just unloading the
driver module might not be sufficient if the USB device is removed andcdde
back. A more reliable technique is to firshmod the driver and then rename

2Turns out theusbhid driver is the significant one for the USB mouse, the presence or edsétthe
moduleusbmousehas no effect on whether or not the guest can see a USB mouse.
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the driver file in thelib/modules directory, just to make sure it doesn't get
reloaded.

A.4.5 Destroy HVM guests

HVM guests can be destroyed in the same way as can paravirtualized. gifésts
recommend that you shut-down the guest using the guest OS’ providedanéobin
Linux, type the command

poweroff

in the HVM guest’s console, for Windows use Start -¢, Shutdown firstdegnmt data
loss. Depending on the configuration the guest will be automatically dedirotreer-
wise execute the command

xm destroy vnx_guest . d

at the DomainO console.

A.4.6 HVM window (X or VNC) Hot Key

If you are running in the X environment after creating a HVM guest, an Xdamis
created. There are several hot keys for control of the HVM guestddin be used in
the window.

Ctrl+Alt+2 switches from guest VGA window to the control window. Typihgp
shows the control commands help. For example, 'q’ is the command to desé&oy th
HVM guest.

Ctrl+Alt+1 switches back to HVM guest’s VGA.

Ctrl+Alt+3 switches to serial port output. It captures serial output from the HVM
guest. It works only if the HVM guest was configured to use the seridl po
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Appendix B

Vnets - Domain Virtual
Networking

Xen optionally supports virtual networking for domains usimgets These emulate
private LANs that domains can use. Domains on the same vnet can be bogtesl
same machine or on separate machines, and the vnets remain connectedisdoma
are migrated. Ethernet traffic on a vnet is tunneled inside IP packets quhyisecal
network. A vnet is a virtual network and addressing within it need haveladion to
addressing on the underlying physical network. Separate vnetsets &nd the phys-

ical network, can be connected using domains with more than one networfadete
and enabling IP forwarding or bridging in the usual way.

Vnet support is included iRmand xend:
# xm vnet-create <config>

creates a vnet using the configuration in the fitonfig> . When a vnet is created
its configuration is stored by xend and the vnet persists until it is deleted usin

# xm vnet-delete <vnetid>
The vnets xend knows about are listed by
# xm vnet-list

More vnet management commands are available usingrthieol included in the vnet
distribution.

The format of a vnet configuration file is

(vnet (id <vnetid>)
(bridge <bridge>)
(vnetif ~ <vnet interface>)
(security <level>))

White space is not significant. The parameters are:
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e <vnetid> : vnetid, the 128-bit vnet identifier. This can be given as 8 4-digit
hex numbers separated by colons, or in short form as a single 4-digitineber.
The short form is the same as the long form with the first 7 fields zero. idaet
must be non-zero and id 1 is reserved.

e <bridge> : the name of a bridge interface to create for the vnet. Domains are
connected to the vnet by connecting their virtual interfaces to the bridiggd3
names are limited to 14 characters by the kernel.

e <vnetif> : the name of the virtual interface onto the vnet (optional). The in-
terface encapsulates and decapsulates vnet traffic for the netwbikattached
to the vnet bridge. Interface names are limited to 14 characters by thd.kerne

e <level> : security level for the vnet (optional). The level may be one of
— none: no security (default). Vnet traffic is in clear on the network.

— auth : authentication. Vnet traffic is authenticated using IPSEC ESP with
hmac96.

— conf : confidentiality. Vnet traffic is authenticated and encrypted using
IPSEC ESP with hmac96 and AES-128.

Authentication and confidentiality are experimental and use hard-wiresldtey
present.

When a vnet is created its configuration is stored by xend and the vrestganntil
it is deleted usingm vnet-delete <vnetid> . The interfaces and bridges used
by vnets are visible in the output d€onfig andbrctl show

B.1 Example

If the file vnet97.sxp  contains

(vnet (id 97) (bridge vnet97) (vnetif vnif97)
(security none))

Thenxm vnet-create vnet97.sxp will define a vnet with id 97 and no secu-
rity. The bridge for the vnet is called vnet97 and the virtual interface fisr vnif97.
To add an interface on a domain to this vnet set its bridge to vnet97 in its cratfayu

In Python:

vif="bridge=vnet97"
In sxp:
(dev (vif (mac aa:00:00:01:02:03) (bridge vnet97)))

Once the domain is started you should see its interface in the outprttbfshow
under the ports fovnet97 .
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To get best performance it is a good idea to reduce the MTU of a domaiaifaoe
onto a vnet to 1400. For example usiiigonfig ethO mtu 1400 or putting
MTU=1400in ifcfg-ethO . You may also have to change or remove cached config
files for ethO underetc/sysconfig/networking . Vnets work anyway, but
performance can be reduced by IP fragmentation caused by the \cegiseation
exceeding the hardware MTU.

B.2 Installing vnet support

Vnets are implemented using a kernel module, which needs to be loaded trefgr
can be used. You can either do this manually before starting xend, usirogitie
mandvn insmod , or configure xend to use thetwork-vnet  script in the xend
configuration fileetc/xend/xend-config.sxp

(network-script network-vnet)
This script insmods the module and calls tegéwork-bridge script.

The vnet code is not compiled and installed by default. To compile the code and
install on the current system usgake install in the root of the vnet source tree,
tools/ivnet . It is also possible to install to an installation directory usingke

dist . See theMakefile in the source for details.

The vnet module creates vnet interfageff0002 , vnif0OO03 andvnif0004 by
default. You can test that vnets are working by configuring IP addsesa these
interfaces and trying to ping them across the network. For example, usicigmea
hostA and hostB:

hostA# ifconfig vnif0004 192.0.2.100 up
hostB# ifconfig vnif0004 192.0.2.101 up
hostB# ping 192.0.2.100

The vnet implementation uses IP multicast to discover vnet interfaces, sochlimaa
hosting vnets must be reachable by multicast. Network switches are oftégured
not to forward multicast packets, so this often means that all machines usingt a
must be on the same LAN segment, unless you configure vnet forwarding.

You can test multicast coverage by pinging the vnet multicast address:
# ping -b 224.10.0.1

You should see replies from all machines with the vnet module running. absee
if vnet packets are being sent or received by dumping traffic on thelid® port:

# tcpdump udp port 1798

If multicast is not being forwarded between machines you can configuitcesi
forwarding using vn. Suppose we have machines hostA on 192.0.2.20@oatB on
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192.0.2.211 and that multicast is not forwarded between them. We use vnfigLre
each machine to forward to the other:

hostA# vn peer-add hostB
hostB# vn peer-add hostA

Multicast forwarding needs to be used carefully - you must avoid creé&dimgarding
loops. Typically only one machine on a subnet needs to be configurediarth as it
will forward multicasts received from other machines on the subnet.
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Appendix C

Glossary of Terms

Domain A domain is the execution context that contains a runminmial machine.
The relationship between virtual machines and domains on Xen is similar to
that between programs and processes in an operating system: a virtléhenac
is a persistent entity that resides on disk (somewhat like a program). Wisen it
loaded for execution, it runs in a domain. Each domain hdmnaain ID.

Domain 0 The first domain to be started on a Xen machine. Domain 0 is responsible
for managing the system.

Domain ID A unique identifier for alomain, analogous to a process ID in an operat-
ing system.

Full virtualization An approach to virtualization which requires no modifications to
the hosted operating system, providing the illusion of a complete system of real
hardware devices.

Hypervisor An alternative term foMM , used because it means ‘beyond supervi-
sor’, since it is responsible for managing multiple ‘supervisor’ kernels.

Live migration A technique for moving a running virtual machine to another physical
host, without stopping it or the services running on it.

Paravirtualization An approach to virtualization which requires modifications to the
operating system in order to run in a virtual machine. Xen uses paravidaualiz
tion but preserves binary compatibility for user space applications.

Shadow pagetablesA technique for hiding the layout of machine memory from a
virtual machine’s operating system. Used in soMMs to provide the illusion
of contiguous physical memory, in Xen this is used duting migration.

Virtual Block Device Persistent storage available to a virtual machine, providing the
abstraction of an actual block storage devis#8Ds may be actual block de-
vices, filesystem images, or remote/network storage.

Virtual Machine The environment in which a hosted operating system runs, provid-
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ing the abstraction of a dedicated machine. A virtual machine may be identical
to the underlying hardware (asfill virtualization , or it may differ, as irpar-
avirtualization).

VMM Virtual Machine Monitor - the software that allows multiple virtual machines
to be multiplexed on a single physical machine.

Xen Xen is a paravirtualizing virtual machine monitor, developed primarily by the
Systems Research Group at the University of Cambridge Computer ltakyora

XenLinux A name for the port of the Linux kernel that runs on Xen.
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